9
  • I use SO daily (indeed hourly during business hours)

  • I visit a few other SE sites occasionally (eg aviation, space etc)

  • Since about, say, 3-4 weeks ago, I am logged out often as much as a few times a day and if not, then after say about 36 hrs (ie when a clear 24 hr period has passed)

  • Occasionally (say, once every week or two) it will be good for a longer period of time (say 3-4 days, then logged out)

  • As I say since 3-4 weeks ago, but, the same behavior has happened occasionally (say, for "a week or two at a time") since, call it this year

  • I use the "traditional" email/pass login

  • I use both macs & pcs for work, in all cases only with the latest OS, 95% of access is from macs, very rare pc access

  • on mac i use safari 99% of the time for SO access (it's possible I very rarely, ie less than once a month, use another browser). on pc I use only the msft supplied browser, whatever it is now named

  • I never connect using a phone/pad. I never use the SO app(s)

  • I do have two completely different fiber connections to this building. I generally but not always stick to the ATT one fwiw. I never use cellular to connect to SO

  • I have not noticed the behavior on any other sites I frequent (which are few, eg banking, my agent, wikipedia, etc, I'm not an internet user) (Actually, i specifically use a different browser ("brave," for the stupid name :) ) for any very rare general otaka web browsing.)

  • I think but I'm not certain this behavior began, at the time, SO started offering or slightly changed the way that is offered google login (or some other option, i don't pay attention but the log in offerings page has, I think, changed somewhat say within the last year)

  • I'm obviously a programmer but I work almost not at all with www/browsers, I'm a very naive www user so I can't offer much guesses

  • Anecdotally, when mentioned to colleagues etc. I get a few "yeah what's up with SO" comments; but no pattern. Right off the top of my head I'd guess it is a Mac thing, but, dunno. Another possibility is that I often swap around between various computers, and as mentioned possibly swap IPs/networks. (However, I have done exactly that for 10+ years consistently and identically and this is new behavior.) I don't immediately see a wave of similar reports on meta, so, of course, it's entirely possible it is some obscure issue or even mistake on my part; fwiw the (unlike me!) experts who look after my macs/etc haven't been able to find a cause.

Obviously this causes me no drama, I just stick my pretty index finger-tip on the reader and away it goes again, back to arguing about ux, but I just thought I'd report it in an idle moment.

Hope it helps!!!

PS it's always a bit weird putting bug reports on here; ie this is "A message to staff" I suppose, not "chat with free volunteers" so hopefully this didn't waste any time of free volunteers!! (As I understand it there is no bug reporting facility, as such, you just use meta.)


cookie info ..

enter image description here

18
  • 5
    Yes, something is going on. I have been logged out few times myself in the last few months (last time it was today morning). Before I would have been logged on for years. Commented Jun 25 at 13:03
  • @DalijaPrasnikar ; sorry for the time waste! Funny thing though; now that you mention it, I'm actually pretty sure it only happens on SO. (I can't now remember it happening on the few other sites I very occasionally visit, "worldbuilding" and such.) I'll keep an eye out! For now if asked I would say "only on SO" - ! Scary!
    – Fattie
    Commented Jun 25 at 13:10
  • 1
    Yes, I 100% agree with your first comment above, that is in general exactly my experience. Again I think the behavior began at the time "google sso etc" was added, but I'm not sure.
    – Fattie
    Commented Jun 25 at 13:11
  • 3
    I am almost certain that Google login had something to do with it. My problems started right after they introduced it. I know as I was following main Meta posts around it. Commented Jun 25 at 13:13
  • 4
    MSE dupe closed into this one (preserving this one as primary - contains more in-depth info): meta.stackexchange.com/questions/400482/…
    – Slate StaffMod
    Commented Jun 25 at 14:33
  • @Slate how are you, just to be aware, I am say 50% sure this only happens on SO. Just FYI ! I Hate Bugs eh :) As I mention I have little interest/expertise in WWW so I can't give any better info or guesses or repro cases - sorry!!!
    – Fattie
    Commented Jun 25 at 15:12
  • 1
    Same experience, except... Non-SO network sites, PC only, using Google for auth. I've had very occasional issues going back a longer time frame but it's more frequent recently. 7 times so far over the last two months including one time where it was twice in a day. Commented Jun 25 at 17:21
  • This QA is becoming thrilling !
    – Fattie
    Commented Jun 25 at 18:54
  • I was just logged out LOL
    – Fattie
    Commented Jun 26 at 17:13
  • @Slate - might be important - I was just logged out ("as usual"). It occured to me that each (most/every?) time I am incorrectly logged out and face the login-screen, additionally, IT SHOWS THE YOU MUST ACCEPT COOKIES panel Could be relevant?
    – Fattie
    Commented Jun 26 at 17:14
  • @Fattie That sure makes it sound like something is wiping your cookies. Most of the time when this happens it's due to a local issue, e.g. a browser extension. But I won't discount the possibility that something on our side is causing it.
    – Slate StaffMod
    Commented Jun 26 at 17:24
  • @Slate - roger, I will check that. it's pretty unlikely but sure, checking! I just logged in to say I was logged out again straight after, heh
    – Fattie
    Commented Jun 26 at 17:42
  • note - right now I AM LOGGED IN but I DO SEE the "accept cookies" panel, bottom left of screen
    – Fattie
    Commented Jun 26 at 17:43
  • @Slate added an image showing some settings cheers. dunnoif it helps
    – Fattie
    Commented Jun 26 at 17:49
  • 1
    cheers @cart absolutely not experienced on any other sites, unfortunately! FWIW () seen on various macs including brand new ones () as mentioned I less often monkey on Windows but have seen it there too (for example I was on a clients' virtual pc (ie using rdc from mine) and I happened to be checking something on SO, on that remote pc, since I was logged in, and it happened, it logged me out! heh!) () I was aware of that "developer menu mess" on mac when it happened () I've checked endlessly (since I use SO so much!) the various obvious settings, are cookies disabled etc, indeed on many mac
    – Fattie
    Commented Jul 1 at 12:17

0

You must log in to answer this question.

Browse other questions tagged .