9

I mistakenly told a new user that their post was not supposed to be here. I messed up. The user self deleted, which while in their credit, is because I made a mistake. This isn't fair

I'd like to make amends by flagging it for moderation attention - and when I click the flag button I get an error

Interestingly, I also get the same console error if I click on an unread inbox item - it opens but dosen't mark read unless I click on the mail icon specifically. I have the same issue on another computer, on another ISP - but the error on the console turns up and immediately vanishes.

enter image description here

This is the error on the page

enter image description here

Console output as text when I trigger this with the inbox reads as

 full.en.js?v=ba76f8465c35:1 
        
        
       POST https://meta.stackexchange.com/topbar/mark-inbox-as-read net::ERR_BLOCKED_BY_CLIENT
clickSendMarkAsReadBeacon @ full.en.js?v=ba76f8465c35:1
(anonymous) @ full.en.js?v=ba76f8465c35:1
dispatch @ jquery.min.js:3
r.handle @ jquery.min.js:3
full.en.js?v=ba76f8465c35:1 
        
        
       POST https://meta.stackexchange.com/gps/event net::ERR_BLOCKED_BY_CLIENT
(anonymous) @ full.en.js?v=ba76f8465c35:1
s @ full.en.js?v=ba76f8465c35:1
i @ full.en.js?v=ba76f8465c35:1
(anonymous) @ full.en.js?v=ba76f8465c35:1
e @ jquery.min.js:3
dispatch @ jquery.min.js:3
r.handle @ jquery.min.js:3

I've tried this on a clean copy of chrome, turned off my adblocker on vivaldi, and can generally replicate it. I also run a network wide adblocker but I don't see any blocks specific to the time of test.

This is the ublock origin log around when I tried to replicate this with the inbox bug

Logger output
+3 meta.stackexchange.com 3 get xhr https://cdn.cookielaw.org/logos/static/ot_guard_logo.svg
+3 meta.stackexchange.com 3 get xhr https://cdn.cookielaw.org/scripttemplates/202312.1.0/assets/otCommonStyles.css
+3 meta.stackexchange.com 3 get xhr https://cdn.cookielaw.org/scripttemplates/202312.1.0/assets/v2/otPcCenter.json
+3 meta.stackexchange.com 3 get xhr https://cdn.cookielaw.org/scripttemplates/202312.1.0/assets/otFloatingRoundedCorner.json
+3 meta.stackexchange.com 3 get xhr https://cdn.cookielaw.org/consent/cb0f3c87-b769-4e66-bbaa-377f9194216d/018f2f76-a777-7516-9013-d62aa1453fd3/en.json
+3 meta.stackexchange.com 1 get xhr https://meta.stackexchange.com/posts/401151/ivc/6fab?prg=5d612102-c7c2-4ac0-aaba-8a305d603478&_=1720137010578
+3 meta.stackexchange.com 1 get websocket wss://qa.sockets.stackexchange.com/
+3 meta.stackexchange.com 1 get xhr https://meta.stackexchange.com/posts/401151/comments?_=1720137010577
+3 meta.stackexchange.com 3 get xhr https://cdn.cookielaw.org/consent/cb0f3c87-b769-4e66-bbaa-377f9194216d/cb0f3c87-b769-4e66-bbaa-377f9194216d.json
+3 google-analytics_analytics.js:5 << meta.stackexchange.com 3 get script https://www.google-analytics.com/analytics.js
+3 ||google-analytics.com/analytics.js$script,redirect-rule=google-analytics_analytics.js:5 -- meta.stackexchange.com 3 get script https://www.google-analytics.com/analytics.js
+3 ||google-analytics.com^ -- meta.stackexchange.com 3 get script https://www.google-analytics.com/analytics.js
+3 googletagmanager_gtm.js:5 << meta.stackexchange.com 3 get script https://www.googletagmanager.com/gtag/js?id=G-S812YQPLT2
+3 ||googletagmanager.com/gtag/js$script,redirect-rule=googletagmanager_gtm.js:5 -- meta.stackexchange.com 3 get script https://www.googletagmanager.com/gtag/js?id=G-S812YQPLT2
+3 ||googletagmanager.com^ -- meta.stackexchange.com 3 get script https://www.googletagmanager.com/gtag/js?id=G-S812YQPLT2
+3 meta.stackexchange.com 1 get doc https://meta.stackexchange.com/questions/401151/flagging-deleted-post-or-clicking-on-inbox-item-fails-and-brings-up-an-error-500?noredirect=1#comment1338353_401151
+2 meta.stackexchange.com 1 get doc https://meta.stackexchange.com/posts/comments/1338353?noredirect=1
+2 meta.stackexchange.com 1 post ping https://meta.stackexchange.com/gps/event
+2 meta.stackexchange.com 1 post ping https://meta.stackexchange.com/topbar/mark-inbox-as-read
+0 meta.stackexchange.com 1 post xhr https://meta.stackexchange.com/posts/validate-body
+0 meta.stackexchange.com 1 get image https://meta.stackexchange.com/Content/Img/progress-dots.gif
+0 meta.stackexchange.com 1 get xhr https://meta.stackexchange.com/topbar/inbox?_=1720136904008

A quick inspection seems to suggest its not it, though since it happens on my phone, I think I'd be able to rule that out.

18
  • 1
    Is the error when you submit the flag? Or when you choose modflag option in the dialog?
    – VLAZ
    Commented Jul 4 at 15:01
  • When I click the flag button, I'll update Commented Jul 4 at 15:03
  • 3
    Hmm, no repro on my side. So, it might be related to your account. But the "ERR_BLOCKED_BY_CLIENT" makes me think it might be browser-related. See if disabling some addons might help. My first guess would be adblocking addons.
    – VLAZ
    Commented Jul 4 at 15:07
  • 1
    I can't reproduce on another site (where I have 10k reputation) - can you try what happens on e.g. HardwareRecs?
    – Glorfindel Mod
    Commented Jul 4 at 15:10
  • Can reproduce on a vanilla copy of chrome. I'll need to find a deleted post on hardware recs.. Commented Jul 4 at 15:17
  • on the 'bright' side - other than 'one' time when it worked, I can repro at will Commented Jul 4 at 15:25
  • Got the same thing, randomly, possibly for the inbox / marking read on clicking too i.sstatic.net/KnvWgvNG.png I'll go poke at my PC further in the morning ._. Commented Jul 4 at 15:31
  • 1
    So it's the inverse of "works on my machine"? :P
    – Glorfindel Mod
    Commented Jul 4 at 16:14
  • Seems so, or there's some part of my admittedly multilayered adblock and very unique environment that's suddenly triggering this off. The only changes I made recently were a dumb switch and MAYBE running 2 ethernet connections... Commented Jul 4 at 16:22
  • i.sstatic.net/JphUzb92.png can repro the inbox clicking issue on super user Commented Jul 4 at 16:28
  • 3
    @Glorfindel I believe that's called cursed :D Commented Jul 4 at 16:32
  • "Cursed on my machine" :P
    – VLAZ
    Commented Jul 4 at 16:33
  • 2
    .... Can repro on my phone... So just cursed, and the phone has neither AdBlock options my main system has Commented Jul 4 at 16:34
  • 2
    I raise flags on deleted posts on a irregular basis, both through the normal SE website endpoints and SE API. I have not experienced this issue (i.e., it's worked fine for me).It has worked every time I've done it over the last few/several years, including just now. In other words, doing this is something that normally works fine and just worked for me.
    – Makyen
    Commented Jul 4 at 17:37
  • @Makyen or you could just say you can't reproduce it... ;) Anyway, no repro here, I just flagged a deleted post, and it went through just fine. (including retracting the flag.) Commented Jul 4 at 18:24

0

You must log in to answer this question.

Browse other questions tagged .