6

Possible Duplicate:
Answer Only RSS feed for a user

I tried to get feed of the top rankers.
But there were too many feeds(because of their comments feed)
It's annoying me.

I want to get feeds of their answer.
Is it possible?

6
  • Discussions about stackoverflow should be done at meta.stackoverflow.com
    – Dan
    Mar 26 '10 at 15:38
  • I think you should ask this question here: meta.stackoverflow.com?
    – rochal
    Mar 26 '10 at 15:38
  • haha Dan, you're 2sec quicker ;-)
    – rochal
    Mar 26 '10 at 15:39
  • I don't understand what you mean; the user feed doesn't include comments.
    – balpha
    Mar 26 '10 at 15:49
  • It includes comments.
    – Benjamin
    Mar 26 '10 at 15:54
  • Oops, you're correct, they're just not in chronological order with the other posts.
    – balpha
    Mar 26 '10 at 15:59
3

This is possible using a small application I created called Stack2RSS that converts API requests into RSS feeds.

Example (shows all answers by Jon Skeet on Stack Overflow):

http://stack2rss.quickmediasolutions.com/2.2/users/22656/answers?site=stackoverflow

20
  • @George: It doesn't work since a couple of weeks ago. Your app make url like this. stackapps/questions/2439 .com is trimmed.
    – Benjamin
    Jun 11 '11 at 14:55
  • @Benjamin: There was an upgrade a couple of weeks ago. Can I please have the exact URL of the feed that is no longer working? Jun 11 '11 at 16:28
  • @George: quickmediasolutions.com/stack2rss/stackoverflow/users/17034/… The feed works fine. But when I click the feed title to jump real page(stackoverflow.com) in Google Reader, it jump to wrong URL.
    – Benjamin
    Jun 12 '11 at 1:27
  • @Benjamin: Ah, you're right. I'll get this fixed - in the meantime, you can change stackoverflow to stackoverflow.com to make it work. Jun 12 '11 at 1:58
  • @George: Anything works anymore. What happened?
    – Benjamin
    Jun 14 '11 at 11:55
  • @Benjamin: Sorry about that. It's working now. Jun 14 '11 at 16:10
  • @George: Everything is fine again. Thanks.
    – Benjamin
    Jun 15 '11 at 1:16
  • When I add more users now, I get No Content at my feed reader. I have to click the link and should jump SO to read the answers. But for the users I registered long time ago, the feed get the answer's all content. So I can read them at my google reader conveniently. Why is it?
    – Benjamin
    Jan 31 '12 at 2:49
  • @Benjamin: Can you please provide me with the URL for the feed you are using? Jan 31 '12 at 2:51
  • I have guessed what is the problem, though. It's the query string, right?
    – Benjamin
    Jan 31 '12 at 2:56
  • Your application added the query string body=true by default long time ago, but not anymore I think.
    – Benjamin
    Jan 31 '12 at 2:59
  • @Benjamin: I honestly can't remember if it used to add body=true or not. But it definitely does not add it now. You will need to explicitly add that parameter. Jan 31 '12 at 3:03
  • Okay fine. I know what the problem was now. I fixed all address missing query string. I'm using user app very well, everyday. Thank you.
    – Benjamin
    Jan 31 '12 at 3:05
0

This has been asked once before, but I don't see it having been responded to by an admin.

1

Not the answer you're looking for? Browse other questions tagged .