I recently created a MyOpenID to log into Stack Overflow. This login works on SO but not on Meta Stack Overflow. Why is this? This seems like it is a problem on MSO's side rather than MyOpenID's side.

When I attempt to log into MSO using MyOpenID, I end up being redirected to a blank page with a very long query string. The URL of the blank page is


Secondly, my Google login does not work. When I attempt to log into SO using my Google login, I end up seeing a blank page with a URL beginning with


I am using Firefox 3.6.3 and I can successfully log into SO using MyOpenID but not with MyOpenID onto MSO and not with Google onto SO.

Please note that I would prefer to use my Google login to log into SO. I only created the MyOpenID account to get to the root of the problem.

Stack Overflow should seriously consider giving users the option of having SO-specific credentials because for me — and I am sure countless others — this OpenID thing doesn't work.

(I know this should be posted on MSO, but that requires a working OpenID, which I do not have.)

  • This question belongs on meta.stackoverflow.com Apr 8, 2010 at 12:04
  • Migrate to MetaStackOverflow.com?
    – The Elite Gentleman
    Apr 8, 2010 at 12:04
  • Trusty old Google OpenIDs.
    – random
    Apr 8, 2010 at 12:15

3 Answers 3


I'm experiencing the same problem (attempting to authenticate shows a blank page). I did some investigating, and I think I know what is happening.

Short version:

Something (e.g. a router, firewall, Websense) is filtering packets that contain long URLs (like the ones stackoverflow uses to authenticate users).

Long Version

Using Wireshark, I discovered that no response packets are sent for any request with a very long URL (somewhere between 900-1100 characters, the length of the URL seems to vary based on browser or some other factors). The problem can be reproduced independently of stackoverflow by simply doing a Google search for a very long string (e.g. http://www.google.com/search?q=asdfasdf...[many more characters]...asdfasdf). However, if Google secure search (https) is used, the problem doesn't occur. This seems to indicate that something (possibly a firewall, router, or, more likely, Websense) is inspecting packets and rejecting ones that contain long URLs. The URLs of https traffic can't be inspected because the packet is encrypted, so the packets aren't filtered.

As long as you still have the cookie containing the authentication information, you won't see the problem, but if you log out, you won't be able to log in again. I noticed the problem because I was already logged into stackoverflow.com when my company activated Websense filtering, but I wasn't logged into meta.stackoverflow.com because I don't visit that site very often. When I tried to log in, I saw the blank page even though I was able to continue to use stackoverflow.com normally.

This appears to be a specific case of #1 in a related question.

  • thanks for the update. It is a very common troubleshooting step to look at something on your network which may be filtering long URLs -- the #1 item at meta.stackexchange.com/questions/1774/… Nov 4, 2010 at 20:10
  • Seems reasonable considering that another answerer said a change to Websense fixed the problem.
    – Pops
    Nov 4, 2010 at 22:00

I had the same problem for a long time and it was related to Websense. I sent this article to our security admin and he configured the Cisco router to stop truncating the long URLs, which was causing the OpenID authentication to fail.

From the documentation at: http://www.websense.com/content/support/library/deployctr/v762/dic_cisco_ios_conf_cmds.aspx

This was the problem:

ip urlfilter audit-trail

%URLF-6-URL_BLOCKED: Access denied URL ; client server This message is logged for each URL requested that is blocked by Websense software. The message includes the blocked URL, the source IP address/port number, and the destination IP address/port number. Long URLs are truncated to 300 bytes and then logged.


I have tried both google and myopenid at home and they work on http://stackoverflow.com and http://meta.stackoverflow.com

It would seem as though it is something specific on the network, i am on within my place of work. They have "web sense" blocking.

I will just have to try it again.

  • You can associate your SO and Meta accounts in the Accounts tab on your user profile.
    – Jon Seigel
    Apr 8, 2010 at 20:32

You must log in to answer this question.