I've spent a good 10 minutes looking for this question. The only one I found is this one which may be, at the cause level, the same. However, it was referring to a different search box, and it was never answered.

When searching for a word with an apostrophe, SO filters out the apostrophe. Thus a search for can't finds cant but does not find can't. I tried escaping it with backslash (can\'t), and I tried two apostrophes (can''t), and I tried quoting it ("can't") all to no avail. Is there a way to make this work? Is this a bug?

There is a work-around: use google to search SO instead. But that's not pretty.

Edit: If this is by-design, could the search engine be modified to ignore apostrophes in question titles, such that can't == cant?

2 Answers 2


I just checked on Super User and found that searching for "can't" some pages, after editing out the "can't", still show up. They just aren't highlighted.

To extend on that, note that URL slugs don't have apostrophes. If the search includes the URL (which from the above example it does) then I would assume apostrophes aren't an issue.

Other than that, I'd guess it's feature-by-design because they remove ' and " from queries.

  • Not sure what you mean about titles not having apostrophes. Titles do have apostrophes, but URLs don't. If the search only looked at URLs, then "can't" would get both "cant" and "can't". Ergo the search (on SO and Meta at least) seems to be looking at titles, and deciding that "can't" (in the title) != "cant" (in the de-apostrophe'd search string). It seems that if the search engine would de-apostrophe the titles it searched, this problem would go away. Commented Apr 9, 2010 at 18:28
  • Yes, the URL string doesn't have any apostrophes, that's what I meant.
    – Josh K
    Commented Apr 9, 2010 at 18:44
  • 4
    Apostrophe's shouldn't have any apostrophes. Commented Jul 8, 2010 at 3:52

After the latest search changes, we'll search any term in quotes as an exact match, including symbols such as apostrophes. For example, compare searching for "cant" vs "can't".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .