For some reason I am recently getting a lot of "An error has occurred - please retry your request" error while voting and other ajax things. This started about week or two ago.

I am using Windows Vista and Chrome.

I am also experiencing errors while editing posts and problems when posting comments.

It seems that this error occurs only with Google Chrome and not with Firefox. My chrome is version (45376) and Firefox is version 3.6.3.

  • 3
    Have you cleared your cached? – random Apr 17 '10 at 9:00
  • Well, I cleared cache. The error has not occurred at least yet. – Juha Syrjälä Apr 17 '10 at 9:26
  • 1
    This happens to me sometimes (quite rarely) when I try to post an answer using Google Chrome on Windows 7 x64. I type the answer and when I click post I get a 500 error page. I close the browser, reopen it, retype the answer and same thing happens. Impossible to post the answer to this particular question. If then I copy paste the url of the question into IE or FireFox, retype the answer, it works just fine. Then I go back to Chrome, navigate to the same question, try to edit the text, same I get 500 error again. It already happened to me a few times and it's quite annoying. – Darin Dimitrov Apr 17 '10 at 14:31
  • The error has occurred at least once after clearing the cache. – Juha Syrjälä Apr 18 '10 at 12:01
  • Clearing the cache didn't help. This error still occurs. – Juha Syrjälä May 3 '10 at 17:20
  • Juha - also try restarting your browser. I experienced this as also , and after restarting Chrome, all was well. – rlb.usa May 4 '10 at 15:32
  • @rlb.usa: restarting does not help. – Juha Syrjälä May 8 '10 at 10:06
  • thanks for the update. We're looking at ways to make the feedback better (see my answer for an example of that), but it's a bit low pri at the moment. – Jeff Atwood May 8 '10 at 10:08
  • @Jeff, I just tried and the fix didn't work for me. I got this error again: stackoverflow.com/error?aspxerrorpath=/posts/2252674/… (XSRF validation: Request form value 'fkey' did not match CurrentUser.XSRFFormValue) – Juha Syrjälä May 17 '10 at 15:41

Can you provide steps to reproduce the problem?

edit: I added the actual error message to the HTML of the error page in an HTML comment. View source on the error page and look for:

Actual error:
This is a test exception generated by SimpleErrorHandler 
1.0.3764.33883. Please disregard.

So, provide me that. I suspect this is XSRF stuff you guys are running afoul of, as we suppress all those "errors".. they're caused by networking problems 99% of the time.

edit: We did find a small bug that might have caused this in rare circumstances, for users who tend to switch IP addresses rapidly. Let us know if it's any better after today (May 14 '10).

  • It's about time you added an error code! – Earlz May 4 '10 at 17:59
  • do not have prepro steps yet, but this occurs only with chrome, not with firefox. – Juha Syrjälä May 8 '10 at 10:05
  • The May 14 fix did not work for me. I am still getting the same error. – Juha Syrjälä May 17 '10 at 15:35
  • @juha then AFAIK your internet connection to us is a bit busted :( – Jeff Atwood Jun 2 '10 at 22:12
  • BTW I can't get this to work with IE 11, so I just use Chrome. I could send you a fiddler trace if you like. I suspect it's an issue inside our domain. – RickAndMSFT Jan 22 '14 at 3:40

I visit SO almost exclusively on Windows/Chrome, and I cannot reproduce nor do I recall seeing anything like this very frequently. If you see it beginning to happen more, open up a network monitor and see what scripts/requests are failing, and where - that will help diagnose the issue real quick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .