I am getting quite a lot of Oops! Something Bad Happened! while editing existing posts. It seems to occur only when trying to update posts, not when creating a new one. It seems to occur when I first create a new post, then immediately after saving click the "edit" link to change it again, and then try to save those changes.

One example of error page URL: https://stackoverflow.com/error?aspxerrorpath=/posts/2662048/edit-submit/32cc6a03-b1e3-4146-a382-679e32ab67e6

If I press the back button and try to submit again, I get the same error again. If I go back to answer list and refresh the page, the editing works.

I am using Windows Vista and Google Chrome. This does not happen every time, but often enough to be annoying. This error has started to appear only recently.

I am also experiencing errors in ajax stuff like voting, see this question, for more details.

Edit: I got this error again after about 3-5 tries in SO. HTML comments have this error msg. URL for error page is this https://stackoverflow.com/error?aspxerrorpath=/posts/2767030/edit-submit/ff34ea58-e917-411e-92bc-a45f59710553

Actual error:
XSRF validation: Request form value 'fkey' did not match CurrentUser.XSRFFormValue

Edit: I experimented with editing tags. This problem occurs with Google Crome (45376), but does not occur with Firefox 3.6.3. I made same steps in both: make a search, go to question, edit tags, click back buttons until back in search results, go to question etc. Repeat many times.

I do not have any extensions installed in Chrome. I used same Vista machine with Firefox and Chrome. So is Chrome losing my cookie all the time, or what is wrong? I don't see how this could be networking related, like Atwood suggested.

  • 3
    Happens to me, too. It started with editing posts but became quite cumbersome for votes and comments as well. Right now comments are the most frustrating since they are completely lost when "oops, something bad happened". (I'm from Europe/Berlin, using Firefox3.6.x)
    – VolkerK
    Commented Apr 21, 2010 at 15:10
  • @Juha - are you only using that one Chrome browser to access the site? We're seeing that you've had six cookies access Stack Overflow today. Commented May 4, 2010 at 22:57
  • @VolkerK - we're also seeing that you're getting a lot of new cookies - about four every day. Are your log ins and log outs an attempt to remedy this issue? Commented May 4, 2010 at 23:01
  • @Jarrod, I am using linux chrome at work and vista chrome at home. I never explicitly logout. However sometimes the cookie is lost and I need to login, perhaps once a week or so (I don't know why). Commented May 5, 2010 at 6:29
  • Recomendation Copy (Ctrl + C) your own comment or answer or question BEFORE press send or add coment or Post your answer, or whatever, it's a kind of "backup"
    – please delete me
    Commented May 5, 2010 at 16:14
  • Juha, we did find a small bug that might have caused this, for users who tend to switch IP addresses rapidly. See my update and let us know if it's any better. Commented May 14, 2010 at 10:22

4 Answers 4


Can you give us consistent repro steps? We can't reproduce this.

edit: I added the actual error message to the HTML of the error page in an HTML comment. View source on the error page and look for:

Actual error:
This is a test exception generated by SimpleErrorHandler 
1.0.3764.33883. Please disregard.

So, provide me that. I suspect this is XSRF stuff you guys are running afoul of, as we suppress all those "errors".. they're caused by networking problems 99% of the time.

edit: We did find a small bug that might have caused this in rare circumstances, for users who tend to switch IP addresses rapidly. Let us know if it's any better after today (May 14 '10).

  • 1
    I am located in northern Europe. Could it be that trans-Atlantic delay would be enough to cause timeouts? Commented Apr 20, 2010 at 14:01
  • @Juha hardly - SO has a lot of users far away from SO's servers.
    – Pekka
    Commented Apr 21, 2010 at 17:06
  • 3
    I do not have the repro steps other than 1. go edit some post, 2. submit 3. error page. Sometimes this occurs, sometimes not. If I start over from 1. (by reloading answer list and clicking 'edit' submittng seems to always work. Commented Apr 21, 2010 at 18:39
  • 1
    The only time it happens to me is if I take too long to reply.
    – Locutus
    Commented Apr 21, 2010 at 19:03
  • 1
    @Jeff: I got the error again. See question for error msg. Commented May 4, 2010 at 16:44
  • @juha as I predicted... Commented May 4, 2010 at 18:08
  • @Jeff, so what is the cure? Commented May 4, 2010 at 18:27

If a press back button and try to submit again [..]

Does this imply you're using that Back button for your first edits as well? If yes: that is not supported on most websites. After posting your post, use the "edit" link to make changes. Do not use the Back button to try to submit again.

  • Nope. I write a new post, submit it, get list of answers page. Then I click edit, do some editing, submit and get error page. Besides if I should use back button in unsupported fashion, the website should detect that and give me a specific error message. Commented Apr 18, 2010 at 11:53

This is a test to submit an answer after 20 minutes of inactivity. Also, I only see the error message for a fraction of a second before the browser goes to a blank screen looks like its loading a new page but never loads. Im running the latest firefox

  • hmm.. can do it now but I will try later tonight on my laptop
    – Locutus
    Commented Apr 21, 2010 at 19:59
  • what are the repro steps? Commented May 3, 2010 at 16:39
  • 3
    I dont think its a procedural issue that can be reproduced via steps... although its just a guess, I believe its a latency issue. Ive noticed that when it does happen to me, Im usually on my cellular card and getting very high ping times (via netstat).
    – Locutus
    Commented May 3, 2010 at 21:04

It does seem to be some sort of internal session timeout. Clicking Back and resubmitting the form that threw an error (post edit, profile edit) only results in the same error being thrown again, but if you call up the form anew (losing everything you typed) you should be able to submit it that time. However, you can also find that you get forcibly logged off and get a CAPTCHA page come up, or simpy "Page Not Found", where the site has kicked you off without actually noticing. Getting "Page Not Found" instead of "Please log in" is quite worrying.

Unfortunately, since the site displays the sort of hopelessly unhelpful error message that anyone here should be ashamed of, it's very hard to guess what might be going on. The error message does also contain a comforting note that it's SuperUser's fault (that's the site I was on), and that the error has been logged and will be investigated (or words to that effect), so, since no-one is able to do this, does this suggest that the logging is completely inadequate for determining what's happening?

  • what are the repro steps? Commented May 3, 2010 at 16:39
  • Using Chrome? I've had exactly the same kind of problems and I don't notice me doing anything different than usual
    – Ivo Flipse
    Commented May 4, 2010 at 9:02
  • Using Mozilla Firefox 3.6.3 in Win XP. I don't have steps to reproduce as I only dropped by to answer someone's question: he'd contacted me via my site (about content on my site) and posted at Super User at the same time as a fallback. I then joined this site to comment on the bug, since the first thing I found was that the site was broken :P I've now joined Stack Overflow itself just to test my OpenID server set-up. All I was doing was going back to an open tab and hitting Edit on my comment (as I couldn't reply to someone else's comment (TRWTF)), and trying to fill in my profile. Commented May 4, 2010 at 21:41
  • OK, got the same error clicking "Copy Profile From Stack Overflow", just a different silly picture this time. Brought up the Activity tab to post this comment, then tried clicking the button again: it worked. I wasn't idle either -- was only a few minutes since I last did something. The error I was kicked over to was: meta.stackoverflow.com/error?aspxerrorpath=/users/copy-profile It seems that you only have to leave the site idle for a few minutes before it can choose to reject various requests, but if you ask to view something it seems to clear out whatever is stuck. Commented May 4, 2010 at 22:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .