I've just been logged out of SO and now cannot login again. My OpenId provider is verisign, and I can log into my account there OK. The message SO is displaying is:

Unable to log in with your OpenID provider:

Error occurred while sending a direct message or getting the response.

Anyone know what is wrong?

Edit: Are there any Verisign users who are not having login problems. If there are, please make yourselves known!

  • Hm... seems to be spreading. Similar to meta.stackexchange.com/questions/48006/…
    – Grace Note StaffMod
    Commented Apr 27, 2010 at 18:31
  • Yes, this is happening to me as well. See the link in @ccornet's question Commented Apr 27, 2010 at 18:47
  • I've mailed the SO team asking for a response.
    – nb69307
    Commented Apr 27, 2010 at 18:52
  • 2
    I'm having the exact same problem with Yahoo. It worked after trying a couple of times though.
    – wds
    Commented Apr 28, 2010 at 9:22
  • Same problem with Verisign at the moment (on main SO). OpenID sucks!
    – rjh
    Commented Apr 28, 2010 at 16:33
  • @rjh more like Verisign sucks. That's like complaining the internet sucks because a website is down. Commented Apr 28, 2010 at 23:28
  • @Jeff I was able to login into all SO suite sites except careers.stackoverflow.com and doctype.com . Verisign still insists that it's the problem on the SO end. And to me that story indeed points out some problems/dangers with the whole OpenID thing. Commented Apr 29, 2010 at 4:37

7 Answers 7


@jeff, @josh, @dolzenko, @Neil, @rjh, @ccornet, @wds, @heavyd, @cbrulak - following some great support from Andrew Arnott we were able to get to the bottom of it and indeed the gang at SO was correct the problem was indeed with us.

To save everyone the gory details why it just started to happen was that our association table in our db needed attending to quite simply because the service is used quite extensively. Once we were able to work through that we identified what was causing things to take as long as they were and all should be much better now.

I cannot speak to @wds comments about Yahoo and they could be totally different.

Thanks to all for the help and support.


PS. Oh and @jeff - no we don't "suck"...:-)

  • @gkall Thanks! I"m glad you guys were able to get things worked out!
    – heavyd
    Commented Apr 29, 2010 at 20:03
  • I'm glad enough that the problem is solved!
    – Grace Note StaffMod
    Commented Apr 29, 2010 at 20:11
  • Thanks Gary, for all your efforts - and for honesty!
    – nb69307
    Commented Apr 29, 2010 at 20:16
  • Excellent! Thanks a million for following up with us! Commented Apr 30, 2010 at 0:11
  • If you're still around, care to take a look on this report? Commented Mar 18, 2013 at 8:58
  • Still not working for me!
    – SamGoody
    Commented Oct 6, 2013 at 11:52

Verisign is taking more than 10 seconds to return a response to us, so it is timing out.

This is the first time I've ever seen a provider consistently take that long. It's a new phenomenon, even for them...

I can duplicate this using our test verisign openid and http://test-id.org

2010-04-26 19:51:13,139 
   DEBUG DotNetOpenAuth.Messaging.Channel - Sending message: CheckIdRequest
2010-04-26 19:51:13,139 
   DEBUG DotNetOpenAuth.Http - Redirecting to http://pip.verisignlabs.com/server?openid.claimed_id=http%3A%2F%2Fstackoverflow.pip.verisignlabs.com%2F&openid.identity=http%3A%2F%2Fstackoverflow.pip.verisignlabs.com%2F
2010-04-26 19:51:34,279 
   INFO  DotNetOpenAuth.Messaging.Channel - Scanning incoming request for messages: 

Notice the gap of 13 to 34 -- that's 21 seconds waiting for a response from Verisign.

  • Hell no! I've been able to successfully login with my dolzenko.pip.verisignlabs.com to the 3 sites in a row from OpenID sites directory myopenid.com/directory . That's bloody frustrating to be locked out of your account :( Hopefully you can fix that. Commented Apr 28, 2010 at 8:49
  • 1
    Jeff, could we have an update on the status of this issue, with regard to the StackOverflow site?
    – nb69307
    Commented Apr 28, 2010 at 19:38

By way of introduction I am the technical director for the PIP here at VeriSign. As Neil states we have not made any changes to the PIP and the problem does seem to have started happening recently.

What is of more interest is that the browser is that the request/response does appear to happen visually in the browser very quickly so I am not sure what might be the issue. According to the logs from SO it is in a 20 sec wait and for me in the browser it is not taking that long before SO throws the error. Anyway we'll have another look.

Interesting I just used PIP to post this response and it is working fine...hmmmm...

  • 1
    @gkrall as Jeff mentioned in his comment earlier there were some changes made to the site on meta.stackoverflow.com to extend the timeout to 20 secs, so logins are working(albeit slow) on MSO. Logins on the vanilla stackoverflow.com are still timing out.
    – heavyd
    Commented Apr 28, 2010 at 16:12

An update for those also experiencing problems - I've exchanged several emails with Verisign tech support, who were helpful but insist nothing has changed at their end. I've suggested to them that they and Jeff talk directly. I've also opened a new OpenId account using Google which is working fine, so we can exclude any client-side stuff from the problem I think.

BTW, it would be a kindness if you could upvote this answer sufficiently for me to be able to comment from this id!

  • you might be able to log in to meta now. Try it.. I increased the timeout from 10 seconds (for the record in the entire history of Stack Overflow this setting has never been a problem) to 20 seconds. Commented Apr 28, 2010 at 12:36
  • @Jeff Yes, the login worked. Are you going to change the timeout on SO too? If not, can you add my google openid to my old account there - I've sent you an email about it.
    – nb69307
    Commented Apr 28, 2010 at 12:58
  • @Jeff, strangely I can log into SU & SF(both 2010.4.28.1) but not SO(2010.4.27.2). Meta is also working for me.
    – heavyd
    Commented Apr 28, 2010 at 13:54
  • I'm able to log in to SuperUser and Meta now also. But not StackOverflow. Commented Apr 28, 2010 at 14:47
  • Same here, logged in to Meta but not SO Commented Apr 28, 2010 at 20:04
  • @Josh Please prefix your comments with @Jeff so he gets notified about them.
    – nb69307
    Commented Apr 28, 2010 at 20:52
  • @dolzenko Please prefix your comments with @Jeff so he gets notified about them.
    – nb69307
    Commented Apr 28, 2010 at 20:52
  • @Neil: Sorry, normally I do that. I am now able to log in to all three sites, how about you? Commented Apr 29, 2010 at 13:57
  • @Josh Yes, everything is OK now.
    – nb69307
    Commented Apr 29, 2010 at 14:37

Jeff: Is there any way to contact you directly? We traced the transaction and the authentication response from the PIP returns very quickly and occurs prior to what seems to be a "pause" on your end. We have not made any changes at all to our code in over a month and I am not receiving any other reports of RPs experiencing similar problems. My email is gkrall at verisign dot com.


For now, we relaxed the timeout from 10 seconds to 20 seconds.

We're working with Gary Krall of Verisign (thank you for following up!) to figure out why this started happening; it appears 100% specific to Verisign on our end.


I'm seeing this happening again with Verisign Open ID. Whenever I try and login, I just get this error:

Unable to log in with your OpenID provider:

No OpenID endpoint found.

I've been in touch with Martin Thurmann at Symantec and they've looked into it and can see everything is working fine on their end.

I've contacted [email protected] but no response after 24 hours.

P.S. I've had to create a brand new account to just post this. I really would prefer to have my account back with some reputation attached to it.