1

Possible Duplicates:
Minor bug: Croatian keyboard layout’s ] combo (AltGr+G) results in Insert Image dialog
WMD editor bug: German keyboard layout - “@” creates blockquote section

Hello Everyone,

This is my first question on Meta Stackoverflow.
The issue is pretty simple: I can't type starting braces ({), ending angle brackets (>) and ending square brackets (]) into SO questions or answers.

On typing {, the **strong text** text appears.
On typing >, nothing happens.
On typing ], the "insert image" dialog appears.

I suspect that my keyboard layout is responsible. I'm typing with the standard Hungarian keyboard layout and all those characters are accessible with AltGr key combinations.

{ = AltGr + B
> = AltGr + Y
] = AltGr + G

I think that the site may define keyboard combos for users with English keyboards, which conflicts with my keyboard layout. A possible way to fix this would be to be able to present users with an option to disable these.

So far, the only way I could input those characters was to type them elsewhere and then copy-paste (or swith to other layouts), but this is very inconvenient.

I use Firefox 3.6, but the issue may be present in other browsers as well. If anyone could recommend any usable workaround, I'd be very grateful.

Thanks in advance!

EDIT: This might be related to this question and this other question.

marked as duplicate by sth, Jeff Atwood May 17 '10 at 12:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.