7

Not sure if meta is the right place to post this. While the following query works with Data Explorer:

Select 'silver'

this one

Select 'gold'

gives me an

Error: Unclosed quotation mark after the character string ''. Incorrect syntax near ''.

Can this be fixed?

7
  • 4
    Wow, a gold bug!
    – user138231
    Commented Jun 7, 2010 at 19:33
  • 2
    @waffles: Actually, this is just broken for any literal that matches *go*. This must be because of the way the GO statement is implemented on the data explorer. Commented Jun 7, 2010 at 19:39
  • 1
    Just posted this: meta.stackexchange.com/questions/52847/…
    – Jon Seigel
    Commented Jun 7, 2010 at 19:42
  • BIG bug on my part, I will try to deploy a fix today
    – waffles
    Commented Jun 7, 2010 at 22:41
  • status-completed just fixed this see: meta.stackexchange.com/questions/52847/…
    – waffles
    Commented Jun 8, 2010 at 11:13
  • @waffles: Thanks, that should be sufficient. Would you like to add that link as an answer to my question? This would give me something to accept, and you some well-earned reputation for your excellent work on Data Explorer :) Am I supposed to edit my question and add the status-completed tag?
    – Peter Lang
    Commented Jun 8, 2010 at 11:48
  • @Peter, Jeff will take care of that, only admins can do it.
    – waffles
    Commented Jun 8, 2010 at 12:11

1 Answer 1

3

Ok this is much better handled now, see: Data Explorer bombs if you use the GO keyword

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .