9

Forgive me if I'm just ignorant of some well-known fact that explains this behavior:

When I log into Data Explorer with my usual OpenID provider (myOpenID), then I'm logged into the system as

where I actually should be

What's going on? (And the latter URL gives a YSOD with a generic "Runtime Error" message)

5
  • 1
    I will fix up the YSOD, its poor form
    – waffles
    Jun 16, 2010 at 7:39
  • 1
    FYI YSOD is fixed
    – waffles
    Jun 21, 2010 at 6:06
  • Why should your Data Explorer ID be the same as your Meta ID? The only reason your Meta and SO IDs are the same is because Jeff copied the SO user base when he set up Meta. Your SU and SF ids are different.
    – ChrisF Mod
    Jun 21, 2010 at 14:05
  • @Chris: Why should they not? Would be just equally unreasonable to assume that they must be different when they used to be the same on the trilogy sites so far (and the trilogy sites are what the Data Explorer is about, after all). It was my initial assumption, I asked, it turned out as wrong, case closed. ;-)
    – Tomalak
    Jun 22, 2010 at 22:15
  • @waffles: Nice 404 page. :-) Thanks!
    – Tomalak
    Jun 22, 2010 at 22:17

1 Answer 1

6

Your user account on Data Explorer is not tied to, and does not share its ID with, your accounts on SO/Meta. The system, though similar in appearance, is completely different, as it started life as a third-party tool

1
  • I see, thanks. However, the YSOD error needs some attention anyway. ;-)
    – Tomalak
    Jun 14, 2010 at 19:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .