It is not possible to prove being a human!!!

There is no text to read.

Checked adblocker, nothing blocked.


To repro:

  1. Open question
  2. Enter 'abc'
  3. Click 'Post answer'
  4. Get the expected error that message is too short
  5. Click 'Post answer' again
  6. Presented with 'empty' CAPTCHA

Here is the HTML I receive:

<script type="text/javascript" src="http://api.recaptcha.net/challenge?k=6Ld...">

  <iframe src="http://api.recaptcha.net/noscript?k=6Ldchg..." ...>
  <textarea name="recaptcha_challenge_field" rows="3" cols="40"></textarea>
  <input name="recaptcha_response_field" value="manual_challenge" type="hidden"/>

Also I cannot even open the CAPTCHA url directly. Just end up with a Google 404 error.

I find it surprising no-one else is getting this.

Another update:

Here is what Firebug gives me:

HTTP/1.1 302 Moved Temporarily
Via: 1.1 ZAISA01
Connection: Keep-Alive
Proxy-Connection: Keep-Alive
Content-Length: 154
Date: Fri, 23 Jul 2010 11:11:49 GMT
Location: http://www.google.com/recaptcha/api/challenge?k=6LdchgIAAAAAAJwGpIzRQSOFaO0pU6s44Xt8aTwc
Content-Type: text/html
Server: nginx

Then it 404's on the Google url.

I will try it out from home tonite, seeing this is a work connection.


It works from home. I get a JSON reponse from the URL I provided earlier. I can only assume this is some proxy issue, as it used to work.

Final update:

We got a new proxy installation at work, and it started working magically even though all the rules were replicated...

At least it works now :)

alt text

  • 23
    "It is not possible to prove being a human!!!". That sounds like exactly the sort of thing a computer would say... Jul 21, 2010 at 6:09
  • 1
    If only there was a some text to read, and a text box to input!
    – leppie
    Jul 21, 2010 at 7:28
  • 1
    captcha is "the humans are dead" Jul 21, 2010 at 7:37
  • 5
    Can we have [Status-NoReproByHumans]
    – devinb
    Jul 21, 2010 at 15:31
  • 3
    The only times I've ever seen this, I was blocking a necessary javascript domain (probably recaptcha.net).
    – Ether
    Jul 21, 2010 at 18:32
  • I have this too. If I try to open the reCaptcha Javascript file directly, Firefox says the SSL certificate expired. Apr 28, 2011 at 22:32
  • @Bart, what URL is that? I don't see any https:// URL. Are you using HTTPS Everywhere or some related add-on?
    – Arjan
    Apr 29, 2011 at 9:49
  • @Arjan: It's the URL in <script src="...". I'm indeed using HTTPS everywhere. Apr 29, 2011 at 9:51
  • @Bart, really that URL with simply a https:// prefix, or more precisely api-secure.recaptcha.net ?
    – Arjan
    May 2, 2011 at 8:06

2 Answers 2


Some general pointers to debug this:

  1. Check the JavaScript console for errors.
  2. Is scripting allowed?
  3. Try again after a few minutes; maybe there was a problem with the captcha provider
  4. Are you behind a proxy?
  5. I guess the captcha is embedded using an iframe or something like that. Check the source code of the page for any oddities.
  • 1
    Stack Overflow uses reCaptcha, whose main service is provided via JavaScript/Ajax. There is a non-ajax option but given that the sites heavily rely on scripting that would be the first thing I would check.
    – Andy E
    Jul 21, 2010 at 10:14

We can't reproduce this in any browser.

  • 1
    I am still getting it. Maybe proxy related?
    – leppie
    Jul 23, 2010 at 10:22
  • 3
    @leppie - Or addon related, have you tried without extensions enabled? Jul 26, 2010 at 11:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .