I was not able to create a new account on the new Gadgets site with my livejournal.com OpenID; I get this error from the authentication screen (after being redirected to LJ):

The site you just came from seems to want to verify an identity that you, as <LJ username>, cannot provide.

(I also have the same problem with a SE site that just started its private beta.)

(This is probably not related to my other problem, just filed with team@..., regarding not being on the private beta list when I should be.)

UPDATE: Livejournal OpenID logins are now working again.

  • I had this exact problem on ODATA this morning, so it isn't JUST SE. – sysadmin1138 Jul 21 '10 at 22:53
  • Agreed, I just tried serverfault (the only site in the tetrology where I wasn't logged in) and it is likewise broken; updated title. – Ether Jul 21 '10 at 22:56
  • I'm having this problem with Stack Overflow and Stack Overflow Meta now. Funnily, this was my first login attempt after I added a secondary OpenID to my Stack Overflow account yesterday, so I thought it was that that messed things up, but now I see that it's not just me! – SlimShaggy Jul 22 '10 at 12:40
  • 1
    I'm having the same problem. Looks like LJ made some OpenID changes recently: community.livejournal.com/lj_releases/59530.html – Billy Jo Jul 23 '10 at 23:40
  • 3
    They note that this is a bug in a recent post to the lj_support community: community.livejournal.com/lj_support/811222.html – Conspicuous Compiler Jul 25 '10 at 13:51
  • I can confirm this. It's affecting all my accounts, so I had to create temp accounts (including this one), and I've asked that they be merged so I can log in through delegation. – Matthew Flaschen - temp Jul 26 '10 at 19:16

This has to be a change on LiveJournal side; we haven't changed anything on our end.

I'll check into it.

Update courtesy of Andrew:

LiveJournal.com has been a poor OpenID implementation. I forgot what the specifics were. But now, when I type in my OpenID of http://example.livejournal.com/ they respond with an identifier_select OP Identifier, which they later fail to auhenticate. This is a LiveJournal bug. :(

LJ bug filed:

  • 1
    LJ is working again; this question can be marked [status-completed]. – Ether Jul 29 '10 at 16:19



The site you just came from seems to want to verify an identity that you, as shog9, cannot provide.

However, delegating to a LJ ID still works just fine. Comparing the URLs of the successful delegation and unsuccessful direct attempts shows that the identity is being set to "http://specs.openid.net/auth/2.0/identifier_select" in the latter case, which of course is not my identity. Perhaps LJ is doing better input-checking on requests now?

  • @Sog9: what do you mean by delegating to a LJ ID? How is this different than providing a LJ URL as an OpenId? – Ether Jul 21 '10 at 22:18
  • @Ether: I pass shog9.com as the openID to the gadgets site, which reads my LJ ID and the delegation links to LJ from the markup and proceeds to authenticate with LJ. But passing the LJ ID directly fails... Possibly because the site tries to pass identity=http://specs.openid.net/auth/2.0/identifier_select as my identity... ( view source on this answer) – Shog9 Jul 21 '10 at 22:24
  • 2
    Perhaps this is the kick in the ass I need to set up delegation from my vanity domain! – Ether Jul 21 '10 at 22:25
  • 1
    @Ether: DO IT! The time you save not typing, ".livejournal.com" will more than make up for whatever effort it takes to upload a new default page. – Shog9 Jul 22 '10 at 0:39
  • Nah, I just click on the LJ icon and type the first letter of my username to get it to be auto-filled. The only annoying part is typing the full name on the first site I log into, after restarting my browser. – Ether Jul 22 '10 at 4:27
  • Btw, i the ame problem is in publicauth app for django. Maybe, LJ switched standarts? – DataGreed Jul 22 '10 at 17:35
  • RE: "Perhaps LJ is doing better..." No. LJ is checking their inputs and failing on perfectly valid inputs -- inputs that LJ itself in fact is causing the RP to generate. – Andrew Arnott Jul 25 '10 at 2:37
  • @Andrew: beats me; delegating to LJ still works, so I'm happy. – Shog9 Jul 25 '10 at 3:04
  • Yes, using delegation produces a different result in the discovery step that causes a differently formed auth request to go to LJ, so that's why that still works. It's just the LJ-hosted OpenIDs that have the problem when you use them directly. – Andrew Arnott Jul 25 '10 at 17:14

Worse than that, I have a secondary OpenID registered and accounts on Meta, ServerFault and SuperUser associated with it, and now it is a crapshoot to which site I can login with that alternate OpenID (which I since made the primary).

Sometimes its StackOverflow, others it is ServerFault...

If I associate the accounts, then shouldn't the secondary OpenIDs be valid?

ALSO, I did go to the account I managed to login, with the (now) primary OpenID not being the LJ one, I did Copy profile to all associated accounts and I still cannot login using that other OpenID on the other accounts...

I think this shows that identity on the stack exchange sites needs to be more closely tied at least with regards with the openID used, if the accounts get associated.

UPDATE: Holly crap... My secondary OpenID at claimid is now different from when I first used it, and instead of claimid.com/njsf it is now openid.claimid.com/njsf which makes the stack exchange sites think it is a different identity. WHAT A MESS!

  • so email the address at the bottom of every web page and we'll help you get this sorted. – Jeff Atwood Jul 28 '10 at 7:02

I use livejournal as well and I'm getting this error on stack overflow when I try to log into my already existing account.

In the URL being passed to LJ my identity is identity=http://specs.openid.net/auth/2.0/identifier_select. I tried changing it around to various things, putting in http://xxxx.livejournal.com/ does return to stack overflow. Unfortunately I am then greeted with the following:

Unable to log in with your OpenID provider:

The following required parameters were missing from the PositiveAssertionResponse message: dnoa.op_endpoint

  • identity should be a link to stackoverflow – DataGreed Jul 29 '10 at 13:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .