I have a problem with editing a tag on SO. Here is the question I try to edit:
Bitfield enum extension method to return dictionary of included values

I'd like to replace the bit-fields tag by bitfields, but it just doesn't work (neither in the moderators quick edit, nor in the normal question-edit).

I tried to edit with Opera, Chrome and IE. Nothing works. Strangly, I can edit tags of other questions.

1 Answer 1


There's a tag synonym that maps bitfields to bit-fields (the info page for [bit-fields] also shows them). I had a similar problem last week with [c#-3.0] and [java-fx]

  • OK, that answered all my questions ^^ Well ... beside ... why is there no notice on the GUI?
    – tanascius
    Commented Jul 26, 2010 at 17:07
  • @tanascius There was a discussion of what to show the user when a tag is remapped; the common use case is going to be users using the wrong tag, and it should just be silently fixed. It is rather confusing for retaggers though, so it might change Commented Jul 26, 2010 at 17:08
  • 2
    @tanascius: I tried to warn them...
    – Jon Seigel
    Commented Jul 26, 2010 at 17:08
  • 1
    @Jon Maybe it could just show a warning if you do a retagging edit, but not on the original post of a question? Commented Jul 26, 2010 at 17:12
  • @Michael: Suggest that and I'll upvote it. Commented Jul 26, 2010 at 17:19
  • @Michael: To me at least, it makes more sense if the system notifies the user every time there is invalid input.
    – Jon Seigel
    Commented Jul 26, 2010 at 21:59
  • @Jon if we implemented everything from day one, you would still have to wait 6-8 weeks for tag synonyms to show up on the site :) we are only getting a tiny amount of issues on meta considering there are a few hundred synonyms in play now.
    – waffles
    Commented Jul 27, 2010 at 12:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .