8

I have got a white, semi-transparent banner sliding down from the top (like in the chat) and containing the word "Undefined" several times today on SO proper, every time immediately after re-starting a system and opening the browser for the first time.

When I change pages, it disappears and doesn't come back again. I didn't manage to take a screenshot.

Chrome 4 (correction: 5) on Windows 7

5
  • Seconded, Chrome 5 on Gentoo. I've been waiting until I could get a screenshot and/or determine why it happens, but I haven't managed either yet; it's been happening for a few days Aug 25, 2010 at 14:01
  • I think it's the box alerting you that you've been automatically logged in, and it only happens if you click a link while the page is still loading, before that box appears Aug 25, 2010 at 15:05
  • 1
    Also Opera 10.61 on Windows Vista. Same behavior you describe. @Michael: I'm not clicking anything, just letting the page load.
    – Larry Wang
    Aug 26, 2010 at 0:19
  • It works on the main stackexchange.com site, but gives me the white box on every other site I've tried.
    – Larry Wang
    Aug 26, 2010 at 0:35
  • Repro on Opera 10.61 on OSX. Every site that I've tried, except for stackexchange.com
    – Larry Wang
    Aug 26, 2010 at 13:43

2 Answers 2

9

I saw this popup today on all Stack Exchange sites (using Opera 10.61 on Windows XP). Here's a screenshot (click to enlarge):

Note the freehand arrow!

The Close This Window link executes the code javascript:closeGAuthNotification().


Update: Looks like this popup is an automatic login notification, at least this is what it says today after I cleared the browser cache. So, the problem with "undefined" was probably due to the cache.

Just FYI here're the steps to see the popup::

  • Clear the browser cache, cookies and persistent storage.
  • Restart the browser.
  • Open stackoverflow.com.
  • Log in using Google OpenID.
  • Sign in to Google.
  • After you return to SO, open another SE site, e.g. meta.stackoverflow.com. Note that you're not logged in here yet.

After ~5 seconds, a popup appears saying that you've been automatically logged in and suggesting to refresh the page:

More freehand arrows

17
  • That's exactly the one I meant.
    – Pekka
    Aug 25, 2010 at 19:54
  • @Pekka, Helen: How is this response an answer? Come to think of it, how is the original post a question? Aug 25, 2010 at 20:02
  • 1
    @Pekka You should probably wait and accept the answer that fixes the problem, not the one that proves it exists :) Aug 25, 2010 at 20:02
  • 3
    @Peter You realize you're on meta? The original post is a bug report; this post is to include a picture demonstrating the bug Aug 25, 2010 at 20:03
  • @Michael I'm pretty sure this is a bug on SO's side, so I presume somebody will just stamp this status-something one day, no need to mark that accepted :)
    – Pekka
    Aug 25, 2010 at 20:03
  • @Michael - I realize I'm on Meta. The giant button in the upper right of the screen reads "Ask Question" ---- I guess the implied question is, "Could someone fix this?" Aug 25, 2010 at 20:05
  • @Peter Yes? I checked your profile assuming you're new, but you're not; bug reports have always been this way. You did the same thing last week Aug 25, 2010 at 20:09
  • @Michael - Please allow me to needlessly nitpick in peace. Aug 25, 2010 at 20:12
  • @Peter ahahahaha! But you are needlessly nitpicking. This is a perfectly valid Meta question/bug report - and answer/visual confirmation. :)
    – Pekka
    Aug 25, 2010 at 20:21
  • @Peter: Like @Michael said, this is just a screenshot to illustrate the problem. I would have added it to @Pekka's post if I had enough rep to edit.
    – Helen
    Aug 25, 2010 at 20:22
  • Gentlemen please calm down. :)
    – Helen
    Aug 25, 2010 at 20:24
  • @Pekka: @Michael is right; please hold back the accept mark for an official response from Jeff or other team members.
    – Helen
    Aug 25, 2010 at 20:32
  • @Helen done, although it doesn't really matter: There are a lot of bug reports that will never get any official response except for a status-something tag; also, open bugs are tracked through the status-something tag rather than their accept status. Meta is different :)
    – Pekka
    Aug 25, 2010 at 20:41
  • 1
    Same browser, same problem. Windows Vista here though. It displays the message I assume it is supposed to - "welcome back, you have been logged in" in IE.
    – Larry Wang
    Aug 26, 2010 at 0:16
  • @Helen: When you say ALL stackexchange sites, are you including stackexchange.com? That is the only one that works for me.
    – Larry Wang
    Aug 26, 2010 at 0:36
3

I'm having trouble replicating this.

Do me a favor and clear your cache, then close the browser and try again.


This has been resolved. If you should experience it again clear your javascript cache and, if it persists, ping me.

8
  • @Kevin me too :) It seems totally arbitrary, but happened mostly when I totally restarted the machine (no idea why). I'll restart the small machine (without clearing the cache first, then with) and see whether it occurs again
    – Pekka
    Aug 25, 2010 at 22:04
  • @Kevin restarted without clearing the cache, didn't turn up. I'll keep an eye on it, clear the cache and post if it comes up again.
    – Pekka
    Aug 25, 2010 at 22:08
  • @Pekka - there's a check once per session, and it'll only appear if you're not already logged in (barring some minor edge cases that should be fixed tonight). Aug 25, 2010 at 22:50
  • @Kevin check the update by @Larry above - maybe it gives you more info
    – Pekka
    Aug 26, 2010 at 0:32
  • @Pekka - still makes me think bad javascript in the cache. Aug 26, 2010 at 5:58
  • @Kevin: I've tried clearing the cache. Doesn't fix it. Are you unable to reproduce the bug?
    – Larry Wang
    Aug 26, 2010 at 12:42
  • @Kevin: After clearing the cache, the popup now says "Welcome back, you've been logged in" (see my updated post).
    – Helen
    Aug 26, 2010 at 18:18
  • 1
    @Larry - a-haha, I've found the Opera bug. Will fix post haste, though it won't be on production till tonight (PST) sometime. Thanks for your assistance. Aug 26, 2010 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .