I was just having some trouble with registering to the Gaming stack, and finally worked out that for some reason that registration screen selecting MyOpenID was directly entering the base MyOpenID URL and not giving the opportunity to add the user name.

The similar process worked just fine on the main StackExchange prompting for a user id then generating the correct MyOpenID URL.


1 Answer 1


No, this is by design -- myopenid, like Google/Yahoo/AOL, no longer requires the username, so it's one less step for the user when we omit it.


works perfectly for me, I can log in with that, and that's what the login page does now.

The only time this would be required is if you have multiple myopenid accounts -- in that case, enter the URL manually on the login page like so:


(you can omit the http part)

edit: that said, myopenid does have a bug in the way it handles user names with periods. They no longer allow usernames with periods and are still (as of this writing) working on a fix. If you have a legacy myopenid username with periods, you must enter the OpenID URL manually (eg as a complete http://example.myopenid.com URL).

  • Ok, but it wasn't working. I hit the MyOpenId button, it submitted and bounced right back to a similar register/login page with an error message. Not until I hand entered my only openid with the full url did it progress successfully. Sep 3, 2010 at 17:02
  • @greg I suggest clearing your site and myopenid cookies, then trying again. Sep 3, 2010 at 20:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .