Pressing Enter in comment box unexpectedly submits form

Right now pressing Enter auto-submit comments and some other forms - but not others. When writing a technical answer you could need more than two lines of text f.ex. in a comment, and the good habit of pressing Enter to make a new paragraph comes into play... (and yes, currently paragraphs in comments aren't handled/rendered.)

Could you make it an option (ie. old/new behavior)? Right now it makes the Enter key a key to be afraid of, which isn't a good thing when you're composing text...

One alternative to option on/off could be to keep it on, but allowing the user to choose among a few key-combos (say, Enter, ctrl-Enter or alt-Enter) for the autosubmit function.

  • 1
    Duplicate? meta.stackexchange.com/questions/63644/… Sep 9, 2010 at 7:05
  • 2
    The topic is the same, but his is not a feature-request. Mine is, and I suggest some solutions and wouldn't mind seeing others feedback on a solution rather than the problem. I'd like the thread re-opened, but wouldn't mind it being closed if I was offered some other way of influencing this problem so that it's fixed. Sep 9, 2010 at 7:20
  • 1
    Reviewing the duplicate question, it would be clear that this behaviour is not going to be changed, reading some of the comments and answers, but I guess it's better to have a feature request status-declined. Sep 9, 2010 at 19:26
  • Yet again, a tiny amount of explanation
    – Shog9
    Sep 9, 2010 at 19:27
  • +1 I generally like the feature, but it's screwing me over way too often.
    – deceze
    Oct 19, 2010 at 8:40

1 Answer 1


There is a stack app which can be used to emulate this functionality:

Disable enter for submitting comments

It disables the auto-submit, and can be extended to toggle the behavior of the enter key.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .