When I upload an image to Stack Overflow, I cannot see my JPEG file in my post. It's all blank. I've tried it with different files, but gotten the same result.


I see the images just fine in your post.

Could imgur.com be blocked at your workplace?


  • You're right Jeff. After what you mentioned, I noticed that we can view, create, or edit posts in StackOverFlow, but we cannot upload any snapshot. I just asked them to unblock it. Thanks for the support. – paradisonoir Sep 14 '10 at 14:39
  • You are lucky. In Turkey, imgurl is banned country-wide. – Ramazan Polat Jan 30 '20 at 7:32

When imgur.com is blocked, then to at least be able to view images that were uploaded before May 2011, and hence were using the regular imgur.com domain, not the specific stack.imgur.com domain:

  • See fretje's userscript to replace it with the alternative filmot.com domain (a proxy).

  • Or, for these very Stack Exchange sites (or any other site where jQuery is available), the following quick & dirty script can be used as a bookmarklet, or can simply be pasted into the location bar (just like an address/URL) after a page has loaded:

    javascript:function r(i,v){return v===undefined?v:v.replace(/(\w*.?)imgur.com/i,'$1filmot.com');}$('a').attr('href',r);$('img').attr('src',r);

Beware: filmot.com is not affiliated with Imgur; I would NOT recommend signing in through that mirror but to always use imgur.com to access your private account, if applicable. Also, if you are very sensitive about your privacy, you might not want to use it?

It seems there's also an official imgur.com alternative domain, imgur.voxcdn.com. But that uses the very same IP addresses so is probably blocked too.


In my case, imgur.com was blocked by the company server/firewall and not the chrome so in this case it should be unblocked by the server admin. To check whether your company is blocking causing the images not display on StackOverflow etc just try to navigate to imgur.com website and you should be able to see if the company is blocking it or not

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .