This has been bugging me for quite some time, and the problem seems to be getting worse as more SE sites are added. I've watched MetaSO for some time to see if anyone else reports it, and I haven't seen it yet, so here it is:

Anything ajaxy happening on the site seems to be taking and interminably long time to complete. This includes:

  • Voting up or down
  • Adding a comment
  • Deleting a comment
  • Voting to close a question
  • Getting the vote splits on a question
  • etc. etc. etc.

The incident that prompted this question is this answer that, until my fifth or sixth attempt just now, I couldn't register an upvote on.

Maybe it's not even the Ajax stuff. I just did an F5 on the Unanswered page at StackOverflow, and it took 14 seconds to complete.

I'm behind a proxy. Does that make a difference?

Note: SO works fine most of the time from my home, but sometimes these problems happen there too. It almost feels like the server is running out of memory, and is thrashing the swap file.

I feel like I'm whining, but I've gotten used to the sub-3 second historical response times from StackOverflow, and 14 seconds is a long time to wait, given the number of clicks needed to use the site well.

  • 1
    Just tried refreshing this page, and it never came back. I gave up and refreshed again after about a minute and a half, and this time the page came back immediately.
    – user102937
    Sep 29 '10 at 22:58
  • Seems to consistently hang on the first refresh, and come through after the second refresh.
    – user102937
    Sep 29 '10 at 23:00
  • 1
    Possible problems: A) Slow internet connection B) Slow proxy server connection C) Proxy server is resetting sessions D) Slow network E) Router in between you and SO is congested F) Somebody doesn't like you. Either way, its norepo for me
    – TheLQ
    Sep 29 '10 at 23:06
  • @TheLQ: A) No, B) Doubtful, C) Possibly...How would I know? D) No, E) Unlikely. Other sites work fine.
    – user102937
    Sep 29 '10 at 23:10
  • I'm seeing no issue on my end.
    – jjnguy
    Sep 29 '10 at 23:14

I get pretty much instantaneous voting/unvoting/refreshing.


Can you provide repro steps? I can't reproduce this.

  • I don't have repro steps really, other than perhaps using the site behind a proxy. I guess I was kind of hoping that the SO software had some kind of log for this sort of thing (AJAX requests that fail to handshake, or take longer than expected, something like that). Even now, as I write and edit this comment, I see the software hesitate, like it's waiting for something.
    – user102937
    Sep 30 '10 at 17:07
  • Things are much better in Firefox, instead of IE8. I still get stalling, but generally I can retry, and it will work the second time. Performance overall is noticeably better.
    – user102937
    Oct 26 '10 at 21:48

I have seen this on occasion, and it is quite annoying. However, I just attributed it to a bad combination of my browser's cache and Internet connection.

I cannot reproduce the issue, so I can't help much. I just thought I'd let everyone know that this has happened to me before.

You must log in to answer this question.