In my answer here, I was explaining about Internationalized country code top-level domains. Unfortunately, standard links for some reason do not allow users to click on such links.

Such addresses are valid, so I believe that this is a bug which needs to be fixed.

I think that this question is similar but not duplicate of Internationalized domain name silently dropped because here entire country code top-level domains are affected and no sites using them will have their links properly displayed. It is also impractical to use Unicode escapes for entire name of the site. Perhaps an exception should be made for sites which use IDN ccTLD?

Such domains disallow use of characters which are outside of their native character set, so hacks such as мicrosoft.com, miсroѕoft.com, microѕoft.com and similar can be avoided.


If you add the links via the Insert Hyperlink option present on the toolbar, the links will be converted to punycode & URL encoded.


I've tried this in IE9, Firefox & Chrome - and it works fine.

enter image description here

  • Actually, if you add http://, it doesn't seem to work, at least if Firefox and Internet Explorer. The http:// needs to be manually removed. The proper way to encode them if with no prefixes such as http or www or similar. – AndrejaKo Feb 4 '12 at 20:06
  • I'm pretty sure I did add http://. Just tried again in Chrome, seems to work fine @AndrejaKo – Sathyajith Bhat Feb 4 '12 at 20:11
  • I mean, you aren't supposed to add http, the browser should do that automatically and it still isn't working in Firefox and Internet Explorer. – AndrejaKo Feb 4 '12 at 20:12
  • 1
    We detected an invalid link in your post, please correct it. (this message will be automatically removed when the link is fixed) – Community May 14 '12 at 5:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .