On SO, if you submit a comment on an answer but the answer has been deleted in the meantime then you get an error along the lines of:

You may only submit one comment every 15 seconds; resetting timer

rather than notification that the answer has been deleted from underneath you. Or at least I do - maybe 10Ks can still comment on deleted posts?

I've seen this two or three times now. This may be this issue.

Thanks to Jon Seigel and Nick Craver for trying to reproduce - sorry it didn't work :-/ My exact observations were

  1. I try to write a comment on an answer (that I think is wrong)
  2. I get the error above when I submit the comment
  3. I refresh the page to try again and the answer is gone

I didn't think about reporting it on meta until later so I'd lost the exact details and didn't grab a screenshot. I'll keep an eye out for this and come back if I get this again. (Or if I can convince my colleague to lend me his SO account I'll have a go reproducing myself over lunch.)

OK, happened again today: I tried to comment on an answer to this question which I thought was wrong but by the time I submitted the comment the answer had been deleted:

Only 1 comment allowed per 15 seconds; timer reset

Firefox 4.0b10 in case that matters.

  • No repro. On my testing question, I undeleted it so I could comment; in a separate window I had another copy of it open; I re-deleted it in one window, tried to comment in the other. I got "Cannot add comments to this post; it may be locked or deleted."
    – Jon Seigel
    Commented Oct 5, 2010 at 21:49
  • I tried this on both a question and an answer, and got the same result.
    – Jon Seigel
    Commented Oct 5, 2010 at 21:55
  • @Jon - If you delete your own comment, then try to vote on another you'll get the same error, since the cascading delete vote (from the parent answer?) seems to trigger the same timer...not sure of the implementation details, just the UI result. Commented Oct 6, 2010 at 0:35
  • @Nick: Okay. What is the consistent set of repro steps so I can try it?
    – Jon Seigel
    Commented Oct 6, 2010 at 1:03
  • @Jon - Not sure since you're not in control of deleting another's answer, delete one comment and try to vote up another in quick succession for the same effect/message though....potentially a separate issue, but same "wrong-ish message" problem. Commented Oct 6, 2010 at 1:05
  • @Nick: meta.stackexchange.com/questions/59398/… -- start adding a comment to the answer in there, then tell me here when you're ready for me to delete the answer.
    – Jon Seigel
    Commented Oct 6, 2010 at 1:08
  • @Jon - k, go... Commented Oct 6, 2010 at 1:12
  • @Nick: Okay, it's deleted. Try now.
    – Jon Seigel
    Commented Oct 6, 2010 at 1:13
  • 1
    @Jon - imgur.com/YhR1L.png The first error message is correct, "Cannot add comments to this post; it may be locked or deleted"...after that it's showing the timer message unless you idle for 15sec, then back to the "Cannot add comments to this post; it may be locked or deleted". Commented Oct 6, 2010 at 1:18
  • @Nick: Thanks for testing... I'm not sure the behaviour you observed is incorrect, though. Certainly, I don't think it's worth fixing/changing.
    – Jon Seigel
    Commented Oct 6, 2010 at 1:25
  • @Jon - Oh I agree, very minor either way, and glad the question's titled as such, just trying to leave some context of how to repro :) Commented Oct 6, 2010 at 1:27
  • @Jon @Nick - thanks for trying to repro, sorry it didn't work :-/ I was sure that must have been it.
    – Rup
    Commented Oct 6, 2010 at 7:13
  • 2
    Sorry for a little bit of necro, but I ran into this today as well. I'd maybe suggest trying repro again? Not sure what the best way to do it is, though. Commented Jan 3, 2011 at 16:12
  • 1
    I was able to repro again, and started posting a new question and found this (again), forgetting that I had already commented on this. Never got the "it may be locked or deleted" portion. Commented Apr 22, 2011 at 16:13
  • This just happened to me here on Meta. I had no prior knowledge of this bug report (or had forgotten). I was attempting to comment on an answer under this post when the question was deleted, if it helps/matters.
    – Pops
    Commented Sep 27, 2011 at 19:36

2 Answers 2


Reproduced: oh noes

  1. Wrote the "Posting a test answer" answer and posted it. Redirected back to question page.
  2. Duplicated the tab to have two tabs with that question and the original answer in it.
  3. In tab 1, deleted the question.
  4. In tab 2, wrote the comment seen above and clicked "Add Comment" and got this warning.

This happens when you repeatedly try to add a comment within 15 seconds, the actual error you first receive is:

Cannot add comments to this post; it may be locked or deleted

This is the behavior we want to prevent comment spam, the first message being an immediate indicator as to what has happened is correct.

  • No that is not the actual error I first receive. YOU also had a repro of this as well which was deleted (and I assume you as a ♦ see). Commented Apr 22, 2011 at 23:50
  • 1
    @Daniel - I can repro this reliably...but not as the first error, I don't see how you could trip that unless you actually tried (or successfully) posted another comment within 15 seconds. Commented Apr 23, 2011 at 0:04
  • 1
    @Daniel - Following your steps above exactly: I get the correct error. Also, the repro YOU had said "Comments must be at least 15 character in length." image link here...he did not repro the error we're talking about, and I assume that's why he self-deleted the answer. Commented Apr 23, 2011 at 0:15
  • I do see this on my Win7 box running chrome, but was getting the other one consistently on a WinXP box running chrome Commented Apr 23, 2011 at 0:18
  • @Daniel - It's a sliding expiration, are you sure you were waiting a full 15 seconds between testing? The way this works really isn't complicated (the way the code works), so I can't fathom how you'd possibly be hitting this, unless some user script was misbehaving and hitting things it shouldn't. Commented Apr 23, 2011 at 0:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .