Trying to post a question (on StackOverflow), and get the message:

Oops! Your question couldn't be submitted because:

  • users with less than 125 reputation can only post questions every 20 minutes; try again later.

I have not posted any questions within the last 20 minutes. Specifically I haven't posted a question since "nov 24 at 1:21" in 2009.

  • 1
    This might be one of many bugs related to the new "draft" feature Commented Oct 6, 2010 at 21:38
  • On something like the 5th try, I was able to submit the question. Is it possible that the criteria is comments, answers, and questions combined?
    – ulty4life
    Commented Oct 6, 2010 at 21:41
  • Did you get this error on your first attempt to submit, or did you try to submit but got a different error, then corrected and retried and got this error?
    – Jon Seigel
    Commented Oct 6, 2010 at 21:48
  • The error was on my first and subsequent attempts to submit until the final submit, when it successfully posted.
    – ulty4life
    Commented Oct 6, 2010 at 21:52
  • I'm getting the same issue. Haven't used my account in over a year, just created a question and keep getting this message. Nobody else in my company would use Stackoverlow so can't be an issue with IP address as suggested below. Is this a known bug?
    – Damodog
    Commented Jan 16, 2014 at 17:06

1 Answer 1


We have to throttle user activity based on IP address and your IP has collisions with several other accounts.

When you tried posting your question, another user on your same IP had also posted a new question - this is why the throttle was enforced.

We're sorry about this mechanism, but there's not much we can do to alleviate it.

  • Thanks for the explanation. It was pretty confusing behavior for me.
    – ulty4life
    Commented Oct 7, 2010 at 17:11
  • 1
    Curious: does this only take questions from users < 125 into account? (So, in the answer above, was "another user" actually "another < 125 user"?)
    – Arjan
    Commented Jan 19, 2012 at 6:54
  • 3
    We are over 35 thousand users sitting behind a big natting firewall. My co-worker tried to post a new question and got that throttling error message. He was logged in with his own account. Is there no way to throttle on the accounts instead of IP addresses?
    – delixfe
    Commented Feb 4, 2013 at 16:18
  • @delixfe it's a bit too easy to create new accounts for the throttle to really work. Only for relatively higer-rep users this could possibly work.
    – Mołot
    Commented Feb 28, 2014 at 15:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .