Possible Duplicate:
Add a clear button when a saved draft is loaded

How do I delete these draft things? I wrote an answer to a question then decided not to post but the draft answer won't go away. I've tried closing the browser and starting it again, and also tried blanking out the box, but neither of these ideas worked.


From this post:

You only get one draft (if you start answering a new question, old draft is blown a way).

Clear the box, type something and wait for the draft to be saved (there will be a message below the textbox).

  • 2
    That saves another draft, it doesn't delete it. – delete Oct 10 '10 at 0:58
  • @Kinopiko, did you try it? It works for me. – Pops Oct 10 '10 at 1:36
  • @Popular Demand: Yes I did try it. I cannot get rid of the text. I want to remove the draft completely. With the above method, if I delete all the text, it will not save it, and when I reload the page, the old text is still there, seemingly perpetually. The only thing this answer lets me do is change the text, not delete it. – delete Oct 10 '10 at 2:06
  • 2
    As I said, if you save a draft for a question you don't care about, your other draft will go away. – Gelatin Oct 10 '10 at 2:15
  • 1
    OK Simon, I give up. – delete Oct 10 '10 at 2:28
  • 3
    @Kinopiko, if you're willing to keep trying, I'm willing to as well. You said "when I reload the page" in your last comment. That makes it sound like you did not go to an entirely different question before saving the "throwaway" draft. Could you provide details about the exact steps you used in your attempt to repro? – Pops Oct 10 '10 at 4:45
  • Ctrl-S doesn't work in Chrome; I get the save dialog to save the page. – Chris W. Rea Dec 17 '10 at 13:05
  • Ctrl-S doesn't work in Firefox either. Same behavior. – Chris W. Rea Dec 17 '10 at 13:07
  • Finally, Ctrl-S in Internet Explorer just makes my computer go "ding" and does nothing. Does this even work on other Stack Exchange sites? – Chris W. Rea Dec 17 '10 at 13:08
  • 2
    @Chris FYI: the Ctrl+S functionality was removed in November. – DMA57361 Dec 24 '10 at 10:39
  • 2
    I'd personally just like to know why the solution is to "wait" [for your browser, your system, or the server] to do something. I too am having this problem. Waiting 30 seconds for the draft to be saved is not ideal. – Brian Jan 3 '11 at 16:01
  • @Brian: According to Mr. Atwood in the link DMA posted, it was to effectively lighten the load on the server. I'm not convinced however. – Jeff Mercado Jan 4 '11 at 21:55

Since March 2012, there is a "discard" just at the side of the posting button, if a draft has been saved. Clicking it will erase the draft:

  • I saw you wondered about the community wiki thing. That's just because the (old) question was made community wiki by its author. Then all new answers are CW too. Now, as the author is no longer a member here and cannot move the "Accepted" answer to this one: why not remove your above answer? You're not getting any rep from it anyhow. Then I will edit this answer into the existing answer. – Arjan Jun 25 '12 at 4:48
  • @Arjan I got the necromancer badge :D – ajax333221 Jun 25 '12 at 14:41
  • Are you saying you want to keep this mess alive for a badge...? – Arjan Jun 25 '12 at 15:33
  • @Arjan but his post is not CW – ajax333221 Jun 25 '12 at 16:32
  • We can still edit it into that... :-) – Arjan Jun 25 '12 at 16:39