Update #4: Just adding to the data, firefox 3.0.12 just installed and firefox restarted. First page I went to was stackoverflow, and tried to up-vote an answer. This happened. I opened firebug to watch the requests - it refreshes my browser to start listening - and now I cannot repo the issue.

Update #3: The problem appears to be within the client-side methods for updating the UI, and not the data-sending/retrieving. I'm noticing that I can vote and receive confirmation of votes, but the client-side methods to update the UI are bombing-out.

Update #2: Appears to be working again....bummer. I was just about to watch the traffic as I sent the request again.

Update: This appears to be happening for all answers on the page too. Refresh doesn't fix it for me either.

Went to vote (this happens with up & down) on a question only to find that my return value was "null." I've still got the page open if there's any form data you guys would be interested in seeing:

  • SiteName: SuperUser
  • QuestionID: 5564
When my up-vote is removed   When my upvote is applied.

alt text

  • What browser are you using? Heh, forgive me for not plowing through our IIS logs to find out :) – Jarrod Dixon Jul 20 '09 at 6:06
  • 2
    Is that a rhetorical question? Firefox :) – Sampson Jul 20 '09 at 14:53
  • Same thing was happenning to me at work today, Firefox 3.0.11 – TM. Jul 20 '09 at 22:03
  • Have you had FireBug installed the entire time you've experienced this? If so, can you disable it from FF's Add-Ons -> Extensions dialog and see if you can repro? Also, are you on a mac? – Jarrod Dixon Jul 23 '09 at 9:29
  • Heh, you're probably not on a mac, from the fonts in the screenshot - SO WHY AREN'T YOU ON FF 3.5.1? :) – Jarrod Dixon Jul 23 '09 at 9:31
  • Can someone edit the title of this question to be a bit more descriptive? – Swingley Jul 29 '09 at 2:01
  • Is there any way to FlashMob firebug in order to get them to fix whatever bug they have? Bring all of the StackOverflow firepower. – devinb Jul 29 '09 at 12:22

Can you define "a consistent set of repro steps", Jeff?

It is happening to me as well. Some strange behavior when trying to accept an answer as well:


This is consistently happening whenever I try to vote or accept an answer.

  • try clearing your cache. This is usually because we did a deployment. The file names do increment, so not sure how. Never been able to reproduce it. – Jeff Atwood Jul 19 '09 at 22:11
  • And if you can provide a step-by-step repro, I'm all ears! – Jeff Atwood Jul 19 '09 at 22:14
  • What browser are you using? And can you see if the requests are made via any http proxy/sniffer? fiddler2.com/fiddler2 is a great one. Thanks for your help! – Jarrod Dixon Jul 20 '09 at 5:59
  • It stopped happening at some point yesterday, so I can't really tell you much more anymore. I am using Firefox. – Paolo Bergantino Jul 20 '09 at 20:06
  • Do you have FireBug enabled? By enabled, I mean in the Tools -> Add-ons -> Extensions dialog of FF, not just on a given site in FireBug's options. Also, can you repro this in another browser, e.g. Chrome/IE? – Jarrod Dixon Jul 23 '09 at 9:26

This has just started happening to me in the last few days. It seemed to start after I flagged someone's comment as spam/abuse/hatespeech (it was my first time using this feature), but it might be completely unrelated to that. Now that I have associated my account with meta.stackoverflow, I get the same issue here.


The null/empty box does not come up if I disable Firebug. I.e., Firebug is causing the problem. Firefox 3.0.6, Firebug 1.4.0, running on OS X 10.5 in case you want to test, but there might not be anything you can do about it. BTW Do I get a badge for this?

  • No, badges are out. But you get an upvote. So don't cry :) – Ladybug Killer Jul 23 '09 at 6:29
  • Never mind, you just gave me a badge for my first upvote (and I got another for updating my answer). All my Christmases have come at once! – user130949 Jul 23 '09 at 6:55
  • can't repro this. How enabled does Firebug need to be? FF 3.5, Windows. – Jeff Atwood Jul 23 '09 at 7:22
  • Just upgraded to FF 3.5, the problem has gone away. Also, this is not the first time I've had Firebug break a major site for me - 12 months ago I had a Yahoo! Mail feature stop working because of Firebug. – user130949 Jul 23 '09 at 23:20
  • This problem has only occurred for me when firebug was closed. When I open it, the problem can't be reproduced. – Sampson Jul 24 '09 at 16:54

From the way our client code is written, it seems that the browser is either

  1. Not receiving the full response (unlikely)
  2. Misinterpreting the response

Each vote response is a json object, for example:

// sample "mark as accepted answer" response

The client code will update the UI based on the Success property in a simple block:

if (data.Success) {
   // update answer styles
else {

For successful accepted answers, the Message is the new check mark image to display. So the screenshots seem to indicate that the vote was successful on the server and the new image to display is being passed back.

Since the Message seems to be intact, I will try to refactor out the need for a Success property.

In the meantime, if any user is experiencing this, please use FireBug or some other http sniffer to see if the response is like my example! This feedback is much needed!

  • #1 is possible and happened to me on a .NET stack site when accessing the site from super far away, like Seoul Korea to data-center in Dallas, TX. This might have had more to do with how the data-center moved high-latency packets. It also happened to me in Google Chrome when using an apparently not-so-great proxy (NTLM style). – dlamblin Jul 23 '09 at 6:43
  • @dlamblin - would this be the case here? The response comes back in one packet; since tcp/ip is reliable, wouldn't the network stack ensure the response is good? – Jarrod Dixon Jul 23 '09 at 7:02

We've seen this but can't reproduce it. We think it's internet / networking (eg, failure to connect) related.

If you can come up with a consistent set of repro steps let us know.

  • Happening to me, in all sites now, always. – Paolo Bergantino Jul 19 '09 at 18:00
  • I recommend clearing your cache and/or CTRL+F5 – Jeff Atwood Jul 19 '09 at 22:10
  • @Paolo same thing here, happening in all sites, at all times (on my work PC). Didn't think to hard refresh :/ – TM. Jul 20 '09 at 22:04
  • Stopped for a while. Happening again, on all sites, at all times, after hard refresh and clearing cache. – Paolo Bergantino Jul 21 '09 at 23:03
  • simply can't repro. If you can give me repro.. – Jeff Atwood Jul 21 '09 at 23:54
  • 1
    also, I'm starting to suspect a configuration or networking problem on your end. – Jeff Atwood Jul 21 '09 at 23:56
  • 2
    I'm not sure what you want from us :) I want to help, but we're giving you what is happening to us: "voting gives me this box" is the repro steps, there's not much else to it... it's happening to other users as well so I don't really see how it's on my end. We're all programmers here so I understand the frustration if you can't see what is happening to a user, but I definitely think some digging into your dialog code is in order. – Paolo Bergantino Jul 22 '09 at 5:09
  • See my answer below ... – user130949 Jul 23 '09 at 6:17

This started happening to me today (didn't happen yesterday) on StackOverflow (tried to find this as an issue, but this question didn't come up when searching for "click on this box to dismiss".

click on this box to dismiss

Clicking on it made it go away.

I wasn't shown it for up-voting a comment.

Running Firefox 3.0.12, with Firebug 1.4.0 installed but off.

I'm seeing SVN: 4060 at the bottom of StackOverflow.

I'm also seeing this here on Meta as well.

With Firebug disabled, it does indeed go away.

Seeing as this version of Firebug works with FF 3.5.1, I'm going to go upgrade, and hope MouseGuestures updates soon!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .