This started yesterday morning


(Obviously, I have no problem with meta StackOverflow; I have problems just with Stack Overflow.)

It also appears that not many other users have the problem because there is much recent activity shown on the home page.

I went to Stack Overflow this morning, and saw the StackExchange inbox had one item (white 1 in a red circle). I clicked it open, and it would not finish loading; eventually it just blanked out. (All Sites and Hot Questions load just fine.)


I went to this meta and my question yesterday about this problem is gone. I only showed three questions in my profile. I am supposed to have 4. I looked at the SE inbox using meta and saw the comment to my deleted question


When I click the comment I get what shown in the following screenshot.


Also I am able to see my question on Google Search, but it opens me back to the same Page not found.


I went and clicked all the header and all the footer links on SO and the only ones that work are either different domains or they have subdomains.

Around the time that the issue first started, I was showing as not logged in, but when I clicked log in it would show all the logos of different OpenID options but then a white notice would come across the top and I would pop back to the page I was on (home page) and be logged in. This happened twice without me clicking "logout." ("Logout" does not work, by the way.)

I cleared cookies from stackoverflow.com and now it says:

Welcome back myname, you've been logged in. Click here to refresh the page.

This must be the same white notice from my last edit. Problem is not fixed.

I logged out of my Google Account (the one my OpenID came from), and I cleared the cookies. I went back to Stack Overflow, and it shows me as logged in. I clicked on "log out" (open in new tab) and it just refreshed the home page showing me still logged in. I clicked it again (not new tab) and it logged me out, but it again says:

Welcome back George Bailey, you've been logged in. Click here to refresh the page.

I refreshed the page and clicked logout again and now it is hanging just like all the other pages.

When starting from scratch (no cookies), I can access the site just fine. When I click log in, I click Google, I enter the sign-in info, and click on Sign In, then the following happens:

POST https://www.google.com/accounts/ServiceLoginAuth HTTP 302  
GET https://www.google.com/accounts/CheckCookie?.......... HTTP 302  
GET https://www.google.com/accounts/o8/ud?.......... HTTP 302  
GET https://stackoverflow.com/users/authenticate/?.................. HTTP 302  
GET https://stackoverflow.com/questions/4269389/using-jpa-2-0-criteria-api-and-cast-causes-generated-jpql-to-fail-in-hibernate ***HTTP 504***  

Now that I am logged-in, it stops working.

These URLs work: - https://stackoverflow.com/feeds, - https://stackoverflow.com/questions-all (and page numbers), - on the front page: the "Interesting," "Featured," "Hot," "Week," and "Mont"h tabs. - the 404 page for https://stackoverflow.com/all-questions.

  • Are you going through a proxy?
    – waiwai933
    Nov 24, 2010 at 16:34
  • No I am not. The whole site has worked fine for months until yesterday morning. Also there were some temporary outage notices yesterday if I remember right, but that did not last long. Nov 24, 2010 at 16:46
  • @GeorgeBailey, yeah, I remember making that comment. I thought it was a bug, too, but it's not; an admin deleted your post. It's still there for 10k users.
    – Pops
    Nov 24, 2010 at 17:05
  • On a more general note, could you not post screenshots with so much whitespace? They make me think the page isn't done loading, or didn't render properly.
    – Pops
    Nov 24, 2010 at 17:06
  • Sorry, I was in a hurry. Nov 24, 2010 at 17:13
  • What does "It's still there for 10k users" mean? Nov 24, 2010 at 17:14
  • 1
    Users with at least 10000 reputation can view deleted posts, that's what @Pop is referring to.
    – Grace Note StaffMod
    Nov 24, 2010 at 17:40
  • I have been having this exact same problem since ~Saturday. I have tested my account in 2 other locations and on every browser I know of. Also I created a dummy account via yahoo and tried logging in that way and there was no problems at all. So It appears to be my account which has the issue and not an environmental problem. You will most likely not be able to access anything on the stackoverflow.com main domain, but the sub domains (i.e. chat.stackoverflow.com) will work still.
    – Sean
    Nov 25, 2010 at 20:34
  • 1
    PS - I can also browse around when not logged in. And I can still use my account on all the other sites like meta and webapps, only stackoverflow.com is affected. I have contacted the team directly about my account and they were not able to see any issues when they tested. In my last reply to them I have directed them to this post.
    – Sean
    Nov 25, 2010 at 20:51
  • Sean: Are you getting anywhere? I would be glad to provide my login credentials if I could be sure that it was not published. Nov 29, 2010 at 13:50
  • Not yet. I didn't expect a response due to the holiday weekend. Will keep this updated if/when I hear anything.
    – Sean
    Nov 29, 2010 at 14:49
  • +1 for interesting bug :)
    – Benjol
    Nov 30, 2010 at 10:49

2 Answers 2


Your account was one of the "lucky" accounts to produce this issue - we will be releasing a fix soon.

  • 1
    Interesting. I would love to hear more if you are willing to share :p
    – Sean
    Nov 29, 2010 at 20:00
  • Yay! Fixed. I too want to know what happened to my account :) Nov 29, 2010 at 20:15
  • Mine Too. Thanks Geoff, Jeff, Kyle and whoever else worked on getting this fixed.
    – Sean
    Nov 29, 2010 at 20:19
  • 2
    There's a Mutex bit that is set on a user account when we perform operations that require an exclusive lock. This bit "should" never stay on for very long but .. it stuck. It's a symptom of a larger issue which we will dig in to find. Nov 29, 2010 at 20:19

This sounds like a problem on your end, rather than at stackoverflow. If you're behind a proxy check to make sure that it's not losing your packets.

I would also try clearing my cache: not just cookies but also content like javascript. You may have a cached javascript file that's redirecting you to the wrong place.

  • 1
    I am not behind a proxy. That 504 message could only be coming from the SO servers. I tested with Firefox after clearing cookies & cache (and all other items on that check box list). Nov 29, 2010 at 18:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .