5

This query works on odata.stackexchange.com

select Tags from Posts

Try it yourself

Yet, if you access OData endpoint like this:

http://data.stackexchange.com/stackoverflow/atom/Posts

... you can see that Tags field mysteriously has became TagNames field:

<d:TagNames>&lt;c#&gt;&lt;math&gt;</d:TagNames>

Do you know why? Is it a different database?

  • +1 Nice find. I think this is probably a bug in the OData endpoint. At a guess, they missed remapping the field from "TagNames" to "Tags". – Jon Seigel Nov 30 '10 at 3:47
1

Okay, I've pushed what I think should be a fix for this:
https://code.google.com/r/jseigelis-test/source/detail?r=2faea6ff20645541959c6c4b6ad9867f64bdf4a5

I say "should be" because I was unable to test -- IIS7 can't be installed on XP here at home. I know you've been making some changes -- if you are able to test, grab these changes into your own clone and make sure it works before we flag down @waffles to push this into the trunk.

Edit: The fix is now live.

  • Thank you Jon. I pulled your change and it works! I believe you can now request a merge. – Pavel Chuchuva Dec 19 '10 at 22:58
  • By the way, I managed to get it working under Cassini by using raw URLs and commenting out lines with IncomingMessageProperties. – Pavel Chuchuva Dec 19 '10 at 23:01
  • @Pavel: Oh, perfect. That's good to know. Thanks for testing. I sent Sam (aka waffles) an e-mail requesting a merge. – Jon Seigel Dec 19 '10 at 23:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .