I can't seem to log back in to stackoverflow.com now on my Mac (I'm still logged in on my PC). I'm getting the following error message (my OpenID provider is WordPress.com):

Unable to log in with your OpenID provider:

The following required parameters were missing from the DotNetOpenAuth.OpenId.Messages.CheckAuthenticationResponse message: is_valid

Update: I try logging out of WordPress.com, then logging back in to SO. WordPress.com asks me to sign in as usual, so I do it and refresh that page. And I get this:

Unable to log in with your OpenID provider:

Cannot decode Key-Value Form because a line was found without a ':' character. (line 3: '<head>')

I reload SO's login page and try logging in with my WordPress.com OpenID again. However many times I try that now, I no longer get the first error, only the second.

From the looks of the errors, they seem to be the ones slipping up. Should I report this issue to them too, just in case? I've contacted them with a link to this question.

Just to add: I don't get automatically signed in to the main site even though I'm still logged into meta on my Mac, as well as a bunch of other Stack Exchange sites. I don't know if this has anything to do with the WordPress.com issue though.

  • 3
    that is odd, I would definitely open a support ticket on their end. We haven't changed anything in a long, long time. Commented Jan 28, 2011 at 12:13
  • 2
    @Jeff: yeah I just shot them a support mail at the same time you left the comment. I definitely think it's their fault more than ours. Commented Jan 28, 2011 at 12:14
  • 2
    status-notourfault? Commented Jan 29, 2011 at 11:30
  • Strange; I first noticed a problem Thursday night, and it was the same on Friday but with new error messages. I searched for questions both times (with the specific errors) but couldn't see anything relevant, so I posted my own. Perhaps this question was not high enough on the list of results at that time. Can you add a WordPress tag to this question?
    – Mark C
    Commented Jan 29, 2011 at 16:21
  • @Mark C: I've done that now. Commented Jan 29, 2011 at 16:29
  • Thanks. Please let us know when they contact you.
    – Mark C
    Commented Jan 29, 2011 at 17:48
  • @Jeff @Bolt Ok, is their fault, but what can we do in the mean time to login? Should we create a new openId and associate it with the existing?
    – OscarRyz
    Commented Jan 31, 2011 at 14:46
  • @Oscar: That's what I'm thinking, but I'm lazy so I'll wait it out. Commented Jan 31, 2011 at 16:10
  • People, you can go to your profile, click in the "accounts" tab and click the link "add openid" in front of the "Registered User" title - and add a new OpenID. That is what I did to be able to comment here. Also, you all probably have more than one OpenID (or you do not have a Gmail account or Facebook profile? :) )
    – brandizzi
    Commented Jan 31, 2011 at 16:42
  • Doing this causes some mess with related accounts, though.
    – brandizzi
    Commented Jan 31, 2011 at 17:04
  • 1
    @brandizzi We, certainly we can't do that, if we don't log in first right?
    – OscarRyz
    Commented Jan 31, 2011 at 20:02
  • 1
    Now that they've fixed it, and it indeed is status-notourfault, perhaps it is time to close this as too localized :) Commented Feb 1, 2011 at 13:17
  • @Oscar well, you can do it if you have accounts in another Stack Excange site - although fortunately it is not possible :)
    – brandizzi
    Commented Feb 1, 2011 at 17:12

3 Answers 3


I've contacted the WP support and they said:

We have corrected a glitch and the problem should no longer be occurring.

At least for me, it's working again.

  • 2
    Indeed they have, I've just received a reply as well and it's working for me again. Commented Feb 1, 2011 at 5:02
  • Same here, it was frustrating not being able to login here and add comments ;)
    – gerikson
    Commented Feb 1, 2011 at 11:36

Definitely looks like a problem on the WordPress end. I repro the problem at http://test-id.org/OP/Sreg.aspx when entering my WordPress OpenID and get the same error. Their OP Endpoint is broken. The logs from test-id.org show they aren't handling OpenID associations nor are they responding correctly to the check_auth verification step.

  • 1
    Nice work. I got a reply from them last night - they say they're on it. Commented Jan 29, 2011 at 11:30

Yeah, its WordPress - they've changed something. Leaving a comment on blogger.com doesn't work either.

Blogger.com reports:

Your OpenID credentials could not be verified.

  • Yes i faced the same problem just now. But 2nd time it works. Don't know what is exactly happening :( Commented Nov 8, 2011 at 19:58

Not the answer you're looking for? Browse other questions tagged .