4

I upgraded to Firefox 4 this morning and noticed for all pages in Stack Overflow I am getting the following pop up. I read this question, but that did not work. I did not get this with Firefox 3.6 though. Any clue on what might be happening?

(The image button in Firefox 4 is also broken when I click on it pastes my clipboard content.)

For security reasons, framing is not allowed; click OK to remove the frames.

Popup: For security reasons, framing is not allowed; click OK to remove the frames.

Is this something to do with Firefox 4 rendering?

11
  • What OS? I'm running Firefox 4 (Win7 Enterprise) and I'm not seeing any pop up warnings.
    – ale
    Mar 23, 2011 at 19:29
  • 1
    No problems here, Win7 w/ FF4 on SU.
    – studiohack
    Mar 23, 2011 at 19:34
  • I am using win XP on this machine. I will try on my ubuntu when I get home.
    – CoolBeans
    Mar 23, 2011 at 22:26
  • No problems on OS X 10.6 either.
    – Arjan
    Mar 23, 2011 at 22:27
  • And other browsers at the place you're at don't have the same issue?
    – Arjan
    Mar 23, 2011 at 22:34
  • 7
    I'm thinking proxy, or adware/virus/worm/trojan. Can you confirm that all your proxy settings in firefox and the system are turned off?
    – Pollyanna
    Mar 23, 2011 at 23:00
  • Yes it happens without proxy too ...
    – CoolBeans
    Mar 24, 2011 at 1:49
  • Can't reproduce on FireFox 4 on windows 7 64.
    – Pollyanna
    Mar 24, 2011 at 3:22
  • You shouldn't have to, but if you haven't restarted your system since upgrading FF, try rebooting now and let us know if you get different results. Unlikely to change anything, but within the realm of possibility.
    – Pollyanna
    Mar 24, 2011 at 3:24
  • I wonder if it's an ad or something like that which includes an iframe that could be causing it?
    – Spudley
    Mar 24, 2011 at 14:26
  • @Spudley, no. The script: if (top != self) { top.location.replace(document.location); alert('For security reasons, framing is not allowed; click OK to remove the frames.'); }
    – Arjan
    Mar 24, 2011 at 16:07

3 Answers 3

8

It's got to be an extension or toolbar that's trying to add a frame around pages. What extensions do you have installed?

7
  • Firebug 1.7.0,AdBlockPlus 1.3.3,GreaseMonkey 0.9,Java Quick Starter 1.0 and JavaScript Debugger 0.9.88.1 .
    – CoolBeans
    Mar 23, 2011 at 19:59
  • I also had all these extentions in 3.5.6 too.
    – CoolBeans
    Mar 23, 2011 at 20:15
  • @CoolBeans, what if you use menu Help, Restart with Add-ons disabled?
    – Arjan
    Mar 23, 2011 at 22:24
  • Same thing happens. :-(
    – CoolBeans
    Mar 23, 2011 at 22:25
  • @CoolBeans I'm curious. You have accepted this answer, so obviously it helped you. But can you explain what about it exactly helped you? For future visitors. Jul 11, 2012 at 19:28
  • I have no extensions, Firefox 3.5, and also saw this "framing is not allowed" alert.
    – Village
    Aug 17, 2012 at 0:35
  • 1
    @Village Old Firefox versions (6 and earlier) are explicitly not supported, so it's very likely that this isn't going to be fixed - or worked around, possibly.
    – a cat
    Aug 17, 2012 at 0:57
4

I can't reproduce this; using the latest current release Firefox 4 and no framing.

I suggest starting Firefox in "safe mode" to disable all extensions.

(It is standard for us to reject framing with the first line of our JavaScript, however.)

4
  • That's what I tried earlier in safe mode but it still happens there. Anyway it must be a one off weird issue. Since nobody else is able to reproduce I would just close this post.
    – CoolBeans
    Mar 24, 2011 at 1:49
  • It does not happen in IE8. I also tired multiple other websites in firefox 4 and only stack exchange sites are giving these errors. Very strange.
    – CoolBeans
    Mar 24, 2011 at 1:55
  • 1
    @CoolBeans, you only see that security msg on stackexchange sites because that msg is generated by Stack Exchange's Javascript, not Firefox 4.
    – YOU
    Mar 24, 2011 at 2:20
  • Works great on Chrome!!!
    – CoolBeans
    Mar 24, 2011 at 3:10
4

A bit too long for a comment:

  • When right-clicking the page to get the context menu, do you get an option "This frame"? (That tells you the browser really thinks it's a frame, and it's not the JavaScript that is failing.)

  • Likewise: what do you get for any other site?

  • For the Stack Exchange sites: when disabling JavaScript in Firefox, you will be able to do a "view source" (using Ctrl-U or Command-U) before getting redirected. You might then see some <frameset>, and maybe even some comments that explain what inserted that then (which would then NOT originate from Stack Exchange). (Compare with an example site for which you're sure it uses frames; again note that there you will get the option "This frame" in the right-click context menu.)

  • Next, after loading without JavaScript and then enabling JavaScript again: does pasting the following in the location bar (address bar) give you anything else but the expected URL?

    javascript:alert(top.location);
    
  • If the view source indeed gets you a frame, this might be a good time to get to know Wireshark, to see if that was really sent by whatever remote host you're connecting to.

  • Today, a ping stackoverflow.com should get you IP address 64.34.119.12. (As an aside: ping6 stackoverflow.com still fails! June 8th is coming soon...)

  • You're not somehow using Google to get to these sites?

  • And clicking OK does not get you into an endless loop with the very same message for that same page again, right? (The checkbox might indicate otherwise, but maybe that option is shown as you have the same message for other pages on Stack Overflow?)

2
  • Thanks for the detailed message Arjan. I dont get it on other sites on only stack exchange profile pages in particular. I will try out the rest of your ideas and let you know.
    – CoolBeans
    Mar 28, 2011 at 17:38
  • The message is generated by the Stack Exchange family website, @CoolBeans. So I would not expect that message on other sites. However, the right-click context menu item "This frame" might also be shown on every other site you visit. If that's true, then something is adding such frame.
    – Arjan
    Mar 28, 2011 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .