When clicking "link" below a question or answer, one gets a popup with a pre-selected link:

Share link popup

I cannot get the selected text to actually copy and paste using vimperator on X11.

The old behavior was great; clicking the link would load that specific URL into the browser's location field, and then y would yank the URL into the selection buffer. Great success.

This new behavior, I can't get the text in the miniwindow into the selection buffer or the clipboard: ^X, ^C, right-click copy, right-click cut, none of those actually let me paste the URL later. Whatever cruft I might have in my selection buffer is pasted instead. Not much success.

Is there any chance of fixing this bug? Or am I the only one here using vimperator? :)

  • Reading your whole question, I understand that copy does not work either? As cutting does not make a lot of sense, maybe change the title to put the emphasis on copy then? – Arjan Apr 10 '11 at 10:32
  • Another aside: as this is pre-selected, maybe you can paste using the middle mouse button without any further ado? – Arjan Apr 10 '11 at 10:35
  • @Arjan, wish I could. It's all for show. :( The selected-look is all a big tease. – sarnold Apr 10 '11 at 10:35
  • Odd; others complain that the pre-selected text destroys the older existing contents of that "middle-click to paste selected text" buffer (not to be confused with the clipboard): Don't break Linux “copy-on-select” in link dialog. What behavior do you get there? – Arjan Apr 10 '11 at 10:41
  • @Arjan, hah, I've never tried that little button before. I can type [blah](shift+insert) quickly enough that I never look for a button. Anyway, that little thing destroys my selection buffer and inserts d, thirteen space+newlines, d, six space+newlines, a, newline. Amazing. – sarnold Apr 10 '11 at 10:47
  • Amazing indeed. It shows http:// on your screen, right? – Arjan Apr 10 '11 at 10:49
  • (Ah, "selection buffer"! I knew there was a simple term for it!) – Arjan Apr 10 '11 at 10:50
  • @Arjan, yeah, I'm as surprised as you :) The window showed http:// just as one might expect, but pasting it into vim or (stupid, bash) gives d \n \n \n \n \n \n \n \n \n \n \n \n \nd \n \n \n \n \n \na\n. Where \n of course means newline. It must be bed time. – sarnold Apr 10 '11 at 10:56
  • Any other selection of text on these sites just works as expected, I hope? And likewise when you type something yourself and select that? Or when you explicitly deselect and select the http:// manually again? (Just to exclude odd HTTP Content-Type issues in vimperator, though simple text such as http:// in UTF-8 really is the same as in ASCII, so I doubt there wold be any issues there.) – Arjan Apr 10 '11 at 11:00
  • this is not a bug in us, this is a bug in vimperator -- vimperator.org/vimperator – Jeff Atwood Apr 10 '11 at 11:12
  • @Arjan, Heh, I forgot: if I decide to change a comment I'm writing into an answer, I have to paste it into the edit control using ^V (really, ^V^V, the first one to send the second one through to the edit control) -- middle-click to paste will lose the entire first line. Once I figured out the workaround for that (^V^V) I haven't thought much about it since. :) As for the http:// example, yeah, I tried de-selecting and re-selecting a few times, just to confirm that I really did see what I saw. :) – sarnold Apr 10 '11 at 11:12
  • 1
    @Jeff Atwood, I sure wish I knew why SO is the only place that can trigger this behavior. :) Gmail, pragprog forums, launchpad, various bugzillas, amazon reviews, project euler, even my bank :), everything else works fine. Just not SO. :( – sarnold Apr 10 '11 at 11:15
  • talk about a corner case... – user1228 Apr 11 '11 at 14:24

You must log in to answer this question.

Browse other questions tagged .