http://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js is error 404

Well, it seems that Wget picks it up so the last statement is false and the exact message is:

Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

and it loads in Chrome once after I clear the cache but not after.

  • 14
    I always thought this message as a missed opportunity to make a jQuery joke. "I see you are using Stack Overflow without jQuery enabled. You should totally drop that and use jQuery."
    – Borror0
    May 1, 2011 at 11:18
  • 4
    @Borror, indeed Balpha resisted the temptation to do something like that ;-)
    – Arjan
    May 1, 2011 at 15:52
  • Note that it's Chrome that is giving you this message; not the Google web server, nor the Stack Exchange web sites. Not sure about that net:: prefix, but maybe the message really refers to the local file system, and Chrome somehow messed up its local cache? If this is Chrome 11, then you're not alone: Does anyone have problems viewing SO in Chrome 11?
    – Arjan
    May 1, 2011 at 15:59
  • no its Chrome 12.0.712.0 (Official Build 79102) dev but clearing the cache and reloading once for each domain did fix it
    – Dan D.
    May 1, 2011 at 16:03
  • It seems to be a temporal problem. It just happened to me within 5-10min of this comment that I couldn't connect to ajax.googleapis.com. It's up right now so they were probably resetting the servers or something. May 2, 2011 at 7:24
  • @Arjan, I don't understand what open/closed status has to do with showing up in search results.
    – Pops
    May 2, 2011 at 14:24
  • @Popular, not a lot, unless someone wants to add another answer that better fixes things? That said, I guess this very question won't be a perfect FAQ either ;-)
    – Arjan
    May 2, 2011 at 21:23
  • Happening frequently to me in last 30 minutes. I don't even see a request on the page (failed or otherwise) for any jQuery library. On the super-unlikely chance that this is related to page content, I'm seeing it on this page which happens to have a code using that same URL on it.
    – Phrogz
    May 3, 2011 at 20:20
  • > Note that it's Chrome that is giving you this message; not the Google web server, nor the Stack Exchange web sites. Um no, it is indeed SE. The sites used to work just fine and the problem only began late this week. My browser has not changed, so it is definitely SE (not to mention that Chrome does not have such a banner, and it can be sourced to the site's JS).
    – Synetech
    Jul 23, 2011 at 18:35
  • I just started getting this same message today with Safari on Mac OS X. I also tried Chrome on Mac OS X and got the same message on all SE sites. Clearing cache, refreshing pages, etc does not seem to help.
    – Paul R
    Jan 4, 2012 at 9:50
  • Turns out in my case that it was due to a phishing filter at OpenDNS - whitelisting ajax.googleapis.com in my OpenDNS settings fixed the problem.
    – Paul R
    Jan 4, 2012 at 10:46
  • 2
    Why can't SO just host their own javascript... why are they allowing themselves to be at the mercy of the availability of some other site. This seems like a terrible design. It also discourages safe browsing practices (i.e. limiting 3rd party scripts, which are a common source of mischief)
    – Gus
    Feb 27, 2012 at 20:55

11 Answers 11


For future reference (not for this specific case, but for future search results):

If you receive

Stack Overflow requires external JavaScript from another domain which is blocked or failed to load.

The Stack Exchange sites fetch jQuery JavaScript libraries from a Google domain. When those fail to load, the "external JavaScript" warning is shown (but only when the SE JavaScript from another domain, sstatic.net, does load successfully).

So, be sure that ajax.googleapis.com is not blocked by, for example:

See also the list of external dependencies in Which browsers are officially supported, and what else do I need?

  • After I added ajax.googleapis.com to the white list, and the message disparaged, thanks a lot!
    – Kuyo
    Sep 12, 2014 at 8:38
  • I've add the ajax.googleapis.com to SwitchOmega AutoSwitch list to a proxy, the message disappear immediately. Thanks a lot!
    – Marslo
    Sep 8, 2017 at 7:03
  • Wow, after adding ajax.googleapis.com to exclude list of proxy server worked. Thanks Sep 26, 2019 at 11:54
  • Is there any option for users in China other than using VPN?
    – zyy
    Oct 27, 2021 at 9:01
  • @zyy, as this apparently is a problem for you, maybe respond using an answer or ask a new question about that. I don't know about a solution, and I may be the only one seeing your comment.
    – Arjan
    Oct 28, 2021 at 5:22
  • @Arjan Thanks! I will see if I can find anyone who has already asked the question, if not, I will try to ask one (I have to be careful because it is really easy to get vote downs in this site)!
    – zyy
    Oct 28, 2021 at 6:10

It seems that I had to clear the cache and refresh the page once for each domain.

  • 3
    This tip works fine, not sure why though ? I have been having the problem with slideshare.net site not showing the slides as well. FireFox error console was showing a similar error that failed to load a script from google domain. Clearing the cache seems to take care of both the problems.
    – Ramesh N
    Jun 1, 2011 at 7:05
  • @RameshN I updated to Firefox 24.4.0 ESR, and I got this “Stack Overflow requires external JavaScript from another domain” message, too, even with all my plugins disabled, etc. I'd never gotten it before in any earlier FF versions. I cleared the cache, and it fixed everything; I'm not sure why it worked, either.
    – Geremia
    Apr 1, 2014 at 17:49

I had to deactivate the Decentraleyes plugin for Stack Exchange, so that jQuery works again. I don't know why it fails. https://git.synz.io/Synzvato/decentraleyes/issues/312



Not for me it isn't.

Are you going through a proxy?

Maybe it was a temporary glitch. Maybe a problem with load balancing in google. Can you check again?


For Chinese users, please check whether you can visit google.com. If not, use VPN/GoAgent or other methods to surf the Internet.


I've just received this error on Chrome. When I try to navigate to http://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js I receive this error page

"Panda Cloud Antivirus is blocking the download page"

I select "Continue" and then navigate successfully to "http://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js" . The .js file then loads successfully and when I reload the stackexchange site it loads successfully.

It seems Chrome is using Panda as part of its antivirus protection... ?


Common adblockers like AdBlock on Safari will also cause this issue. Try pausing the adblocker to see if it fixes the issue, and if so, then exempt the domain and you should no longer see the message.


In my case, the issue was resolved after removing all entries from hosts file in windows/system32/drivers/etc folder.


Input command ipconfig /flushdns and ipconfig /registerdns in the command line with administrator permissions.

And if you're using GoAgent and SwitchySharp, please add a default rule "stackoverflow" in it.


If you are on Mac, do the following:

  1. Open a Terminal and run: sudo nano /private/etc/hosts
  2. Check for any occurrences of ajax.googleapis.com (In my case, I had ajax.googleapis.com)
  3. Delete that line if (2) is true, and then save (ctrl+o) and exit (ctrl+x) the file.
  4. Run dscacheutil -flushcache in the Terminal.

Note: This is a solution to a possible problem. If it does not work, then try another browser to be sure your current browser is not at fault.

  • 5
    You know you must have added that very line yourself, or have some serious malware on your Mac?
    – Arjan
    Aug 13, 2012 at 19:32

I'm using the "AdBlock — best ad blocker" extension, and had the "Enable local content caching for popular website libraries" setting enabled. Just today (I've never had this before), I got the error banner on SO and MSE:

Meta Stack Exchange requires external JavaScript from another domain, which is blocked or failed to load. Retry using another source.

I don't know whether to call this a bug since it's caused by an extension, and clicking "Retry using another source" resolves the issue. I just thought it would be better to raise this than not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .