I am currently getting a red banner reading: "... requires external JavaScript from another domain, which is blocked or failed to load." on StackExchange sites.

I used to get a similar banner about jQuery if I had googleapis.com blocked, but I do not have it blocked now. Furthermore, the sites appear to be working fine apart from this banner.

Should I just ignore it?

Correction: the sites were working correctly, but now different features seem to be broken, such as live message preview, and the notification fly-out next to StackExchange.

Also, the button in the edit view are now gone. What's changed?

Apparently I cannot post comments now either.

I cannot post comments, so I will have to append them to this message instead.

I am using Firefox 4.0.1. Everything was working just fine until now. I did not change my configuration.

If I paste http://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js into the URL bar, I get the error:

Firefox can't find the server at ajax.googleapis.com.

Is this to be expected, or an indication of what is going wrong? Again, I haven't changed any settings and everything was working fine.

I tried ipconfig /flushdns but it did not help.

  • I have started seeing this error message but only when I use Safari on my iPhone. I have cleared my cache & cookies and now I cannot log in. May 9, 2011 at 9:43
  • @Barry I am sorry to hear that. I was hoping this was a one time glitch in Firefox. For some reason a reboot fixed it, at least for the moment.
    – Mr.Wizard
    May 9, 2011 at 9:44

3 Answers 3


Problem solved, I hope.

I did a full reboot, and now this site is working again. I have no idea why that helped.

Before rebooting, I tried ipconfig /flushdns without effect.

  • this happened in my mac FF, i restarted FF and the problem went away. Jul 30, 2012 at 15:52

I suspect a browser configuration issue.

Can you try

  • disabling all browser extensions or working in "browser safe mode"

  • a different web browser than you normally use with a default install

and see if that helps?

  • Jeff, I did not change anything in my browser config or extensions. A reboot fixed the problem. I would love to know why.
    – Mr.Wizard
    May 9, 2011 at 9:42
  • I had the same problem after (and thirst thought because) updating Firefox to version 10, but then I tried Opera, and had the same problem there. Feb 8, 2012 at 21:42

Firefox can't find the server at ajax.googleapis.com.

No, that's not to be expected. This is a configuration or networking issue on your side – I can reach ajax.googleapis.com fine from here, and there has been no change at all regarding the address we pull jQuery from.

The last change was on April 30, and this only switched from jQuery 1.5.1 to 1.5.2.

  • Do you know why a reboot would fix my problem, while /flushdns did nothing?
    – Mr.Wizard
    May 9, 2011 at 9:38
  • @Mr.Wizard: I think Firefox has its own internal DNS cache, which would be unaffected by flushdns; maybe that was it.
    – balpha StaffMod
    May 9, 2011 at 12:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .