In Chrome, I see the marker to the left of badges that I've received as a square. Ever since joining SO, I've been waiting for it to be fixed to be a graphic, or to something more attractive or meaningful.

For the heck of it, I used my mouse to selected it. Then did a copy paste into a textbox. It's a checkmark!

Who knew? Why doesn't it look like a checkmark on the page? I assume the font I'm using in the browser lacks a checkmark. If that's common, maybe you should switch to an image.

✔ <-- Looks like a checkmark in the editor, but a box in the preview.

✔   <-- It's a checkmark in the editor and in the preview.

Does it show as a checkmark to other people, or does everyone see it as an empty box outline?

In my other browsers:

  • Firefox: Checkmark
  • Safari: Checkmark
  • IE6: Box for one, box with question mark in it for the other!
  • IE7: Checkmark
  • IE8: Checkmark
  • Opera: Checkmark

So only IE6 and Chrome show the box. All other browsers show the checkmark.

Update: Changed my fonts in Chrome, but Stackoverflow seems to force the font, so no fix. Guess I'll just learn to live with the ugly box.

Update 2: Apparently Windows IE was notorious for not having checkmark available. But that seems to have been fixed (for me) in IE7. Only IE6 is broken (I refused to try anything earlier). Not sure why my Chrome hates the SO checkmark.

  • 2
    I use Chrome on XP and I see a checkmark.
    – akf
    Jul 25, 2009 at 18:38
  • What's your OS and what's the language. It might be that that symbol's either not available or has a different value in your character set.
    – ChrisF Mod
    Jul 25, 2009 at 18:43
  • America English Windows XP SP3 patched.
    – Nosredna
    Jul 25, 2009 at 18:45
  • 1
    You probably don't have the character available in the font being used. This was brought up before but I can't find it. Jul 25, 2009 at 18:46
  • 1
    @Ian Elliot - Is this the discussion you were thinking of? This might be of some help: meta.stackexchange.com/questions/1861/… Jul 26, 2009 at 4:00

4 Answers 4


I'm using Chrome and I see it as a tick/check mark everywhere. When viewing the post normally and when editing the post in the edit text area and the preview.

I'm running Windows XP SP3, fully patched in English (UK) - if that's important.

  • I've seen it as a box in both Chrome 2 and the Beta 3, all along from day 1. I also am XP SP3 patched, but I lack your Britishness.
    – Nosredna
    Jul 25, 2009 at 18:43

I've always seen it as a checkmark on Chrome, on Windows XP, Vista and Linux.


Chrome should render the checkmark (And other Unicode fine by default).

Perhaps you have changed or installed some other foreign-language support that is messing it up. For example, if you have installed a font like Code2000, LastResort, UnicodeBMPFallback, or something, they may be getting used as the default.

Another thing to check is Chrome’s configured language settings:

Wrench->Options->Under the Hood tab->Change Font and Language Settings (under Web Content)->Languages tab

Check the list of languages you have in the list. As the note says, only install the languages you actually use regularly. I tried adding a bunch of languages and found that Unicode started showing up as boxes. By removing them I fixed it. (Make sure you keep at least one though, I found that Chrome would crash when I tried to remove them all.)

Edit Check the Fonts listed in the Fonts and Languages dialog. Make sure that the three classes of fonts are set to fonts that have Unicode characters (eg Times New Roman, Arial Unicode MS, and Courier New).

Also check the default encoding; if it is set wrong, then the pages can be rendered incorrectly. See if setting it to UTF-8 (if it’s not already) fixes the problem—you can also try going to the badges page and changing the encoding dynamically by going to Page->Encoding. See if Auto Detect is checked. Try Western and Unicode to see which one gets the checkmarks right.

If it still doesn’t work, then go to a page that displays Unicode characters to figure out whether it is the page encoding, selected font, page, or browser settings. That page has the checkmarks (search for 2713), then you can check—no pun intended—if it is only that glyph or block, or what that is incorrect. This way you can narrow down the cause.

  • Hmm. I'm not really the foreign font installing type.
    – Nosredna
    Jul 26, 2009 at 2:41
  • I have "English (United States)" and "English." I'll try getting rid of them one at a time.
    – Nosredna
    Jul 26, 2009 at 2:42
  • Did not help, but thanks for the effort.
    – Nosredna
    Jul 26, 2009 at 2:44
  • So what's Chrome doing differently from Safari, Opera, Firefox, and IE8? Those all work for me.
    – Nosredna
    Jul 26, 2009 at 2:48
  • Chrome works for me and others as well, so it’s probably not Chrome that’s doing something different. See if Chromium has the same effect. Try running Chrome with a clear User Data directory (no modified settings).
    – Synetech
    Jul 27, 2009 at 14:38

My Firefox tends to show it as a box with numbers in it. I managed to fix it on one of my machines, though I've never figured out what changed - the other ones continue to display the box. Searching for solutions on the web seems to show things like "Update your fonts!" ...Because most of the people having the problem are having issues with foreign language alphabets. (Maybe at some point I'll ask SU for a solution.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .