4

When I search for certain terms on Stack Overflow, I get a long, but empty, page with search results. This only happens for some search terms, and currently I encountered the bug while searching for "java typedef" (without the quotes).

The search results flashes visible quickly while the page is loading, but when the page is done loading the search results are not visible any more.

I am using a freshly updated Chrome with version 12.0.742.100.
Example search that triggers the bug: https://stackoverflow.com/search?q=java+typedef

It seems to be reproducible always.

4
  • 1
    Sounds like you have one or more of the searched tags ignored and the "hide ignored tags" preference checked.
    – Tim Stone
    Jul 4, 2011 at 9:00
  • What OS are you on? I can't reproduce with 12.0.742.112 on Ubuntu 11.04. Jul 4, 2011 at 9:00
  • Haha, 12.0.742.100 is not "freshly updated" anymore. 12.0.742.112 is the current version. (Does anyone really even care anymore?) Anyway, I can't repro this using version 12-something on Windows 7. Jul 4, 2011 at 9:04
  • @Cody: I just pushed the update chrome button and relaunched, hmm. @Fabian: I am using Ubuntu 11.04 64bit and have installed google chrome directly from Google, and not via. apt-get.
    – bjarkef
    Jul 4, 2011 at 9:07

2 Answers 2

4

The problem is not the browser or the search implementation. And it's actually not a bug at all.

It turns out that this is a feature. You most likely have the tag as one of your ignored tags, and the "hide ignored tags" preference enabled in your user profile.

Since you're using Chrome, the easiest way to test this theory is to right-click on the link you posted above, and select the "Open link in incognito window" option. You should notice that it works fine.

The issue is that the filtering for the "hide ignored tags" preference actually happens on the client side. That's why you see the "hits" flash briefly. The search returned them correctly, but as soon as they arrive, your browser hides all of them because it thinks you don't care about any question tagged .

Also see: Don't "Hide ignored tags" on search results pages

3
  • Thanks, you are completely right. My mistake. But, this is not very intuitive behaviour. Perhaps the user should be warned when searching for a term that the user have ignored?
    – bjarkef
    Jul 4, 2011 at 9:10
  • They are. The page is blank. If you told the system you don't want to see questions with that tag, why would you want to see them in a search? Jul 16, 2011 at 7:46
  • That is not a very intuitive warning. What about actually writing something like: "You are searching for a tag that you have ignored, and you will therefore not see any results."
    – bjarkef
    Aug 15, 2011 at 7:03
-2

I have this and its because of Kaspersky Internet security Follow the steps below and it will work again.

From the dashboard of your Kaspersky software, click the gear icon in the bottom left corner to go to Settings. There are several setting topics listed on the left side. Click Protection then scroll down to Anti-Banner. This is disabled by default. Turn it off and the Ads will be visible again. This changes form time to time, probably when there is an update, so bookmark this so you don't forget it. :-)

If you are using another Internet protection look into the option for that one, it may be a similar issue.

Best Greenee

1
  • 1
    This isn't about ads, thought. It's about SE's built-in site search function for finding questions and answers.
    – bobble
    Aug 13, 2021 at 15:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .