33

Syntax highlighting for code has a long section about syntax highlighting but it fails to mention how to disable it.

I guess one can use "lang-none" as a language code (it's listed in Interface options for specifying language prettify):

<!-- language: lang-none -->

Is this correct?

I think it should be added to the FAQ. It's a special case, i.e. non-obvious.

1
  • 2
    If you use <pre><code> ...<b>bold line</b> ... </code></pre> instead of four-spaces in order to emphasise certain lines of code, then to disable highlighting, do: <pre><code class="prettyprint lang-none"> ... </code></pre> – Evgeni Sergeev Jan 18 '14 at 5:08
17

That's a great idea; I've added it to the Markdown help page (will be visible after the next deploy).

6

That's correct. It would be worth adding to the help page I think.

See also Syntax highlighting language hints for the full list of highlighting options.

0

I've found an alternative way to turn off syntax highlighting:

just start a code block with ```none

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .