5

When I inline edit a question, I do not see tag suggestions as I type in the tag box. Can someone look into this?

I am using Firefox 5 on Windows 7 Home Premium 64-bit.

Edit: The error console returned the following error:

Error: bindTagFilterAutoComplete is not defined
Source File: http://superuser.com/questions/308771/why-are-we-still-using-cpus-instead-of-gpus
Line: 2

Note that the above URL is only one page where I experienced the problem; it occurs on all pages that I attempt to retag.

Edit 2: An image of the problem:

Missing tag suggestions while inline editing

I've updated to Firefox 5.0.1, but the problem persists. Anyone else running Firefox 5 with this issue?

  • I see them on Chrome 12 Dev Mode, now going to test on FF6 – amanaP lanaC A nalP A naM A Jul 12 '11 at 20:30
  • it works on FF6 – amanaP lanaC A nalP A naM A Jul 12 '11 at 20:33
  • Non-repro on Opera 10.63 - Cleared your cache? – random Jul 12 '11 at 20:34
  • Do you have firebug installed? Can you check if tageditor.js is ever loaded? – balpha Jul 12 '11 at 20:46
  • Firebug is not installed. – bwDraco Jul 12 '11 at 20:47
  • Although I can't reproduce this, I have a theory -- please test this for me: After you have started inline editing and confirmed that tag autocomplete is broken, put javascript:void(bindTagFilterAutoComplete('#tagnames')) into your location bar and check if works then. – balpha Jul 12 '11 at 21:04
  • The above code worked, and autocomplete appears to be the issue. – bwDraco Jul 12 '11 at 21:06
  • @DragonLord: I don't understand -- Can you confirm that tag suggestions did not work before you pasted that code, but did work aftwerwards? – balpha Jul 12 '11 at 21:08
  • Doing it again failed. The loading animation (at the right end of the input box) appears for a split second, but nothing else appears. – bwDraco Jul 12 '11 at 21:11
  • Can you try if it works now, please? – balpha Jul 13 '11 at 11:58
  • @balpha, the tag autocomplete now works. – bwDraco Jul 13 '11 at 16:11
9

I suspect a timing issue between the loading and execution of JavaScript files. We've seen issues like this previously; they are hard to reproduce reliably across machines.

In addition, this particular autocomplete issue would only appear for non-moderators between 2000 and 2999 reputation (you fall into these boundaries on Super User, as does another user on Webmasters who reported the same issue).

So while this is indeed , it's plausible; we'll have a look at trying to avoid these timing issues.

Update: We've made a change to how the JavaScript is loaded, and since you report it's working now, I guess my suspicion was right.

  • .. so that explains why I was facing the same problems on SO. (can't link to my meta question, it's been deleted) – Sathyajith Bhat Jul 22 '11 at 6:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .