Sometime in the last day or two I've noticed the tag previews no longer show up.

Previously, I'd be able to type in tags and see the tags show up underneath, allowing me to double-check my tag choices by hovering over them and getting the tooltip. But as I write this, I am not seeing any tags for this question. Nor did I see tags update when I was filing a suggested edit that retagged a question.

Typing out this question shows me this: Submitting a new question

Suggesting a retag shows me this:

Suggesting a retag

I've reproduced on Windows 7: IE 8, FF5, Chrome, and on OS 10.6.8/Safari (5.0.5).

Update After playing around some more with FF5, IE8, and Chrome on Windows 7, I seem to have this issue when I'm logged in. If I turn on private mode and try to do stuff anonymously, I see the tag previews as normal. I've tried clearing cache and browser history, and even tried browsers that haven't visited this site before to no avail.

  • Have you cleared your cache?
    – random
    Jul 13, 2011 at 19:34
  • @random, i have the same issue right here on wiki, try adding a tag and you will see (using Chrome 12 dev)
    – Naftali
    Jul 13, 2011 at 19:36
  • Non-repro on Opera over Vista at least
    – random
    Jul 13, 2011 at 19:37
  • @random same issue on FF6 on Window 7
    – Naftali
    Jul 13, 2011 at 19:40
  • 1
    @random -- it works in IE8 on windows 7. So far only able to replicate on Chrome 12 and FF6 on Windows 7
    – Naftali
    Jul 13, 2011 at 19:41
  • @random Clearing my cache didn't help. When I'm logged out, I get the normal behavior. As soon as I log in, the previews all stop.
    – Troyen
    Jul 13, 2011 at 20:00
  • I saw the same thing also, but just thought it was something on my machine. Jul 13, 2011 at 20:21

1 Answer 1


There was a bug (or, well, issue that hadn't come up before) in our deferred JavaScript loader. While it did load the file it was asked to (in this case, the tag preview functionality), it didn't make sure that all our JavaScript helper functions (in this case, the tag renderer) were available as well before continuing.

Until a recent change to the tag editor this was never required, but now it is; that's why the tag preview bailed out.

This didn't come up for people using inline-editing (either full or tag-only), because when the inline editor is started, that helper functionality is long loaded (we're only talking about milliseconds here).

This is fixed after the next build.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .