I've been having issues accessing stackoverflow for the last couple of days.

Today, I've tracked it down to having issues getting content from the CDN. It takes an age to load the page and it is missing the CSS and js files that make it look presentable, ad aloow voting etc.

If I view source and try to download the linked css file directly I get the follwoing message:

"The proxy cannot establish a connection to the web server: cdn.sstatic.net /".

This is accessing from work in the UK. I've not tried from home, yet.

Is this issues affecting anyone else? Is it just my office proxy and I need to catch our IT dept? (I'm not aware of any other websites not working - just the stackexchange family using cdn.sstatic.net).

Also, I can connect to http://sstatic.net, it just the cdn. subdomain

EDIT: Also, any reason why meta.stackoverflow.com does not use the cdn?

EDIT: The issues appears to have resolved itself .. not sure who did what where...

  • 1
    I'm also seeing the problem, in my office in the UK. Your office doesn't happen to use WebRoot Proxy as a filtering provider, does it? Commented Jul 20, 2011 at 10:19
  • On further investigation, my problem seems to be a DNS lookup: I get "DNS lookup for the web server name (cdn.sstatic.net) failed." if I try to visit the URL for one of the stylesheet directly. Commented Jul 20, 2011 at 10:22
  • @Matt: Yes, I believe we do have a WebRoot Proxy. - but the issue appears to have now resolved itself.
    – Grhm
    Commented Jul 20, 2011 at 10:43
  • I've found WebRoot proxy unreliable on DNS lookups on at least another couple of occasions this week (I think with their system it's their proxy server that does the DNS lookup, so I guess it's just a bit rubbish at the moment.) They also seem to be blocking all sorts of random things -- my image placeholders have started failing because they've blocked placehold.it for "Media Sharing"! Commented Jul 20, 2011 at 10:48
  • @Bobby Those all appear to relate to failure of the CDN/connection to the CDN after a successful DNS lookup, rather than what I'm seeing. But I suppose that they're technically duplicate questions, even if the answer isn't the same... (Incidentally, I just temporarily hardcoded a CDN IP address in my hosts file, and it's working fine now, so it's definitely a DNS issue for me.) Commented Jul 20, 2011 at 10:57
  • This is still affecting me. Cannot connect to cdn.sstatic.net at all, so stackoverflow gets served with missing content. Some stuff is usable (can post a question) but some other functions don't work (cannot post comments). meta.stackoverflow.com works fine. Maybe as a workaround, make changes necessary to have stackoverflow functional even without cdn served content? Commented May 16, 2012 at 13:51
  • C:\Windows\System32\drivers\etc>tracert cdn.sstatic.net Tracing route to sstatic.stackexchange.netdna-cdn.com [] over a maximum of 30 hops: 1 * * * Request timed out. 2 * * * Request timed out. ... until it gives up. Commented May 16, 2012 at 13:53
  • having similar issue.
    – Sisir
    Commented Jun 13, 2013 at 9:02
  • SO has been down for me for 10 days now. Considering the Google result for "jquery ajax error NaN" this can be called a catastrophe. I'm in Africa. I'm told SO was fine (on the speedy side) here for years. What happened on the 1st of august?
    – yPhil
    Commented Aug 6, 2014 at 10:26
  • 1
    @xaccrocheur You might want to raise this as a separate question - it not going to be noticed as a comment here..
    – Grhm
    Commented Aug 6, 2014 at 10:51
  • I get the same issue routinely when I'm on the company VPN & proxy. To answer @user1394355 I put entries for cdn.sstatic.net and cdn-careers.sstatic.net in hosts (which I swap with Hosts Switcher when I drop/reattach to VPN) and downloaded all the files that SO needs to a separate web server that hosts now points to. That works, though at some point my files will fall out of step with SO's. Fiddler might be a less intrusive workaround than a heavy-handed hosts change/server stand-up.
    – ruffin
    Commented Apr 30, 2015 at 13:22
  • @Grhm If @xaccrocheur could get here but not SO, there's a good chance he's having the same issue you were. As you noted, Meta doesn't pull these files from sstatic.net. Initially, I edited the cdn links in Firebug or Chrome's web tools so SO used Meta's (which made SO look a little funky). Then I found that, strangely, SO's CSS files are/were on meta too. Example: meta.stackexchange.com/content/stackoverflow/… Unfortunately that's a different path than SO wants, or I'd've pointed hosts to Meta! cdn.sstatic.net/stackoverflow/all.css?v=45963981ca3b
    – ruffin
    Commented Apr 30, 2015 at 13:30
  • 1
    Does this answer your question? sstatic.net "Malware" warning
    – TylerH
    Commented Aug 28, 2023 at 13:59

2 Answers 2


Well, given that we both have the same problem and we both seem to be using WebRoot Proxy, I'd say that the issue is that WebRoot Proxy is having problems resolving the IP address for cdn.sstatic.net. The DNS lookup error I see when I try to visit one of SO's stylesheets in my browser certainly seems to come from WebRoot Proxy's servers rather than anything local.

I've tested this by temporarily making a local override for one of the CDN's local IP addresses ( in my hosts file, and that has allowed me to successfully see Stack Overflow's stylesheets again.

The long-term solution is to get your IT people to get on to the providers of the WebRoot Proxy service and ask them nicely to investigate their DNS lookup failures, I'd say.

  • 1
    I don't think my issue was WebRoot failing to do DNS lookups. The error message (as shown in my question) quoted the server name and IP address.
    – Grhm
    Commented Jul 20, 2011 at 11:08
  • @Grhm Good point! I hadn't noticed the IP address in your post. Interestingly, my problem seems to have disappeared now, though I've removed the IP address hardcoding and flushed my cache. I still suspect some transient problems at the proxy side of things are the cause for both of us... Commented Jul 20, 2011 at 16:18
  • @Matt Gibson i tried to ping it is not reachable Ip is returning. which is content provider for stackoverflow
    – bikram990
    Commented Jul 12, 2013 at 10:34
  • I suffered from this problem and fixed it by adding the CDN's IP address to my host file. This week the problem returned, however. This is because the IP address of the CDN's changed to So you should either change the IP address in your host file or remove the entries altogether, because for me the issue resolved itself.
    – gijswijs
    Commented Jul 28, 2016 at 10:31

I had this problem.

After digging into my firewall, I discovered that the IPv4 addresses for cdn.sstatic.net were on my bogons list. My firewall's bogon-blocking list had become out-of-date.

So, update your blocked-bogons list, or turn off bogon filtering in your firewall, and cdn.sstatic.net becomes reachable.

Team CYMRU maintains downloadable IPv4 and IPv6 bogon lists that can be loaded directly into a pf table.

  • 1
    Four very similar answers in quick succession. Is this necessary? Is it legit?
    – Werner
    Commented Nov 5, 2015 at 5:06
  • @Werner: No and the system actually automatically flags carbon-copy answers posted in this manner. Commented Nov 5, 2015 at 11:24
  • @Werner: Not intended as spam. Just read through several instances of the same problem here while trying to solve it. Posted my solution to each thread so others wouldn't have to dig as hard. If SE wants to merge them all together, that would be preferable. Commented Nov 6, 2015 at 6:08
  • @BoltClock'saUnicorn: Not intended as spam. Just read through several instances of the same problem here while trying to solve it. Posted my solution to each thread so others wouldn't have to dig as hard. If SE wants to merge them all together, that would be preferable. Commented Nov 6, 2015 at 6:15

Not the answer you're looking for? Browse other questions tagged .