Linked Questions

27
votes
4answers
4k views

Markdown handles inline bold text (within a word) incorrectly

When I bold text inline like strongtext it gets parsed as italics instead of either bold or nothing. I created the above with the following line: **strong**text As I understand it, inline ...
8
votes
3answers
16k views

Markdown quirk on bold and italics

***SomeText*** gives SomeText but ***Some_Text*** gives Some_Text It seems as though there's interference with the underscore character, since it can be used itself as markup for italics. Only ...
11
votes
2answers
727 views

Fail of markdown parser detected if '_ 's are used in a naked URL

In the answer realloc() for NUMA Systems using HWLOC, the parser breaks my URL link. The URL was with __word__: http://www.open-mpi.de/projects/hwloc/doc/v1.2/group__hwlocality__membinding.php#...
11
votes
3answers
344 views

Italicizing words that include an underscore doesn't work

Here's the screenshot of my experience with italic text over Stack Overflow. Basically it just wraps the word into asterisks and leaves it like this. Here on Meta I do not observe this bug.
-11
votes
3answers
201 views

Question banned user meta review queue

On an average day Meta gets 4 or 5 cross posted questions from question banned users on SO. How about a review queue for incoming questions from q-banned users? All questions from QB users could be ...
3
votes
1answer
633 views

Bug due to overzealous encoding of URLs

This link works fine when it's copy/pasted: https://github.com/cyga/www_fdw/ But the _ gets encoded as %5f when it's autolinked, and this can break the URL: https://github.com/cyga/www_fdw/ Edit: ...
7
votes
2answers
95 views

Turning a line into italic doesn't always work - why?

I noticed while trying to consistently format e.g. error messages in posts that the "italicizing" in the markdown editor doesn't seem to work reliably... Can someone explain why it does work on lines ...
5
votes
2answers
205 views

Bug in SO's Markdown parsing for bold

I believe there might be a bug in the Markdown preview script. It shows the following foo**strong text** as foo*<i>strong text*</i> But I've looked at several other Markdown parsers, ...
6
votes
2answers
135 views

Intra word markdown doesn't function properly when combining italic and bold

I mean, why can I write in thisway, (just bolding: **wo**rd, or just italicizing:*wo*rd), but I can't ***comb***ine bold and italic? It works non-intra-word, but doesn't work ***intra-***word. Is it ...
4
votes
1answer
138 views

Asterisks in formatted text: questions/answers vs. comments

There are several questions that touch upon this bug (?) peripherally, but none of the ones I could find address the question exactly. I post mostly on ELU, where I am one of the posters that ...