All Questions

Filter by
Sorted by
Tagged with
1
vote
2answers
251 views

URL with multiple ending parentheses produces broken links in markdown preview

I tried to create a link to https://docs.racket-lang.org/reference/Filesystem.html?q=rktl#(idx._(gentag._305._(lib._scribblings%2Freference%2Freference..scrbl))) using Markdown in this way: [example]...
17
votes
0answers
124 views

Visibility of links with uppercase letters in protocol section is inconsistent

Any link is visible in post preview despite of case in protocol section. But only links where protocol in lowercase are visible in result. Here is the link with uppercase letter in protocol section: ...
2
votes
0answers
26 views

Link formatting broken when it renders correctly in preview

I went back to an older answer of mine and I realized that the link formatting was broken (as you can see in this revision): But the preview (see—but don't save—here) showed that everything looked OK:...
2
votes
3answers
120 views

Intra-word emphasis using Pagedown vs. Stack Exchange's WMD Editor

Why does Stack Exchange's WMD Editor allow you to do things like bold parts of sentences while the Open Source PageDown (https://github.com/StackExchange/pagedown) does not?
-23
votes
1answer
90 views

Feature Request : Visual Post Editor [closed]

Posting in StackOverFlow isn't visual. Users have to fetch what it will look like and have to post. So, please add a feature of visual editing (Like Wordpress).
9
votes
0answers
41 views

Editor preview resolves title to HTTP links but rendered post does not

The editor and the actual rendering of a post differ in their treatment of post link title expansions for non-HTTPS links. For example, the following: HTTPS: Network-wide HTTPS: It's time HTTP: ...
2
votes
0answers
50 views

Incorrect preview for link with closing parenthesis at the end

When I write a link whose URL ends with a closing parenthesis, it's handled correctly when I save the post, but not when I look at it in a preview. For example this markdown: [`CSharpCompilation....
29
votes
1answer
127 views

Bug in markdown parser - Horizontal line parser

Symptoms The following input causes stackexchange page to freeze (give it a try :P) - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - a Cause This is caused by a ...
1
vote
0answers
15 views

Preview formatting doesn't match real formatting when italics are within quotation marks

I am currently editing a post. The first line is i have two tables "*TABLE_A*" and "*TABLE_B*", The italics work in the preview, but not in the rendered post. In the rendered post, I can see the ...
4
votes
0answers
50 views

Formatting bug: preview doesn't look the same as the published question or answer

In answering a question earlier today, I used some funky formatting. While this formatting might not be the best way of doing things, there is still a bug where the preview question doesn't look the ...
3
votes
1answer
82 views

Why does this markdown preview differently?

See this question. When published, the markdown does not render the same way it does in preview for edit mode. The numbered list does not continue when published, but appears to continue in preview. ...
4
votes
0answers
39 views

markdown preview / final result, issue with quoted “*”

in this answer by Olivier Dulac: https://stackoverflow.com/a/16989110/592540 there appears to be a difference between the preview of the answer when editing and when the final result is published. In ...
4
votes
0answers
31 views

links with $ signs handled ambiguously

It appears that links like http://nginx.org/r/$uri are shown with the $uri part being part of the link during the live preview (JavaScript), yet not when shown statically on the page (server-side). ...
3
votes
2answers
74 views

Effect of * in quoted text not shown in preview but affected actual post

In my recent post, In quoted text of first special parameter description, The preview shows well: But in actual post * effect cause inclined text: So, Why preview!=actual of post? and How to fix it?
1
vote
2answers
30 views

Second succesive link is not displayed (links with URL at the end of the page)

While editing a [question on Ask Ubuntu] I noticed a bug: > the link after [CMYK] [reference chart] is not displayed [CMYK]: https://en.wikipedia.org/wiki/CMYK_color_model [reference ...
5
votes
0answers
52 views

Warn if the generated preview HTML is different from the cached HTML when starting to edit a post

Occasionally, the Markdown engine has breaking changes made to it; three such changes are coming up when CommonMark compatibility is brought in. There's a suggestion there for warning editors that ...
8
votes
0answers
49 views

Inconsistent parsing of HTML comments containing backticks

HTML comments and markdown special characters interact in a strange way. Let's fiddle with <!-- foo `bar` qux --> This apparent HTML comment ends at the first backtick: qux --> This apparent ...
-7
votes
1answer
75 views

markdown editing in comments, 5 minutes only and paragraphs [duplicate]

If I answer as an 'answer' I get the good-looking UI to help me do all the things I want, BUT if I am in comments I am helpless. Would it take much resources to have the same same UI to keep sanity in ...
1
vote
0answers
23 views

If you mess around with tag markup too much, the editing toolbar vanishes [duplicate]

I ran into this bug myself earlier today, the basic nature of which is that typing in certain tag markup causes the markdown preview to freeze. I was testing this markup on Anime.SE to see what ...
4
votes
0answers
65 views

Units in img width/height breaks image [duplicate]

In both the preview and rendered question, this does not work: <img src="http://i.stack.imgur.com/R7QBb.jpg" width="100px" height="100px"> ..as the image doesn't appear (cleaned up by HTML ...
5
votes
1answer
119 views

Is this bug or any special method to write a post using special character? [closed]

When I try to use underscore in my post, sometimes the preview displays my text in italics with no underscore. That confused me, and I have placed two underscores. Now the preview does not show the ...
15
votes
0answers
127 views

Perverse <del>/code block nesting preview is misleading

I just noticed that including code blocks in <del></del> seems to work in the preview but does not in the posted result. For example this: <del>Not code but enclosed in del tags ...
6
votes
0answers
25 views

Inconsistent auto-hyperlink behavior between post preview and actual post

In the preview zone for posting, this link: http://fr.wikipedia.org/wiki/Allégorie_de_la_caverne breaks just before the é. Here's a screenshot to demonstrate: However, as you can see in the ...
7
votes
0answers
45 views

Markdown preview is inconsistent with actual rendering when using blockquotes inside a list [duplicate]

On Meta Islam I posted this question, which seemed perfect in the preview below the edit box. But when I posted the question I got something partially different:
0
votes
1answer
116 views

Markdown error rendering URL? [duplicate]

Here's a URL: http://read.pudn.com/downloads99/sourcecode/windows/bitmap/406853/doors.cpp__.htm On my screen (Chrome browser, Mac OS X, up to date), it reads this way, both in the live preview and ...
1
vote
0answers
69 views

Inconsistent rendering of monospace text in markdown preview versus actual posts

Consider the following markdown: `a b `c Note that there are two trailing spaces in the first and second lines. In the editing preview, this looks like this: In actual posts, it looks like this:...
12
votes
0answers
220 views

Cyrillic letter-highlighting differs in preview and in post, while identical for latin characters

I found that the rendering xxx**yyy**zzz as xxx*<i>yyy</i>*zzz is by-design, but for latin letters it works identical both in preview and after posting. But this is not so for cyrillic ...
4
votes
1answer
106 views

Markdown preview differs from final for `**` surrounding text with line breaks

The following Markdown from this question renders differently in different places: **Edit:** **It seems there are differences between the two, and the + notation has restrictions that the ANSI join ...
14
votes
2answers
186 views

Can't edit (a specific) post without script freezing

I'm trying to edit: BYTE to python C-Type structure Conversion Issue However, every time I click on edit, Firefox (16.0.1 - Ubuntu 12.10) hangs for about 10 seconds, then prompts the usual "debug ...
5
votes
0answers
61 views

Preview and final formatting are not consistent

There are quite a few questions here about formatting, but I could not find anything to answer my problem. I've been answering a question on Linguistic site, and the question was about word ...
8
votes
1answer
299 views

New Line in URL in Inline Link causes unexpected output

Providing a new line as the first character of a URL in an inline link causes unexpected ouput. Input [Invalid]( http://www.example.com) Expected Output [Invalid]( http://www.example.com) Or ...
2
votes
1answer
60 views

Unfiltered raw MarkDown shown in question summary

This question has a picture right at the start of it. This results in the raw Markdown being shown in the question summary (as illustrated). This Markdown needs to be filtered out. Thinking that I ...
0
votes
0answers
61 views

Markdown code block parsing fails after lists [duplicate]

Possible Duplicate: Code block is not properly formatted when placed immediately after a list item Code block parsing fails after lists: A B Contents List of Figures iii List of Tables ...
12
votes
1answer
544 views

HTML comment containing URL breaks if followed by another HTML comment

While fixing up a broken imgur link on StackApps, I noticed that a HTML comment in a post that contains a URL that Markdown might parse will break in the preview if that comment is followed by at ...
4
votes
1answer
62 views

Differences in preview-vs-live rendering with <!— language -->

I noticed that, while typing out a question, the <!-- language --> specifier caused different rendering in the question preview than when I published the question. Specifically, omitting the ...
3
votes
1answer
76 views

Lining things up in the editor — disparity between preview and post

Yes I know I am being a bit nitpicky, but I like things lined up in neat little rows, damnit. In the preview it looks great: but on the post it lines up according to the editor, not the preview:
2
votes
1answer
288 views

Formatting preview is not accurate for code blocks in numbered lists [duplicate]

Possible Duplicate: Can the </pre> tag start in a new line (possible previewer bug)? Edit this post and look at the preview. Note how the preview incorrectly shows that the following ...
0
votes
0answers
45 views

HTML comment immediately before list handled differently between C# and JS renderer [duplicate]

Possible Duplicate: Unbalanced blank lines after inline HTML comments might break formatting Source: <!-- please keep this list updated! ---> * 1 * 2 * 3 The JS renders: 1 2 ...
4
votes
2answers
482 views

Can the </pre> tag start in a new line (possible previewer bug)?

How is the exact syntax of the <pre> tag? Can I put the closing </pre> tag on a new line? If I do, then the preview is completely messed up, but the final result is as expected. (I know ...
0
votes
0answers
27 views

Tag links doesn't work on preview pane [duplicate]

Possible Duplicate: Tags don't render in preview For example this text: Why tag links doesn't appear on preview? e.g. [tag:c#] Yield this preview:
3
votes
1answer
91 views

PHP version of the markup used for the stackexchange?

Is there a php version of the markup used for the stackexchange, more info on the mark up at Stackoverflow's Markup.
2
votes
2answers
73 views

Inconsistent handling of not-encoded URL in preview [duplicate]

Possible Duplicate: Hyperlink is shown incorrectly in SO post In the preview, the link below is displayed correctly (but is incomplete). After posting, it does not work any more. The brackets ...
11
votes
0answers
184 views

Style XML element in code block messes up syntax highlighting coloring [duplicate]

If you put some XML in a code block (by indenting by 4 spaces) and one of the tags is <Style> it will mess up the syntax highlighting of the generated result. This works: <Style2 Foo="...
4
votes
3answers
195 views

Tags don't render in preview

The [tag:tagname] syntax is now supported in the post, but the preview doesn't recognize them and show them as plain text (i.e. instead of markdown, it is simply displayed as [tag:markdown] ).
0
votes
1answer
57 views

Inconsistent preview with unclosed <pre> tag

The following text: * Boo <pre> Zoo Is previewed as But rendered (at least on my Firefox) as
1
vote
0answers
59 views

Links in answer editor appear correctly in preview, but not in the answer [duplicate]

Possible Duplicate: Hyperlink is shown incorrectly in SO post I my answer I attempt to link to a page in the Oracle Java documentation. The URL of the link is: http://download.oracle.com/javase/...
2
votes
1answer
80 views

Not correctly closing the <sub> tag renders “correctly” in the preview zone but not in the actual text

If you open the <sub> tag and forget to close it in a question's text, it will render text as subscript in the preview zone, but not on the actual question's page. For instance, this text ...
3
votes
0answers
67 views

Bug in preview of ordered lists [duplicate]

Possible Duplicate: Discrepancy between the WMD preview and posted lists Consider the following Markdown code: 1. first * second * third In the client-side preview, this will be displayed as: ...
1
vote
2answers
71 views

Answer preview and final formatting differ in the face of cross-paragraph inline HTML tags

There is a minor bug in formatting preview feature. In the following case, preview shows all text striked out (even text following the </s>), but final formatting doesn't allow cross-paragraph ...
2
votes
1answer
43 views

Preview displays as expected, but actual post cuts text out

In this answer, the second code block cuts off half way through. If you click to edit the answer, the full code block (and a third one) is there, and displays fully as expected in preview pane.