Questions tagged [ssl]

HTTPS (TLS, aka SSL) is newly supported on Stack Exchange. Use this tag for remaining bugs.

Filter by
Sorted by
Tagged with
13 votes
0 answers
61 views

Change "http" to "https" in the tag-info imported for the default tags

On every per-site-meta, there are default tags1 which are automatically created when the site is created. At the same time, the tag-info for some of them is created - although there are a few bugs ...
  • 13.3k
4 votes
0 answers
106 views

Harmonize display names for automatic URL rewrites

A couple of years ago, Stack Exchange switched to HTTPS-only and all internal links were rewritten by (non-bumping) edits by the Community user, like this one here. I just noticed that on Stack ...
  • 225k
6 votes
0 answers
50 views

Change blog link in election text to HTTPS

The introductory text for elections contains the following paragraph with a link that's still HTTP: Community moderators are accorded the highest level of privilege on our community, and should ...
  • 225k
23 votes
0 answers
391 views

Change the HTTP status blog links to HTTPS

In the "We are currently offline for maintenance" page, the status blog link is a HTTP one. Please change it to HTTPS. Also, in the header which is shown when the site is in read-only mode, ...
6 votes
0 answers
40 views

Link to per-site meta in the sidebar/dropdown "Step 1: Draft your question" is not HTTPS and has the old format meta.*.stackexchange.com

Similar to: Link to parent site is not HTTPS in the sidebar/dropdown "Step 1: Draft your question" on any per-site Meta. When asking a question on some SE sites, such as Mathematics the ...
14 votes
1 answer
163 views

Change to HTTPS links in the /users?tab=moderators page

In the /users?tab=moderators page of all SE sites (SO too), there is a link to the election page under each moderator's profile but the links are HTTP. Please change them to HTTPS. Reasons to post ...
8 votes
1 answer
90 views

Link to parent site is not HTTPS in the sidebar/dropdown "Step 1: Draft your question" on any per-site Meta

When asking a question here on Meta SE, the sidebar titled "Step 1: Draft your question" (which appears as a dropdown menu on mobile in the responsive design) has the following text: Is ...
11 votes
1 answer
259 views

Is Stack Exchange affected by the upcoming mass revocation of Let's Encrypt SSL certificates?

For a few years now, Stack Exchange has used Let's Encrypt as their SSL security certificate provider. Just today, a large number of security certificates issued by Let's Encrypt were found to have ...
18 votes
0 answers
85 views

The chat image upload "from the web" is broken for sites that use the new R3 Let's Encrypt SSL certificate

Let's Encrypt expired their X3 root certificate and started issuing certificates with their R3 root certificate at the end of September. The image uploader in chat offers an option to provide an url ...
  • 81.8k
2 votes
1 answer
207 views

TLS for meta.*.stackexchange.com, again

When Stack Exchange transitioned to HTTPS, meta.*.stackexchange.com subdomains were changed to *.meta.stackexchange.com subdomains. The old meta.* subdomains now redirect to the new *.meta subdomains. ...
  • 4,021
1 vote
1 answer
123 views

Links in Stack Exchange security website

I recently found this website: https://stackexchange.com/about/security I noticed this: I don't think that's how the link is supposed to be shown. Please fix it. Also, I noticed some HTTP links. ...
13 votes
0 answers
126 views

Changing http to https and mobile links for Wikipedia

Many old posts with links to Wikipedia articles contain http rather than https links. As far as I can tell, it is better to have https link rather than http. (After all, internal links have been ...
  • 13.3k
2 votes
0 answers
83 views

Certificate Error on Stack Overflow [duplicate]

Every time I open Stack Overflow this happens. But on my laptop it's working fine. This is just only on my PC.
23 votes
2 answers
1k views

Invalid certificate on all SE sites

Sometime this morning my browsers started blocking all Stack Exchange sites with the following error: Your connection is not private Attackers might be trying to steal your information from workplace....
  • 2,862
13 votes
0 answers
126 views

The SSL certificate for the archived Stack Exchange Gaming Blog is invalid

I tried to visit the Stack Exchange Gaming Blog's archive today but was greeted by a classic SSL warning. Turns out, the certificate behind https://blog.gaming.stackexchange.com/ is invalid as it is ...
  • 291
9 votes
0 answers
134 views

Allow to translate http to https migration revision text

Is it possible to make string like this one in revision list: replaced http://ru.stackoverflow.com/ with https://ru.stackoverflow.com/ translatable via standard SE translation mechanism? I suppose ...
44 votes
0 answers
197 views

Can the http://meta.stackexchange.com/ in the Community user’s network profile page be changed to https://…?

The network profile of the Community user, mentions http://meta.stackexchange.com/. Can this be changed to https://meta.stackexchange.com? On copying and browsing it is automatically redirected to ...
  • 2,561
23 votes
1 answer
110 views

Images section in editing help page contains only "http://" examples

In editing help page, in "Images" section there are few examples with the URL. All the URLs are with the http:// only. When tried those example in the editor we received the "All image ...
  • 34.9k
0 votes
0 answers
44 views

Meta.*.stackexchange.com sitewise certificate issue [duplicate]

There is a bug where I see a privacy error on all meta.foo.stackexchange.com sites. For example, if I try to enter meta.retrocomputing.stackexchange.com into my browser, I get this warning: Can ...
2 votes
0 answers
36 views

Incorrect certificate on hatdash.com / blog.gaming.stackexchange.com [duplicate]

It looks like hatdash.com was used during the 2011 Hat Dash. Both of these links use certificates that are invalid for their domains, making the site show as insecure.
  • 6,420
7 votes
0 answers
52 views

License links are not HTTPS in README files of Developer Surveys

I was having a look at the 2020 Stack Overflow Developer Survey Results and noticed that the license links in README_2020.txt are not HTTPS. The links seem to be the same in the previous surveys too. ...
's user avatar
20 votes
1 answer
154 views

Certificate Expired on SEDE

It looks like the SSL certificate for data.stackexchange.com just expired. If you were in the middle of running queries you would be greeted with: Something unexpected went wrong while running ...
  • 81.8k
77 votes
1 answer
2k views

Let's Encrypt certificate issue requiring urgent renewal

Stack Exchange's certificates are in need of renewal ASAP due to the Let's Encrypt CAA rechecking bug. They have sent out notification emails to affected users but I'm reporting this here just in case....
  • 1,643
3 votes
0 answers
109 views

Ubuntu manpages oneboxing has broken, insecure icon

Oneboxing from the Ubuntu man pages site appears to be using a broken, insecure icon: The broken link is http://manpages.ubuntu.com/favicon.ico. Not only is it attempting to load the icon ...
324 votes
5 answers
24k views

TLS 1.0 and TLS 1.1 removal for Stack Exchange services

Update (2020-02-13): This change was completed last night on the Fastly side. Most of our endpoints now have TLS 1.0 and 1.1 disabled. We’ll be addressing our direct load balancers next. Update (2020-...
3 votes
1 answer
146 views

Picture are not shown in all Stack Exchange sites [duplicate]

This is a screen shoot of SE I took from here. That's mine. But mine or others are the same, not working, no image is shown. That's makes it difficult for me to understand a topic. I have tried with ...
18 votes
1 answer
236 views

StackExchange's OAuth login broken - identifying an HTTPS request as non-HTTPS

Recently (as in, the last few hours - however, it may have been broken for a few days), I've been unable to login via Stack Exchange for a third party application with Stack Exchange's OAuth support. ...
  • 1,312
6 votes
1 answer
148 views

HTTP -> HTTPS script didn't change everything [duplicate]

In 2017 the network decided to implement the HTTPS protocol, as was announced in Network-wide HTTPS: It's time. Although that post isn't completely marked as status-completed I think most, if not ...
  • 33.8k
2 votes
0 answers
54 views

Chat makes old per-site meta links HTTPS and broken

I was looking at an old chatroom when I found a link from a feed that was from before per-site metas switched from meta.%.stackexchange.com to %.meta.stackexchange.com. This link, however, was changed ...
  • 9,442
6 votes
1 answer
88 views

URL link issue in data explorer tutorial page

There is an issue with a URL, in one of the Data Explorer tutorial pages. In the Tutorial -> Next Steps page, I can see the following description You can find some interesting queries in this list ...
  • 34.9k
5 votes
0 answers
171 views

Firefox won't open Stack Exchange sites due to "TLS FEATURE MISSING" [duplicate]

I'm running Firefox Quantun, 67.0 (64 bit) on macOS Mojave and it won't load any of the Stack Exchange sites and instead shows a "Secure Connection Failed" page with error code: ...
  • 151
3 votes
0 answers
49 views

Stack Exchange sites currently do not work in Firefox due to broken OCSP stapling [duplicate]

As of a few minutes (hours?) ago, all SE sites except chat present a TLS error in Firefox: An error occurred during a connection to superuser.com. A required TLS feature is missing. Error code: ...
  • 2,484
21 votes
1 answer
442 views

Is anybody else having PKI problems connecting using Firefox 67.0?

I suddenly started getting the following error message when using Firefox to access Stack Exchange sites: An error occurred during a connection to math.stackexchange.com. A required TLS feature is ...
22 votes
2 answers
304 views

Help Center pages contain non-HTTPS links

Pages within the help center have many non-HTTPS links on them. Many of the ones to questions seem to have been updated, but there are non-HTTPS links to the Stack Overflow blog on Don't Ask, links ...
  • 9,442
36 votes
2 answers
388 views

foo.com is sketchy; “How to Format” and help should use HTTPS links in examples

In the “How to Format” bar that shows when editing the body of a question or editing an answer, there is this example for how to format: <http://foo.com> [foo](http://foo.com) <a href="http:/...
  • 9,442
4 votes
0 answers
42 views

Community should add HTTPS to Chat links

Community changed all links to stackexchange.com and stackoverflow.com to HTTPS a while ago. However, it seems to have not done this to links to chat.stackexchange.com, as seen in this search, this ...
  • 9,442
17 votes
2 answers
283 views

Community user profile has a non-HTTPS link in the "About" section

I was recently reading about Community, when I noticed this ironic, very minor, problem in its profile: the link to an answer in the profile's "About" section is not HTTPS. However, Stack ...
  • 9,442
10 votes
2 answers
117 views

Banners of questions migrated from per-site metas prior to HTTPS changeover link to the origin site's old URL, resulting in certificate error

I was browsing through the question Favicon of Earth Science and Spanish are too similar (exactly the same in HNQ list) which got migrated from Earth Science Meta: As you see, the link points to ...
2 votes
0 answers
98 views

Uploader in Chat doesn't use HTTPS

In the uploader in Chat, when putting an image on Stack Imgur from the web, it doesn't make the link it puts in the message use HTTPS. Here is an example of the uploader doing this. This should be ...
  • 9,442
5 votes
0 answers
53 views

Error message for HTTP image sometimes flows over into preview

When editing a post with an embedded HTTP image (example), you'll see an error message asking you to upload it to imgur or specify an HTTPS URL: However, the lack of a line break after the image in ...
  • 225k
3 votes
0 answers
103 views

Got invalid certificate error trying to log in [closed]

I got an invalid certificate error for stackauth.com a few minutes ago when trying to log in to SuperUser via Google. I tried again (after taking a screenshot and blacking out the potentially ...
  • 30.8k
2 votes
0 answers
97 views

SSL Certificate Error on stackapps.com

When checking to see if there is a meta for stackapps.com I found out that there is none (and a different Panda photo than I'm used to seeing). Also there's an SSL certificate error. This is probably ...
  • 15.4k
6 votes
0 answers
102 views

"Connection is not secure" error in some of the promotion pages

The following promotion pages are with the "Connection is not secure" error. https://contests.stackoverflow.com/promos/1 https://contests.stackoverflow.com/promos/2 https://contests.stackoverflow....
  • 34.9k
4 votes
0 answers
144 views

"Connection is not secure" error in all the stackexchange.com pages

In the StackExchange.com and in the all sub pages, I'm receiving the Connection Is Not Secure error. Screenshot for reference:
  • 34.9k
5 votes
0 answers
47 views

OpenID login on SEDE over HTTP is broken, doesn't show error [closed]

I was trying to log into SEDE using the Stack Exchange OpenID function. However, without any erros, I kept not being logged in. Eventually, I discovered I was using the HTTP to connect to SEDE, not ...
  • 8,058
10 votes
0 answers
106 views

Archived Arqade Blog Overflow gets certificate error

http://blog.gaming.stackexchange.com/2012/08/identifying-games-when-you-cant-remember-the-name/ redirects to https://blog.gaming.stackexchange.com/2012/08/identifying-games-when-you-cant-remember-the-...
12 votes
1 answer
272 views

Non-HTTPS images are still served in some cases

Regarding the announcement from last March, Roadmap to HTTPS: serving and uploading HTTPS-images only, has there been a recent change to this policy? Non-HTTPS images are being displayed on some posts....
8 votes
2 answers
186 views

Old HTTP links to SE sites without ending / weren't converted to HTTPS links

About a year ago, several migration scripts were run to change old HTTP network-internal links across the network to HTTPS links. However, it appears that the script didn't modify links that lack the ...
9 votes
1 answer
121 views

Why doesn't Area 51 use HTTPS by default?

On the page https://stackexchange.com/sites, there is a link to Area 51. This link doesn't use HTTPS and Area 51 doesn't redirect to the HTTPS page.
  • 193
12 votes
0 answers
101 views

Don't allow embedded images from non-HTTPS sources in chat

Quite often, I see a mixed content warning when looking at an SE chat room: This is typically caused by images linked in chat hosted on an HTTP source, not an HTTPS one like the SE Imgur account. ...

1
2 3 4 5 6