Questions tagged [ssl]

HTTPS (TLS, aka SSL) is newly supported on Stack Exchange. Use this tag for remaining bugs.

Filter by
Sorted by
Tagged with
17
votes
1answer
181 views

StackExchange's OAuth login broken - identifying an HTTPS request as non-HTTPS

Recently (as in, the last few hours - however, it may have been broken for a few days), I've been unable to login via Stack Exchange for a third party application with Stack Exchange's OAuth support. ...
6
votes
1answer
120 views

HTTP -> HTTPS script didn't change everything [duplicate]

In 2017 the network decided to implement the HTTPS protocol, as was announced in Network-wide HTTPS: It's time. Although that post isn't completely marked as status-completed I think most, if not ...
2
votes
0answers
47 views

Chat makes old per-site meta links HTTPS and broken

I was looking at an old chatroom when I found a link from a feed that was from before per-site metas switched from meta.%.stackexchange.com to %.meta.stackexchange.com. This link, however, was changed ...
5
votes
1answer
57 views

URL link issue in data explorer tutorial page

There is an issue with a URL, in one of the Data Explorer tutorial pages. In the Tutorial -> Next Steps page, I can see the following description You can find some interesting queries in this ...
5
votes
0answers
65 views

Firefox won't open Stack Exchange sites due to “TLS FEATURE MISSING” [duplicate]

I'm running Firefox Quantun, 67.0 (64 bit) on macOS Mojave and it won't load any of the Stack Exchange sites and instead shows a "Secure Connection Failed" page with error code: ...
3
votes
0answers
45 views

Stack Exchange sites currently do not work in Firefox due to broken OCSP stapling [duplicate]

As of a few minutes (hours?) ago, all SE sites except chat present a TLS error in Firefox: An error occurred during a connection to superuser.com. A required TLS feature is missing. Error code: ...
21
votes
1answer
317 views

Is anybody else having PKI problems connecting using Firefox 67.0?

I suddenly started getting the following error message when using Firefox to access Stack Exchange sites: An error occurred during a connection to math.stackexchange.com. A required TLS feature is ...
11
votes
0answers
56 views

Help has non-HTTPS links in it

Pages within the help center have many non-HTTPS links on them. Many of the ones to questions seem to have been updated, but there are non-HTTPS links to the Stack Overflow blog on Don't Ask, links ...
33
votes
2answers
235 views

foo.com is sketchy; “How to Format” and help should use HTTPS links in examples

In the “How to Format” bar that shows when editing the body of a question or editing an answer, there is this example for how to format: <http://foo.com> [foo](http://foo.com) <a href="http:/...
4
votes
0answers
39 views

Community should add HTTPS to Chat links

Community changed all links to stackexchange.com and stackoverflow.com to HTTPS a while ago. However, it seems to have not done this to links to chat.stackexchange.com, as seen in this search, this ...
12
votes
0answers
71 views

Community user profile has a non-HTTPS link

I was recently reading about Community, when I noticed this ironic, very minor, problem in its profile: the link to an answer in its profile is not HTTPS. However, StackExchange moved to HTTPS ...
11
votes
2answers
98 views

Banners of questions migrated from per-site metas prior to HTTPS changeover link to the origin site's old URL, resulting in certificate error

I was browsing through the question Favicon of Earth Science and Spanish are too similar (exactly the same in HNQ list) which got migrated from Earth Science Meta: As you see, the link points to ...
2
votes
0answers
92 views

Uploader in Chat doesn't use HTTPS

In the uploader in Chat, when putting an image on Stack Imgur from the web, it doesn't make the link it puts in the message use HTTPS. Here is an example of the uploader doing this. This should be ...
5
votes
0answers
49 views

Error message for HTTP image sometimes flows over into preview

When editing a post with an embedded HTTP image (example), you'll see an error message asking you to upload it to imgur or specify an HTTPS URL: However, the lack of a line break after the image in ...
3
votes
0answers
77 views

Got invalid certificate error trying to log in [closed]

I got an invalid certificate error for stackauth.com a few minutes ago when trying to log in to SuperUser via Google. I tried again (after taking a screenshot and blacking out the potentially ...
1
vote
0answers
50 views

SSL Certificate Error on stackapps.com

When checking to see if there is a meta for stackapps.com I found out that there is none (and a different Panda photo than I'm used to seeing). Also there's an SSL certificate error. This is probably ...
5
votes
0answers
88 views

“Connection is not secure” error in some of the promotion pages

The following promotion pages are with the "Connection is not secure" error. https://contests.stackoverflow.com/promos/1 https://contests.stackoverflow.com/promos/2 https://contests.stackoverflow....
3
votes
0answers
131 views

“Connection is not secure” error in all the stackexchange.com pages

In the StackExchange.com and in the all sub pages, I'm receiving the Connection Is Not Secure error. Screenshot for reference:
3
votes
0answers
41 views

OpenID login on SEDE over HTTP is broken, doesn't show error

I was trying to log into SEDE using the Stack Exchange OpenID function. However, without any erros, I kept not being logged in. Eventually, I discovered I was using the HTTP to connect to SEDE, not ...
9
votes
0answers
97 views

Archived Arqade Blog Overflow gets certificate error

http://blog.gaming.stackexchange.com/2012/08/identifying-games-when-you-cant-remember-the-name/ redirects to https://blog.gaming.stackexchange.com/2012/08/identifying-games-when-you-cant-remember-the-...
4
votes
0answers
57 views

Are non-HTTPS-images now being served?

Regarding the announcement from last March, Roadmap to HTTPS: serving and uploading HTTPS-images only, has there been a recent change to this policy? Non-https images are now being displayed. For ...
8
votes
2answers
172 views

Old HTTP links to SE sites without ending / weren't converted to HTTPS links

About a year ago, several migration scripts were run to change old HTTP network-internal links across the network to HTTPS links. However, it appears that the script didn't modify links that lack the ...
9
votes
1answer
119 views

Why doesn't Area 51 use HTTPS by default?

On the page https://stackexchange.com/sites, there is a link to Area 51. This link doesn't use HTTPS and Area 51 doesn't redirect to the HTTPS page.
10
votes
0answers
67 views

Don't allow embedded images from HTTP sources in chat

Quite often I see a mixed content warning when looking at an SE chat room: This is typically caused by images linked in chat hosted on an HTTP source, not an HTTPS one like the SE Imgur account. ...
4
votes
0answers
62 views

“How to not be a spammer” help page contains badly-rendered HTTP link on all sites

See the image below. The link to the Meta post is not in HTTPS on all sites (including SO, SU, SF, AU), at this page: https://*.stackexchange.com/help/promotion As I tweaked in the F12 Developer ...
6
votes
1answer
295 views

CAPTCHA doesn't present words

I know there's a new invisible form of CAPTCHA, but I'm not sure what words should be entered. Am I missing something? Browser logs: This may or may not be due to the HTTPS issue reported in ...
14
votes
1answer
43 views

Questions migrated from the meta site get the wrong link to the original question

See for example Why is there a module for version 9 of core? migrated to Drupal Answers from its meta site. The link given in migrated from meta.drupal.stackexchange.com Oct 19 '13 at 16:40 points to ...
7
votes
1answer
100 views

Winter Bash 2017 : Authentication screen with http:// URL

When I access the Winter Bash 2017 and click the log in option in the top bar, I get the following the authentication screen. There the URL for the winter bash 2017 is http://. Can this URL be ...
-10
votes
1answer
60 views

How can SO query's result did not encrypt the id?

What's the reason StackExchange Data explorer website didnt encrypt the id of the query result ? I mean it's just give the result like postId=1 or postId=655011. Does it make the data in SO vulnerable ...
4
votes
1answer
89 views

Is SEDE secure?

The Stack Exchange Data Explorer aka SEDE is not mentioned in Network-wide HTTPS: It's time. It is not listed in any of the steps, which makes sense as it's not officially part of Stack Exchange, ...
14
votes
3answers
153 views

stackpromos.com HTTPS cert is invalid

The certificate presented does not work for stackpromos.com, leading to a warning in my browser about an invalid certificate.
1
vote
0answers
27 views

Certificate invalid? [duplicate]

I'm not sure what caused this, but my Chrome detected the certificate from *.stackexchange.com invalid for discuss.area51.stackexchange.com This is what I've done: Open this user's chat profile page ...
7
votes
0answers
37 views

Unable to translate error message when post contains a non-https image

If you place the following code into the post body: [![text][1]][1] [1]: http://1 you will see an error message: Text of this message is not available to translate via Transifex. All image ...
3
votes
0answers
29 views

Community Promotion Archive is not secured yet

With all of Stack Exchange sites (except chat) fully secured now, one site was forgotten: the community promotion archive. Trying to change to https manually leads to "Your connection is not private" ...
3
votes
0answers
42 views

HTTPS image conversion didn't work for .ico files

In Roadmap to HTTPS: serving and uploading HTTPS-images only, Step 3 said: After this is enabled, old posts that have HTTP images, accessible via HTTPS, will be edited accordingly. This will be ...
8
votes
1answer
91 views

Ugly look on custom error page on chat because of request to HTTP resource

I was visiting some transcripts from a chat room and then I found a link to another room which was removed. On that custom error page, I found two main issues and one was caused by another main issue. ...
1
vote
1answer
130 views

Invalid certificate for https://www.*.stackexchange.com [duplicate]

Stack Exchange will do a permanent redirect from www to non www for all Stack Exchange sites. This works fine without SSL but, with SSL the browser will throw an Insecure Connection error due to the ...
20
votes
0answers
101 views

A bot script needs to be run to convert meta.[site] URLs to [site].meta URLs

The Community bot already ran through posts to convert internal http:// links to https://, which is great, but it needs to be run one more time: this time, it needs to convert links of this format: ...
8
votes
0answers
72 views

Fix http://data.stackexchange.com to https://data.stackexchange.com with Community♦ for correct session handling

If I click on an HTTPS link to https://data.stackexchange.com, I will be identified: But if I click on an HTTP link to http://data.stackexchange.com, I will not be identified: This HTTP issue ...
24
votes
0answers
165 views

Convert http links to https in tag wikis

As part of the migration to HTTPS, a bot rewrote http:// links pointing inside the Stack Exchange network to https://. This bot only ran on questions and answers. Please run the bot on tag wikis as ...
3
votes
0answers
52 views

Still HTTP links in /tour on various sites

<Something> Stack Exchange is a question and answer site for <some people>. It's built and run by you as part of the Stack Exchange network of Q&A sites. With your help, we're working ...
-2
votes
1answer
34 views

Should we force users to post links to SE sites in HTTPS?

Network-wide HTTPS is a good idea. SE devs have been working hard to replace existing HTTP links to HTTPS, and they even batch replaced links in existing posts with the Community bot on May 20[...
5
votes
2answers
97 views

HTTPS certificate error for meta redirect pages (meta.<site>.stackexchange.com)

Visiting https://meta.security.stackexchange.com displays an HTTPS certificate error in Google Chrome and Internet Explorer 10. For reference, meta.<sitename>.stackexchange.com is the old URL ...
4
votes
0answers
34 views

Change links in errors and warnings to HTTPS

Another question here on Meta brought something to my attention. Most links in errors and warnings that come up when posting or editing still are HTTP. I have a few examples listed below from various ...
10
votes
0answers
116 views

Messaging failed, Houston didn't get contacted

In the answer on Which browsers are officially supported, and what else do I need? a link is offered to the Network Login Help page. I'm not sure if that page is still relevant given the changes ...
3
votes
0answers
27 views

When changing profile picture, the current picture is loaded via HTTP

When changing profile picture, a request is made to /users/popup/change-picture/<user-id>, which returns HTML displayed in a popup. This HTML contains an <img> tag with an HTTP link, for ...
5
votes
1answer
77 views

Link to reputation league from profile page is HTTP

The link to reputation leagues from the Activity and Profile tabs are HTTP.
4
votes
1answer
53 views

“View more [accounts]” link on user profile page is HTTP

The "View more" link below the list of accounts on user profile is HTTP instead of HTTPS. Other stackexchange.com links are also HTTP, for example link to the network profile.
5
votes
1answer
59 views

Mixed content error in Network profile - activity tab

In the network profile activity tab, when trying to expand the answered or asked posts, we are getting the following mixed content error: Mixed Content: The page at 'https://stackexchange.com/users/...
5
votes
0answers
45 views

Chat links to Meta sites have been rewritten with invalid HTTPS

Way back in 2015, a feed bot posted a link to a meta question in a chat room. The link was, in those pre-HTTPS days, http://meta.christianity.stackexchange.com/. However, if you click on it, you are ...