Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
1 of 100

Last updated: Nov 30, 2010

We support current and previous versions of all browsers with some reasonable amount of market share, but not beta or dev versions.

-Jeff, paraphrased (source)

  • Internet Explorer
    • IE 6 — unsupported (source)
    • IE 7 — minimally supported (source 1, source 2)
    • IE 8 — supported (current version)
    • IE 9 — unsupported (beta version)
  • Firefox
    • FF 2 — possibly supported (if it counts as the previous version)
    • FF 3.5 — supported (previous version)
    • FF 3.6 — supported (current version)
  • Chrome
    • Chrome 6 — supported (previous version)
    • Chrome 7 — supported (current version)
    • Chrome 8 — unsupported (beta version)
    • Chrome 9 — unsupported (dev version)
  • Opera
    • Opera 8 — unsupported (not even mentioned in late 2009)
    • Opera 9 — supported (previous version)
    • Opera 10 — supported (current version)
  • Safari
    • Safari 4 — supported (previous version)
    • Safari 5 — supported (current version)
  • Lynx
  • Other
    • unsupported

This answer is community wiki; please feel free to update it with new information.