Escape it with a backslash? That works for many things in Markdown. Alternatively, use one of the HTML entities for the pipe character, e.g. | (or the more meaningful | as mentioned by @GalaxyCat105). The following Markdown: |foo|bar | |---|------| |\| ||| produces this: foo bar | |


I posted this on meta S.O originally because I couldn't post it here (not enough rep) but apparently that restriction was removed and I was told maybe I should repost it here. I tried to post this markdown table in an answer on S.O | Number of bytes | First code point | Last code point | Byte 1 | Byte 2 | Byte 3 | Byte 4 | | - | ------- | -------- | -------- ...


The problem is this block of code near the end of your post: ``` SELECT *, ((longitude - 9.876543210987654321) ^ 2 + (latitude - 1.234567890123456789) ^ 2) AS squared_dist FROM tbl WHERE ((longitude - 9.876543210987654321) ^ 2 + (latitude - 1.234567890123456789) ^ 2) < 0.000000001 -- or whatever ORDER BY point (longitude, latitude) ...


This bug has been fixed in Markdig, the server-side Markdown renderer we're using. I just updated the version we use to the one including the bugfix for this specific issue. Moving forward, you should see a proper level-2 heading in blockquotes with the syntax you gave in your example.


As the other answers have mentioned, you could escape it with a backslash, which is probably a better solution than mine, but you could also use the HTML entities &vert; or &#x7C; in place of the pipe character. |Code |Comment | |------|-----------| |a &vert; b | Comment 1 | Code Comment a | b Comment 1


Do the displayed tables have to be full width? Or, more accurately, when a table is simple and small, as (for example), in this SQL question on Stack Overflow, it would be nicer to my way of thinking if the tables did not expand to the full width. The tables there are: ID Name 157 Bob 157 James 300 Phil 300 Keith 300 Paul and: ID Name 157 Bob, James ...


Stack Snippets are indeed rendering eagerly, even inside code blocks. This original bug report never got an official response and no answer to address workarounds. Your only choice seems to be using HTML. Wrap the content of the code block between <pre><code> and </code></pre>, and replace every < in the content of the code block ...


The escape character you're looking for is a backslash: |Code |Comment | |---------|-----------| | a \| b | Comment 1 | This gives: Code Comment a | b Comment 1


It can be done on the sites where Latex (more clearly, its Javascript implementation named "MathJax") is enabled. These are mostly the science-related sites and their metas. On the SO, it is not enabled (it might have a little performance reason. It might have "funny side-effects" in code, for example Latex code must go between $...$, ...


While we wait for this feature to be implemented, here is a trick you can use from within excel to convert the data into markdown format: In an empty cell to the right of the first row of the data, use this formula: =CONCATENATE("|",TEXTJOIN("|",FALSE,A1:C1),"|") where A1 and C1 should be updated to reflect the starting and ...


3D = 61 ₗₒᵣₑₘ IPSUM WƎᴚO˥ 𝕀ℙ𝕊𝕌𝕄 L̝̤̯̜̙ò̫̪̰͓ͅr̘͢e͡m͏̰̩ Ì̷̷̟̙̮͙͖̖͍̘͓͘P̡̤͖͔̮̜̥̭͉̻̞̹̫Ś̢̘͚͕͎͜Ų̛͙͎̮̦͙̠͙̬̮̠̺̭͓̭̮́̕M̷̨̻͔̼̘͇̫͇̣̠̖͉̟̟̕͡ print("Lorem") IPSUM H̅̋ͥ̓͛̽ͬ̆́͂̔̾ͬ҉̴̢̨͈̱̘̟ï̴̶͉͍̘͚̥͈͌ͪ̒ͣ̾̈́ͭ͗ͪͭ͟g͊ͨ͐͆̔̑͆ͫ͏̬̞̗̲̱̪̞̜̩͔́͞ͅh̷̰̬̼̯̝̫̩̜ͦͭ̌ͦͬͯ̚͟


Just click on the question mark at top right of the edit box.


All text to the right of a table is ignored. Column 1 Column 2 Column 3 1.1 1.2 1.3 2.1 2.2 2.3 I am not sure if this was done on purpose. If it is not a bug, adding this caveat in the post would be helpful. How did I encounter this issue? I was editing some posts on Stack Overflow with "hardcoded" tables (I don't know what's the term for ...



Only top voted, non community-wiki answers of a minimum length are eligible