3

I was just trying to help a user discover why his sql had injection problems, but adding a comment with drop (heretofore known as [d word]) and table (heretofore known as [t word]) together gave an error:

An error occurred during comment submission.

Basically trying to avoid any Little Bobby Tables problems I'd imagine.

This doesn't happen on meta, or at least didn't when that post occurred.

I didnt find any immediate examples on SO of users putting [d word] [t word] in the comments, but am pretty sure that I used to be able to do this.

It seems odd that SO would restrict my language in a comment.

Is the sanitation of comments so difficult that it cant allow this?

Are there any other phrases that I should look out for?

Could the error be a bit more specific so that it would be obvious the problem in the language?

EDIT:

Clearly this is a new issue, I just tried to submit this article with [d word] [t word] together in the title and body and it gave me a generic error.

An error occurred submitting the question.

EDIT 2:

@Mysticial and I just discovered that it may have something to do with rep. In which case, what is the rep to be able to put [d word] [t word] into your posts/comments?

12
  • drop table... err... no repro here – Mysticial Mar 20 '14 at 22:58
  • @Mysticial wow.. i try it and get an error. Could it be a rep thing? – crthompson Mar 20 '14 at 22:59
  • 1
    Oh ic... SE trusts me with the power to drop tables, but not the OP. ahahaha – Mysticial Mar 20 '14 at 23:00
  • 1
    I seriously doubt that SE would have such idiotic input sanitisation anywhere. Are you sure you're not just, say, having intermittent internet problems that caused an AJAX call to fail? – Mark Amery Mar 20 '14 at 23:05
  • Something on your end is blocking outgoing requests with possible SQL injection. Overzealous anti virus is likely culprit. Hunt it down and destroy, or at least disable, it. – Shadow The Vaccinated Wizard Mar 20 '14 at 23:06
  • @ShadowWizard, on my end huh? That would be crazy, tho not impossible i suppose. I will try on a virtual machine. – crthompson Mar 20 '14 at 23:08
  • could you quote the exact comment you tried here (since meta seems fine with it) – Richard Tingle Mar 20 '14 at 23:15
  • 1
    @RichardTingle, thats just it. Meta isnt fine with it for me. It might be as Shadow suggests, just some big brother feature of my work's network. I'm testing that now. – crthompson Mar 20 '14 at 23:16
  • I wonder, I wouldn't be suprised if your work network stripped it out. I guess give it a try from home (or mobile) – Richard Tingle Mar 20 '14 at 23:21
  • testing drop table from azure vm – crthompson Mar 20 '14 at 23:26
  • 4
    It is obviously my network. Thank you @ShadowWizard for the suggestion. I will ask why my IT guys are so paranoid. – crthompson Mar 20 '14 at 23:27
  • Cheers @paqogomez glad it's sorted out, even if not solved. :) – Shadow The Vaccinated Wizard Mar 21 '14 at 0:47

Browse other questions tagged .