If you type [so] in chat, it auto-expands to "Stack Overflow". This is a problem in http://chat.stackexchange.com/rooms/95/english-language-usage, since you might type "so" in brackets to indicate an editorial change in a quote.

This happened in this chat message.

The same behavior occurs in comments (including on EL&U).

Proposed fix

Disable the expansion for [so] and [So], at the very least on EL&U and its chat rooms.

Note that you can still use the [SO] expansion for Stack Overflow. I expect most people already use the capitalized abbreviation for SO anyway.

  • I think you can put ``` marks around it so that it's not interpreted by the editor. Unfortunately, the [] notation is used throughout the network for certain shortcuts, so I don't see this changing, and I'd hardly call it a bug. People just need to learn how to use the editor. ;) – jmort253 Sep 27 '12 at 3:43
  • 1
    @jmort253: Those marks make it look ugly, and they draw attention to the formatting, which is usually unwanted. – Cerberus_Reinstate-Monica Sep 27 '12 at 4:39
  • 2
    Its call Magic Links – Lucifer Sep 27 '12 at 4:42
  • 1
    I kinda doubt anyone capitalizes these intentionally; the whole point is to save keystrokes. – Shog9 Sep 27 '12 at 5:03
  • 3
    The Stack Overflow crowd says: nay – prusswan Sep 27 '12 at 5:18

I agree. It was funny, but wrong. I would like to see this changed. Normal words in square brackets should not change into something unexpected: it is as unfortunate as some websites that change :) into a smiley. shudders It should be changed into something like [[so]]; there is a reason Wikipedia uses double brackets, not singles.


This is a year-old feature, documented here, meant to ease the lives of everyone who's constantly pointing users towards the various sites in the SO family or the FAQ.

The request and subsequent answer describing the completed feature were well received (126 and 109 net votes currently), so unless this question sees significant support, it's unlikely to be turned off globally.

The selective disabling you suggest is certainly possible, but might involve significant work for what's a fairly esoteric use-case (editorial changes in quotes of a limited number of magic words). Obviously the use-case is common enough that you stumbled onto it, but I would want to see some numbers relating to magic link usage before deciding that it's more useful to have [so] not auto-expand in chat/comments.

Selective disabling also invites future questions/bug reports on Meta about why the magic links don't work on EL&U.

  • Ah,,, i was searching for this question, good that you have found it, +1 – Lucifer Sep 27 '12 at 4:40
  • 1
    @Lucier: Why can't it be changed into something like [[so]]? There is a reason Wikipedia uses two brackets, not one. – Cerberus_Reinstate-Monica Sep 27 '12 at 4:41
  • 1
    @Cerberus, You should contact to the developer who developed it, Its not me. – Lucifer Sep 27 '12 at 4:44
  • @Lucier: Oh oops, I meant to address Blahdiblah, my apologies. – Cerberus_Reinstate-Monica Sep 27 '12 at 4:47

Workaround: escape with backslashes

You can avoid this problem (and any similar problem with Markdown-reserved characters) by escaping them with a backslash. This removes all special meanings for the following character. For example, to write [so], the corresponding Markdown is \[so\].

  • [so], you're right! It works! – jmort253 Sep 29 '12 at 8:19

I love the magic links!

I use those probably 20 times a day (~1.1k chat messages per week chat messages).

Whereas, I probably have never yet put the word so in 'editorial brackets'. Make that \[so] and: problem solved

So no, I don't think it should be 'fixed', (in fact I'd love it if it were easier to link to questions/answers like this [post:123456], but I digress).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .