14

(N.B., this is not affecting me, who uses Google auth., but has been reported by multiple people within the Meta Discussion discord).

Upon trying to log in, the error:

An error occurred with log in.

is returned:

enter image description here

This is affecting multiple people, including different accounts, with the people located in different places geographically.

It appears to only affect those using email/password for authentication, not 3rd party SSO.

7
  • 6
    In case devs need to check logs, this affects at least my account, Boson, and a charcoal member tried logging into SmokeDetector with the same error. It is likely limited to email login. Verified in two different scripted environments (read: bots), as well as browsers (running rev 2024.1.9.3159) Jan 9 at 23:17
  • 8
    Hey folks, our Site Reliability Engineering team is currently troubleshooting this issue. Please follow this StackStatus incident for updates.
    – Slate StaffMod
    Jan 9 at 23:43
  • 1
    This affected my account about two hours ago. For a moment I thought I was banned, but then I realized I hadn't done anything to get banned. Jan 10 at 0:58
  • 6
    @RobertColumbia ... yet. :D Jan 10 at 1:34
  • 2
    Thank you for posting this; I had been impacted (being locked out) and this post helped me to understand the situation.
    – Levente
    Jan 10 at 13:00
  • 2
    SRE reports that this bug should be fully resolved. Thank you again for the report
    – Slate StaffMod
    Jan 11 at 18:25
  • 2
    @Slate maybe answer with some details? Thanks! Jan 11 at 19:01

1 Answer 1

8

Recent Incident with Email/Password Log In - January 9th, 2024

Starting on Tuesday, January 9th at 20:45 UTC, we received an alert that our OpenId Provider was receiving timeout exceptions to its Redis instance. This resulted in users being unable to log in or sign up using an email and password across all Stack Exchange network sites (including Stack Overflow) and Stack Overflow for Teams (Free, Basic, and Business). Other authentication providers (e.g. Google, GitHub, Facebook, etc.) remained unaffected.

To mitigate this issue, we attempted to failover to a different region, but the failover environment was experiencing similar issues. We tried various other measures to reestablish the connection between the application and Redis. Eventually, we determined the issue was due to the DNS servers being configured incorrectly. We switched the DNS servers referenced by the application and that ultimately resolved the issue.

During the incident, there were some confusing signals in our observability pipeline that delayed our ability to effectively diagnose and remediate the issue. Specifically, the health check endpoint on our OpenId Provider application was returning a successful response (albeit rather slowly) even though the Redis instance was unreachable. The health check endpoint also failed to log the errors from Redis. Both of these issues have since been addressed.

We’ve also improved our alerting for both the active region and our failover region. This will help ensure that we have a healthy failover instance that we can use to mitigate any future incidents more quickly.

We would like to thank our community for their patience and understanding during this incident.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .