8

https://chat.stackexchange.com/login/global doesn’t work. The “help” / diagnostics page presents me with this information:

  • Test 1: JavaScript – ok
  • Test 2: Cookies – ok
  • Test 3: Messaging – ok
  • Test 4: Storage – ok
  • Test 5: Communication with stackauth.com – failed
    • IFRAMEs – ok
    • Referrer – failed
    • JavaScript – ok
    • Time – ok
    • Storage – failed

I’m on Chrome 24.0.1312.57 / OS X. I use a plugin to block referrers and third-party cookies. I do not block localStorage. Finally, chat.stackoverflow.com works, only chat.stackexchange.com fails.

The fallback login option via stackexchange.com also fails, “No referer was present - this may be due to a browser setting”. When disabling the referrer blocker, this option at least works (but the normal login still doesn’t).

11
  • Try again - I just had issues with accessing StackAuth.com but it seems to back accessible now.
    – tombull89
    Feb 27 '13 at 10:13
  • @tombull89 No change. Feb 27 '13 at 10:14
  • @KonradRudolph: Try clearing your cache, then try to refresh. Feb 27 '13 at 10:19
  • @Madara I did that of course. Feb 27 '13 at 10:21
  • And if you disable the plugin that block referrer? Feb 27 '13 at 10:39
  • @Sha That’s not something I want to do. Feb 27 '13 at 10:56
  • @KonradRudolph just for test purpose; if you prove that's the case you can ask to change the login behavior and not require referrer. Then enable the plugin again. :) Feb 27 '13 at 11:02
  • @Sha Makes sense. See update. Feb 27 '13 at 11:14
  • So sounds like the storage is failing... maybe it's full? Try to empty Chrome local storage, unless you have stuff you know you want to keep in there. Feb 27 '13 at 11:57
  • @Sha My local storage isn’t full, I tried clearing it before without success. Feb 27 '13 at 12:39
  • This is still broken. Any feedback?! Feb 6 '14 at 11:46
5

I had the exact same issue and could not find a solution with the help given.

Going to:

Settings > Privacy > Content Settings > Manage exceptions

and adding

*[**.]stackexchange.com

*[**.]stackauth.com

to make sure those sites can communicate third-party cookies and site data fixed the error message and I got

Storage – ok

On the login test page.

For the workaround login ("No referer was present - this may be due to a browser setting"), disabling referrer-blockers and (!) https everywhere-plugins seems to be required.

3
  • Oh this sucks. I simply don’t manage to create exceptions for the referrer-blocking which make this work, disabling seems the only option. Aug 23 '13 at 10:57
  • Fantastic! I was having the same issue. I disabled 'HTTPS Everywhere' and the chat is working again. Thanks, buddy.
    – Adi
    Sep 26 '13 at 12:24
  • 1
    Instead of disabling HTTPS Everywhere completely (!!), I checked the "Experimental rules: May cause warnings or breakage. Disabled by default. => Stack Exchange (mixed content)" option in the plugin's configuration option and it worked. Too bad Stackexchange delivers mixed content though :-\
    – ckujau
    Jan 22 '14 at 23:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .