Using the Stack Exchange login, why do I have to enter my password again and again to log in? Wasn’t the whole purpose of OpenID to do away with this?

This doesn’t even only happen when visiting a new Stack Exchange site – it also happens for sites where I already have an account but which I don’t visit regularly. Here’s what I mean:

Login dialog

Of course I don’t remember my password (it’s a long random string). And so I have to go to my password manager and manually copy the password from openid.stackexchange.com’s account into the login form. – And incidentally, this is what my password manager looks like now:


(And, by the way, those are the only entries in my keychain so far, but by far not the only SE sites where I have an account.)

… I feel that this defeats the purpose of site-wide login and OpenID. In the olden times when MyOpenID was still working properly, I’d simply enter my OpenID on the login form, and the software would take care of the rest – namely, redirect to the OpenID service, (automatically) verify that I was authorised to use it, and redirect back to the original website, having logged me in. It was literally one button click for me. It’s substantially more work now, and I’d like to understand why this regression is necessary.

(Note: of course once a site’s password has landed in my password manager I (probably?) won’t have to enter it again. But still: wasn’t site-wide login and OpenID supposed to solve this already?)

  • What browser? Any chance you disabled local storage somehow? – Shadow Wizard is Ear For You Mar 11 '14 at 14:13
  • @ShadowWizard Chrome, and what does local storage have to do with that? – Konrad Rudolph Mar 11 '14 at 14:14
  • Credentials are stored in local storage, that's how they auto login the users as far as I know. – Shadow Wizard is Ear For You Mar 11 '14 at 14:21
  • @ShadowWizard Interesting, although that wouldn’t really answer my question, since this used to work previously, and without local storage. Apart from that, I haven’t disabled local storage (and I’ve just verified that it works). – Konrad Rudolph Mar 11 '14 at 14:28
  • Local storage is definitely required. IIRC, it was a workaround on their end to allow SE-wide SSO ("Welcome back derper! You've been logged in" message is indicative of this). Note, it sounds like you're saying that you didn't have to use a password with OpenID, which isn't true as you know. If I wasn't logged into MyOpenID when a redirect took me there, I'd have to do two-step auth.... – user1228 Mar 11 '14 at 14:53
  • @Won't MyOpenID used cookies to keep me logged in. If I went to a new website which redirected to MyOpenID, I did not have to re-enter my MyOpenID password. I’d expect the same to happen for the Stack Exchange OpenID. – Konrad Rudolph Mar 11 '14 at 15:18
  • @KonradRudolph: Cookies crumble. Also, they don't sync (normally) across machines. And when your cookie doesn't exist or has gone stale... come on, say it with me... You have to enter your password, yeah. That's right. – user1228 Mar 11 '14 at 17:38
  • @Won't You said “local storage is definitely required”. But like I’ve just explained to you, for the scenario which I’ve described, it’s not required. Local storage would offer more than cookies, but it’s definitely not required to make the scenario here work (i.e. that I don’t have to re-enter my password even when I’m logged in on other SE sites on the same machine). – Konrad Rudolph Mar 11 '14 at 18:39
  • @KonradRudolph: A team member is going to have to clarify. I do specifically remember that local storage is used to hold auth info. If you've already logged into, say SO, within browser X, then close browser X, then open it back up again and browse to SO, you'll be asked to "click here" to login via a popup that floats over the top bar. You won't have to enter any password. If you can't repro that, you may have other issues (local storage is unavailable, browser is derping, etc). – user1228 Mar 11 '14 at 19:29
  • @Won't I don’t get a popup. I’m just automatically logged in again. And it’s possible that this is done via local storage. But, again, that’s also entirely possible using persistent cookies. This has been around a decade before local storage was a thing. – Konrad Rudolph Mar 11 '14 at 20:32
  • @KonradRudolph: Yeah, I know. Wish I could find the question where someone on the team said they were using local storage for saving auth info... – user1228 Mar 11 '14 at 20:34
  • I have the same problem since this new login page. I guess these here, too: Problem with using StackExchange OpenID, New Login Page, Global Network Login not Working – unor Mar 21 '14 at 15:50
  • Why is this still an issue? Isn't the whole point of this federated identity management thing so that we don't have to keep putting in our passwords? I would understand the need for sites where we don't have an account, but I have to keep doing this for all my stackexchange sites I'm already registered for. A simple remedy would be to remove that for those already signed in and offer a "Confirm Log-on" button to the site. There, problem solved. – ThatRandomGuy Nov 16 '18 at 23:52

Workaround until this (hopefully) gets fixed:

  1. When trying to login, click at More login options.
  2. Enter https://openid.stackexchange.com/ into the input field which says "Or, you can manually enter your OpenId".
  3. You get redirected to openid.stackexchange.com, where you have to click at Confirm.
  4. You get redirected back to the site you want to login. If you didn’t have an account on that SE site, it asks you to click at Confirm And Create This Account.
|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .