5

When I try to apply for this position at Careers, I get redirected to an error page. The error page is just a message saying "Object moved to here" with a broken link (404) and a JavaScript empty alert.

Steps to reproduce:

  1. Click on "apply now"
  2. On the popup, click on "Gmail". Note that this popup surprised me, it's the first time I have seen it.

Screenshots:

Job position

Job position

Error page

Error page

  • This does not repro for me with the steps listed. Can you please try again? – Nick Larsen Nov 19 '14 at 21:49
  • @NickLarsen I tried again, this time on Ubuntu. The error page shows up, but no javascript alert and the default mail client (Thunderbird) shows up after a while. – orique Nov 20 '14 at 13:14
  • 1
    Thanks for the input. I'll fire up some different scenarios and see what we can come up with. – Nick Larsen Nov 20 '14 at 15:16
  • Can you let us know what browser you're using there? Looks like some of the CSS is rendering incorrectly too (repeated Gmail icons). – Dean Ward Nov 20 '14 at 15:33
  • Not to worry reproed in Firefox – Dean Ward Nov 20 '14 at 15:36
  • @DeanWard Firefox 33.0 – orique Nov 20 '14 at 15:38
3

Well, what it should be doing is open a new tab/window with a new gmail message having a pre-set fields.

When on its own, it works fine, see here: http://jsfiddle.net/scqcyqxj/

But some JavaScript voodoo on the Careers page cause it to fail, for me it's opening Outlook and probably you don't have Outlook thus you get the ugly error.

Not a fix, just hope to help clarify the problem.

  • True, I'm using Firefox on Windows without Outlook FWIW – orique Nov 19 '14 at 20:43
  • 1
    @orique can you try and set gmail as the default email client? See here, it might solve the issue for you until the bug is fixed. :) – Shadow The Princess Wizard Nov 19 '14 at 20:47
  • Done, thanks for the help! – orique Nov 19 '14 at 20:58
  • @ShadowWizard Just curious....why make this a CW post? – Shokhet Nov 20 '14 at 2:08
  • @Shokhet well, it's not a fix to the bug more like an extended comment so I feel it's wrong to gain rep from this. – Shadow The Princess Wizard Nov 20 '14 at 8:14
4

This was because our analytics hijacks the click before it has a chance to do its thing. When the analytics is done it redirects the caller back to the original URL.

For the webmail links it is supposed to return the URI to the provider, but instead it would attempt a redirect to the mailto: URI instead. Behavior varies across browsers - in some it cancels this redirect, in others it will act upon it; this is the behavior you were seeing in Firefox.

Anyway, I've pushed a fix that works for me on IE, Firefox, Safari and Chrome. It doesn't work on Lynx however :)

  • Thanks! I tried it again and can confirm the icons are now OK, the error page is gone... BUT a final glitch is that fields don't get populated (Firefox 33.1 on Windows 7, clicking on GMail link). – orique Nov 20 '14 at 17:28
  • 1
    Thanks for verifying. Latest push resolves the last issue! – Dean Ward Nov 20 '14 at 18:03
  • All ok now! :-) – orique Nov 20 '14 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .