0

I am logged in to Stack Exchange/Arduino with my StkEx OpenID. I followed a link to a Stack Overlow question, where I am also a member (I have some rep and badges there), but SO doesn't recognize me as logged in.

I returned to my Arduino profile -> Network Profile. My network profile says I have some rep and some badges in SO. I followed that link to my SO profile which does exist and agrees with the Network Profile (rep and badges). Yet following any SO link on my SO profile page displays SO as though to a stranger. Those would be the SO logo in the upper LH corner of my profile page, and clicking on one of my own SO questions listed on my SO profile page.

Why is SO asking me to log in again, while I am logged in?

Update: Requested screenshots:

Logged in at Arduino:

enter image description here

, yet unrecognzied at SO:

enter image description here

  • Log in is not forever. Just log in again, and you should be, well, logged in. Can't see any problem here. – Shadow The Princess Wizard May 9 '17 at 14:38
  • @ShadowWizard: But I am loggged in. – JRobert May 9 '17 at 14:41
  • Each domain got different login behind the scenes, and Stack Overflow got its own unique domain. Being logged in on site X does not mean you are logged in on site Y. – Shadow The Princess Wizard May 9 '17 at 14:42
  • 1
    Not dupe; not even related. I am logged into stack exchange. I can move freely among my groups - except that one. – JRobert May 9 '17 at 14:43
  • Yet again. Stack Exchange is a network of sites, not one single super site with different names. Each site in this network got accounts of its own, and possibly whole login mechanism of its own. I can't explain this better, sorry. – Shadow The Princess Wizard May 9 '17 at 14:44
  • @ShadowWizard Once you log in on one site you'll be logged in already when you visit any other site you have an account on, regardless of domain (well, at least with Google logins, the OpenID ones may have a different behavior, I do not know). Try it (open an incognito window, log in at any site, then visit another site that you have an account on). The behavior the OP is describing is probably anomalous although we don't have quite enough info to go on and I don't know how OpenID logins behave. – Jason C May 9 '17 at 14:49
  • @JRobert When you visit SO now, while already logged in to the other sites, if you try to log in there, what happens? Also if you try the steps here does it fix it? – Jason C May 9 '17 at 14:52
  • @Jason OP refuse to log in again, that's the whole point here. – Shadow The Princess Wizard May 9 '17 at 14:56
  • @ShadowWizard The confusion is justified, especially given that there is at least one login method (Google) that behaves as the OP expects, which means to me that others could behave the same. Also it's possible that OpenID ones are universal across *.stackexchange.com domains, which is another reason a user could be legitimately confused. There could be no problem here, but you're being prematurely critical. All confusion has a root cause, getting to the bottom of it is always important. – Jason C May 9 '17 at 14:59
  • @JRobert I notice you also have an account on SU. Does the same thing happen when you visit superuser.com? – Jason C May 9 '17 at 15:00
  • @jason: I just visited there, and yes, it did. – JRobert May 9 '17 at 15:08
  • 1
    @Shadowwizard: Isn't 'refuse' is a bit strong? Good debugging/investigating kind of demands not walking all over the evidence. – JRobert May 9 '17 at 15:08
  • @JRobert might be and sorry about that, but you didn't reply to my initial request and ignored my further attempts asking you to simply log in, never mentioned you avoided it for debugging reasons. Cheers! – Shadow The Princess Wizard May 9 '17 at 17:47
1

As far as I can tell, what happened here is that somehow you lost your login credentials on Stack Overflow only, for example I was able to reproduce it by deleting the cookies for Stack Overflow. In your case maybe some extension deleted your cookies. Maybe they expired. Or any other reason.

So when this happens, you are left logged out of one site, while logged in to all other sites.

This is not a bug, just log in again to Stack Overflow and when you will visit again, you will be logged in automatically again.

  • 2
    I've re-logged in to SO and for the moment it seems to persist; SU still thinks I'm a stranger. So I'll accept this as the explanation. Thank you. – JRobert May 9 '17 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .